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PROXY Pro overview

Thank you for selecting PROXY™ Pro remote desktop solutions.

PROXY Pro remote desktop solutions provide professional features that enable helpdesk
technicians, network administrators, IT managers, and software trainers to deliver
professional remote support for a fraction of the cost of hosted solutions.

Some selected features include:

€ Remote Access: Reach anyone, anywhere, anytime using firewall- and NAT-friendly
remote control connections.

€ Remote Control: Diagnose and resolve support issues without having to physically
visit remote computer.

€ Remote Management: Repair remote computers and make configuration changes in
real-time and without disturbing currently logged-on user.

4 Collaboration: Enable two or more technicians to work on the same remote computer
at the same time using chat, screen-sharing and easy-to-pass remote support.

NOTE: Before you use PROXY Pro remote desktop solutions, you should be familiar with
basic network concepts, such as protocols, encryption, IP addresses, ports, and subnets.

To learn more about PROXY Pro remote desktop solutions, see:
"What's New"

"PROXY Pro solutions"

"PROXY Pro applications"

"PROXY Pro technologies"

"PROXY Pro services"

"PROXY Pro connection types"

"PROXY Pro security features"

"PROXY Pro networking features"

® 6 6 O O 6 0 0 o

"PROXY Pro documentation and technical support"
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What’s New in PROXY Pro 8.10

PROXY Pro 8.10 introduces the following new features and capabilities:

¢ Host on Demand: New type of Host that can be launched from the Share My
Desktop button on the Web Console landing page. Enables the desktop of any internet-
accessible machine to be shared instantly. No local or network administrative privileges
are required, and no reboot is necessary to run this new Host type. This is now available
for both Windows and Macintosh platforms. (see PROXY Pro Web Console Operating
Guide)

& UAC Elevation (HOD Pin): Master user can elevate Host on Demand process to
high privilege level by providing administrator credentials to HOD remote desktop. This is
now known as “Pinning” the HOD and will allow the HOD to survive logouts/reboots until
explicitly exited. A Windows HOD instance will now launch as Pinned if the user has the
necessary rights. (see PROXY Pro Web Console Operating Guide)

& View/Edit Host Settings from Web Console: Host settings for any Host connected
to the Gateway can be viewed and/or edited by Account Users with appropriate
credentials through the Web Console. No connection window to Host desktop required
(see PROXY Pro Web Console Operating Guide)

& WebSocket Transport (WS, WSS): In addition to the UDP, TCP and SSL transports
already available, the Gateway Server now supports WebSocket (binary WebSocket over
HTTP) and Secure WebSocket (binary WebSocket over HTTPS) transports to facilitate
connections through corporate firewalls (see PROXY Pro Gateway Guide)

¢ More Host Grouping Rules: Additional grouping rules have been added to allow for
more flexibility in creating custom collections of Hosts, especially when considering your
AD (see PROXY Pro Gateway Guide)

& Support for LDAPS: Encryption of connections between the PROXY Pro Gateway
and the domain controller(s) when doing Active Directory lookups.

& Web Console support for Safari, Chrome and Firefox: Web Console now supports
Safari, Chrome and Firefox web browsers, in addition to Internet Explorer; helper apps
may be required to enable Remote Desktop and other features (see PROXY Pro Web
Console Installation Guide)

& Expanded Search for Recordings: Web Console now provides a more robust
search mechanism for identifying records on a particular Gateway.

& Master Support for Selecting a Specific Monitor for View: Both the installed
Master and ClickOnce connection windows now have the ability to view either the entire
remote desktop or to “zoom in” on just a single monitor of that remote desktop.

€ ClickOnce Connection Window can Suppress Host Mouse and Keyboard: This
mirrors the functionality previously available only with the installed Master.

€ Built-in Utility to Clear the Windows ClickOnce Cache: The Windows operating
system does not provide a convenient way to do this. We have now built this functionality
into the Web Console itself.

& Most Recent OpenSSL Library: In order to provide the most secure SSL experience
possible, the most recent (as of this release) OpenSSL library has been integrated.

Hotfix releases will be made available as needed to provide even newer libraries as they
become available.
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4 Automatic Recording: When this feature is enabled, all specified live Master
connections to Hosts for remote control will be recorded. This is configurable in the Web
Console.

& Official Method and Support for Web Console Graphics Customization:
Customization of the Web Console landing page and colors are now easier to put in
place and will be maintained when the software is upgraded.

What’s New in PROXY Pro 8.0

€ Web Console: A new server-side application that enables browser-based access to
the Gateway Server for configuration and administration. If Private Cloud Edition key is
present, Web Console will also be enabled for Remote Desktop feature (see PROXY Pro
Web Console Operating Guide)

& “Click Once” Web Desktop: Ability to generate a window to a remote desktop
directly from the Web Console (Master not required). No administrative rights needed and
no reboot required. Private Cloud Edition key required for activation (see PROXY Pro
Web Console Operating Guide)

& Kernel-mode Screen Capture driver: The kernel-mode screen capture driver is now
available for Windows 7, Vista and Windows 2008 Server. In many situations, the kernel-
mode screen capture driver will outperform the default user-mode screen capture driver
(see PROXY Pro Host Guide)

€ Input Suppression: Ability to turn off keyboard and mouse input on the remote
desktop machine for Windows 7, Vista and Windows 2008 Server (see PROXY Pro
Master Guide)

€ Address Bindings: Ability to bind the SSL and TCP network protocols to all
addresses or to select specific addresses on the Gateway Server (see PROXY Pro
Gateway Administrator Guide)

& Concurrent User License Mode: In this mode, the Gateway will monitor the number
of simultaneous Gateway users according to account type (Administrative, Master,
Personal) (see PROXY Pro Web Console Operating Guide)

€ Inactivity Timeouts: To free up concurrent user licenses when users are connected
to the Gateway but not active, Web Console, Master and Gateway Administrator will be
automatically disconnected from the Gateway, and input control will be automatically
released from Remote Desktop or Connection Window (see PROXY Pro Gateway
Administrator Guide)

€& Automatic Grouping of Hosts: Ability to configure Hosts to automatically report to
custom Gateway group(s) according to custom or generic rules (see PROXY Pro
Gateway Administrator Guide)

& Virtual Desktop support: Enables virtual desktop images generated in
environments such as Citrix XenDesktop to include Hosts, and to have the Hosts report
to Gateway until the desktop image is discarded (see PROXY Pro Host Guide)

What’s New in PROXY Pro 7.0

¢ Windows 7 support: PROXY Pro 7.0 provides full support (remote access, remote
control, remote management) for Windows 7 computers, including 32- and 64-bit
platforms.

¢ Windows Server 2008 R2 support: PROXY Pro 7.0 provides full support (remote
access, remote control, remote management) for Windows Server 2008 R2 computers
(64-bit platforms only).
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€ Mac, Linux support: PROXY Pro 7.0 provides support (remote access, remote
control) for Macintosh and Linux computers running VNC server software (standard on
Macs).

¢ Wake-on-LAN support: PROXY Pro 7.0 includes ability to turn on remote computers
that are configured to listen for Wake-on-LAN signal.

¢ Remote Power Scheme management: PROXY Pro 7.0 includes new remote
management tools that allows Master user to view and change power scheme settings on
remote computers.

€ Screen Recording Playback via URL: PROXY Pro 7.0 includes ability for Master to
playback a PROXY Pro screen recording from a standard web server over HTTP or
HTTPS.

& RDP compatibility: If a remote computer is hosting an active RDP session, PROXY
Pro 7.0 Host will capture and provide input control to the RDP session.

€ Active Directory integration: PROXY Pro 7.0 Deployment Tool can now be used to
discover computers and OUs in Active Directory domains, install new PROXY Pro
software, upgrade existing software, and/or push configuration changes to existing
software.
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PROXY Pro solutions

Proxy Networks provides three solutions for remote desktop support:

PROXY Pro Workstation Edition

PROXY Pro Workstation Edition is an easy-to-use remote desktop solution that uses
simple peer-to-peer connections between helpdesk technicians and end-user remote
computers. It is ideally suited for smaller companies and workgroups in which the number
of remote computers being supported is small and manageable.

PROXY Pro Gateway Edition

PROXY Pro Gateway Edition is an enterprise-class remote desktop solution that uses a
robust, scalable server to establish and maintain a secure network of connections to end-
user machines. It leverages centralized administration, security and network access to
simplify and automate the creation, management, and monitoring of this “network within a
network”. PROXY Pro Gateway Edition is ideally suited for enterprises and corporate
workgroups with large numbers of remote computers, multiple domains and/or
employees with remote computers outside the network.

PROXY Pro Private Cloud Edition

PROXY Pro Private Cloud Edition is a web-enabled version of the Gateway Edition, and
includes Remote Desktop for on-demand access to remote desktops in place of the
installed Master application.
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PROXY Pro applications

The PROXY Pro remote desktop solutions include some or all of the following
applications:

PROXY Pro PROXY Pro ES\%Z Pro

PROXY Pro Components Workstation Gateway
" . Cloud
Edition Edition "
Edition

PROXY Pro Host Yes Yes Yes
PROXY Pro Terminal Services Host No Yes Yes
PROXY Pro VDI Host No Yes Yes
PROXY Pro Host on Demand No Yes Yes
PROXY Pro Master Yes Yes Yes
PROXY Pro Gateway No Yes Yes
PROXY Pro Web Console No Yes Yes
PROXY Pro Remote Desktop No No Yes
PROXY Pro Deployment Tool Yes Yes Yes
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PROXY Pro Host

PROXY Pro Host runs as a Windows service on the machine on which it is installed, and
supports both peer-to-peer connections as well as Gateway-managed connections. By
installing PROXY Pro Host on a computer in your network, you can:

€ Allow technicians to make peer-to-peer remote control connections to the machine,
whether someone is there or not. Each Host manages its own security settings and
access rights.

€ Allow or force technicians to make Gateway-managed remote support connections to
the machine through a central server (PROXY Pro Gateway), which will automatically
enforce security settings and access rights according to policies set at the server.

The PROXY Pro Host requires a Host license key.

For more information about configuring and operating PROXY Pro Host, please see the
PROXY Pro Host Guide.
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PROXY Pro Terminal Services Host

PROXY Pro Terminal Services Host is a server-side version of the PROXY Pro Host
designed to support Terminal Services sessions.

The Terminal Services Host, also known as the root Host, runs on the Terminal Server
(such as those from Citrix or Microsoft), and is configured to support one or more
concurrent Terminal Services sessions. Each time the Terminal Server generates a new
Terminal Services session, the Terminal Services Host injects a copy of the Host into the
session. The session Host will include instructions for reporting to one or more Gateways.
When the TS session is discarded, the TS Host session will also be discarded and will be
automatically removed from the Gateway(s).

The PROXY Pro Terminal Services Host requires a special Host license key that will
specify the maximum number of concurrent Terminal Services sessions that can be
supported on that Terminal Server.

For more information about configuring and operating PROXY Pro Terminal Services
Host, please see the PROXY Pro Host Guide.
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PROXY Pro VDI Host

PROXY Pro Virtual Desktop Image Host is a special version of the PROXY Pro Host
designed to support the transient nature of virtual desktops.

The VDI Host can be included as part of a virtual desktop template; when one or more
virtual desktop sessions are generated using this template (often to create a pool of
virtual desktop images), the sessions will include a Host with all the features of the
installed Host but not the permanent nature. When the virtual desktop session is
discarded, the Host will also be discarded and will be removed automatically from the
Gateway(s).

The PROXY Pro VDI Host requires a special Host license key that will specify the
maximum number of concurrent VDI sessions that can be supported in the virtual
desktop environment.

For more information about configuring and operating PROXY Pro VDI Host, please see
the PROXY Pro Host Guide.
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PROXY Pro Host on Demand

PROXY Pro Host on Demand (HoD) is a streamlined version of the Host that can be
launched from the Share My Desktop button on the Web Console landing page. It
enables the desktop of any internet-accessible machine to be shared instantly. No local
or network administrative privileges are required, and no reboot is necessary to run this
special Host type.

The PROXY Pro Host on Demand is hosted by the Gateway Server and is enabled by a
special license key installed in the Gateway Server. When enabled, the Share My
Desktop button on the Web Console landing page will light up, and end users will be able
to install as many instances of HoD as they like. Each instance will report back to and be
accessible through the Gateway Server from which it was served.

For more information about configuring and operating PROXY Pro Host on Demand,
please see the PROXY Pro Web Console Operating Guide.
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PROXY Pro Master

PROXY Pro Master is a console application that technicians can use to establish remote
support connections to one or more Host computers. With PROXY Pro Master, you can:

¢ Make one or more peer-to-peer remote support connections to Host computers in
your network.

4 Connect to PROXY Pro Gateway and make one or more Gateway-managed remote
support connections to Host computers from a directory of available Hosts.

View the entire screen of the remote computer.
Take complete control of a Host computer using the local keyboard and mouse.
Share control of the Host computer with its end-user.

Passively monitor the Host computer without exercising control.

* 6 6 o o

Use the clipboard transfer feature to transfer portions of text, bitmaps, and other
objects between your Host and Master computers.

€ Use the PROXY Pro file transfer feature to copy files between your Host and Master
computers.

€ Use the PROXY Pro remote printing feature to print locally from applications running
on a remote computer.

€ Record screen activity on the Host and play back the recording on the Master.
€ Chat with end-user and any other technicians connected to the same Host.

For more information about configuring and operating PROXY Pro Master, please see
the PROXY Pro Master Guide.
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PROXY Pro Gateway

PROXY Pro Gateway is an enterprise class server, which provides centralized
administration, security and management for a network of remote support connections to
Host computers in your environment.

With PROXY Pro Gateway configured as the hub of your remote support network, you
can:

& Organize large numbers of Host computers into logical groups for easier access and
management.

& Reach remote computers outside the network, behind firewalls or NAT-devices.
& Utilize SSL for certificate-based authentication.

€ Create custom access rights policies and apply them to groups to make configuration
changes more quickly and efficiently.

€ Monitor and manage remote support activity in real-time.

& Keep detailed records of all remote support activity in your network with
comprehensive audit logs.

€ Record screen activity on one or more remote computers simultaneously using
PROXY Pro Gateway’s screen recording feature.

PROXY Pro Gateway includes the PROXY Pro Gateway Administrator, a tool for
configuring the Gateway and for monitoring, managing and auditing remote support
activity in your network.

For more information about configuring and operating PROXY Pro Gateway, please see
the PROXY Pro Gateway Server Guide.
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PROXY Pro Web Console

PROXY Pro Web Console is a web application that provides browser-based access to
the PROXY Pro Gateway Server for administration and configuration. It is effectively a
web-based version of the Gateway Administrator.

The Web Console also includes an optional feature called the Remote Desktop, which
allows on-demand access to remote desktops directly from the Web Console. It is
effectively a web-based version of the Master application.

With PROXY Pro Web Console:

€ Administrators can access and edit all the configuration information on the Gateway
Server, including Groups, Security, Permissions, etc. The Administrative web account
can be used in conjunction with or instead of the standalone Gateway Administrator
application.

€ If the Remote Desktop is enabled, Helpdesk technicians can view and access remote
desktops connected to the Gateway.

For more information about configuring and operating PROXY Pro Web Console, please
see the PROXY Pro Web Console Operating Guide.

For more information about installing PROXY Pro Web Console, please see the PROXY
Pro Web Console Installation Guide.
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PROXY Pro Remote Desktop

The Remote Desktop is an optional feature of the Web Console, which allows on-demand
access to remote desktops directly from the Web Console. It is effectively a web-based
version of the Master application.

With PROXY Pro Remote Desktop:

€ Helpdesk technicians can view and access remote desktops connected to the
Gateway.

¢ Employees can view and access their computers at work, even if they are on the
road or at home. The Personal web account offers convenient, secure, reliable alternative
to VPN.

To enable the Remote Desktop, a special key must be entered into the Gateway Server.

For more information about configuring and operating PROXY Pro Remote Desktop,
please see the PROXY Pro Web Console Operating Guide.
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PROXY Pro Deployment Tool

PROXY Pro Deployment Tool is an easy-to-use software distribution utility that
automates the deployment and installation of PROXY Pro applications to remote
computers in your network.

With PROXY Pro Deployment Tool, you can:

€ Automatically deploy an image of PROXY Pro Host, Master or Gateway to one or
more computers or groups of computers in your network and avoid manual effort of going
to each machine.

& Create an image of PROXY Pro Host, Master or Gateway with custom configuration
options that can be mass deployed on large numbers of computers in your environment.

& Create and push custom configuration options for PROXY Pro Host, Master or
Gateway, without having to reinstall underlying software.

€ Use Active Directory to find remote computers and push software and configuration
settings to them.

For more information about configuring and operating PROXY Pro Deployment Tool,
please see the PROXY Pro Deployment Tool Guide.
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PROXY Pro technologies

PROXY Pro remote desktop solutions utilize highly optimized technologies to deliver
speed, performance and reliability, including:

& Highly efficient screen capture algorithms. PROXY Pro utilizes two kinds of
screen capture technology:

+ Kernel-mode screen capture. This technology utilizes the PROXY Pro mirror
driver, which reproduces graphics drawing commands from the remote Host
on the PROXY Pro Master user’s screen quickly and efficiently.

+ User-mode screen capture. This technology works without a mirror driver
and is designed to adjust automatically to the amount of CPU and bandwidth
available on the remote Host machine.

€ Streamlined communication protocol. The PROXY Pro protocol has been honed
over 15 years for efficiency and reliability when sending screen capture data to another
computer in real-time and receiving keyboard/mouse input.

Using these technologies, PROXY Pro remote support solutions enable technicians to
find and fix problems on remote computers faster and easier than ever before.
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PROXY Pro services

PROXY Pro remote desktop solutions offer technicians a number of professional-quality
services for investigating and solving problems on Host remote computers, including:

¢ Remote Control: ability to view screen activity on an end-user’s remote machine,
and with proper authorization, take control of and send keyboard/mouse inputs to the
remote machine in real-time

€& Remote Clipboard: ability to copy selected items on the screen of a remote machine
into the clipboard on the remote machine and transfer the contents to the clipboard on
the technician’s machine, and vice versa

& File Transfer: ability to drag-and-drop files or directories on the remote machine to
the technician’s machine, and vice versa

€ Host-based Chat: ability to chat with the end-user on a remote machine, and any
other technicians connected to that machine

€ Remote Printing: ability to print selected items from the remote machine to a printer
attached to the technician’s machine

€ Host Administration: ability to view and edit configuration settings of the PROXY
Pro Host installed on the remote machine

¢ Remote Management: ability to generate inventory of hardware and software assets
on remote machine, and to query and change certain system settings. See “Remote
Management features” for more information about tools available through this service.
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PROXY Pro connection types

PROXY Pro services are performed over service connections between a PROXY Pro
Master (with appropriate access rights) and a PROXY Pro Host. Service connections are
established on demand, when a PROXY Pro Master requests a service from a PROXY
Pro Host.

PROXY Pro supports several different types of remote access connections:

PROXY Pro PROXY Pro gﬁ\%g Pro

PROXY Pro Connection Types Workstation Gateway
" - Cloud
Edition Edition L
Edition

RDP session sharing Yes Yes Yes
Peer-to-peer connections Yes Yes Yes
Gateway-managed connections No Yes Yes
Firewall-friendly connections No Yes Yes
Terminal Services connections No Yes Yes
VDI connections No Yes Yes
VNC connections Yes Yes No
Host on Demand connections No Yes Yes

RDP session sharing: Follow the active session
PROXY Pro connections can be used to share an active RDP session in real-time.

If PROXY Pro Host is running on a desktop-class operating system (e.g. Windows 7),
and there is an active/connected RDP session being hosted on that computer, then the
Host will automatically capture and provide input control to that RDP session. In essence,
the Host will capture what the remote RDP session user is seeing, not what the local
physical console on that machine is showing (probably the Windows login screen).

When there is no active/connected RDP session being hosted on that computer, or if an
active/connected RDP session is stopped, the Host will automatically capture and provide
input control to the session running on the computer and being displayed on the local
console. The Host will follow the active session as it moves from RDP user back to the
local console.

Note: This feature only applies to desktop-class operating systems, which support only
one active session at a time. Server-class operating systems (e.g. Windows Server 2003,
2008 or 2012) can support multiple sessions simultaneously via Terminal Services; use
the Terminal Services support in the Host to capture and/or provide input control to one
or more sessions on server-class OS.

Peer-to-peer connections
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When a computer with PROXY Pro Master establishes a direct connection to a computer
with PROXY Pro Host, the connection that is established is a peer-to-peer connection.

By default, PROXY Pro Master searches the network for Host computers when it starts
up. Any Host computers it finds are listed on the Peer-to-Peer Hosts tab of the PROXY
Pro Master window.

Peer-to-peer connections from Master (M) to Host (H)

The dotted and solid lines, shown in above depict two different sets of peer-to-peer
connections between PROXY Pro Masters to PROXY Pro Hosts. PROXY Pro’s peer-to-
peer connections enable the following:

€ PROXY Pro Master users with proper credentials can securely access Host
computers within the network.

€ When you permit full access to a Host computer, the PROXY Pro Master user can
monitor all activity on the Host computer. In addition, PROXY Pro Master users with full
access rights can exercise complete control over that computer.

€ When the Host and Masters are in the same domain, PROXY Pro Host can be
configured to use the Microsoft Windows authentication service to check credentials of
any PROXY Pro Master users. An access control policy can allow (or deny) full or partial
access for authenticated PROXY Pro Master users to access services on a Host
computer.

Although PROXY Pro’s peer-to-peer connections provide a secure solution for remote
support, this solution is not recommended for large and/or highly distributed networks;
instead, consider using PROXY Pro Gateway for centrally managed remote support
connections.
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Gateway-managed connections

When a computer with PROXY Pro Master establishes a connection to a computer with
PROXY Pro Host through a central server (i.e. PROXY Pro Gateway), the connection
that is established is a Gateway-managed connection. In this way, the Gateway serves
as a central location for managing and monitoring connections, configuration, security
and reporting. Any Host computers found by the Gateway are listed on the Gateway Hosts
tab of the PROXY Pro Master window.

In large networks, the PROXY Pro Gateway can be configured to manage connections
with hundreds or thousands of Hosts simultaneously, enabling Masters to find and take
control of Hosts instantly.

Gateway-managed connections utilize the same strong authentication and authorization
that is available with PROXY Pro’s peer-to-peer connections. In addition, PROXY Pro
Gateway provides the following capabilities:

€ Seamless connections from Master computers to Host computers through a PROXY
Pro Gateway. To the PROXY Pro Master user, the connection appears as if it were a
peer-to-peer connection to the Host computer, even if the Host is outside the domain
and/or behind a firewall or NAT device.

€ Centralized management of access rights to remote computers in your network.
Once you configure your Host computers to report to the PROXY Pro Gateway, you can
achieve global management through a single security policy that you configure using
PROXY Pro Gateway Administrator.

€ User-based access policies. Customize and apply access policies to individual
PROXY Pro Master users or groups in your network. Allow full remote access to one or
more Host computers for some PROXY Pro Master users, while restricting access rights
for others.

¢ Comprehensive logging and auditing of all remote control activity within your network.
With this feature, you can keep records of all remote support connections.

€ Continuous screen recording. PROXY Pro Gateway allows you to record screen
activity on any remote Host. Efficient file compression makes 24x7 recording economical
and manageable.
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Gateway (G)-managed connections from Master (M) to Host (H)

Firewall-friendly connections

When PROXY Pro Master users need access to Hosts that are outside the domain,
and/or behind a firewall or NAT-device, normal peer-to-peer or Gateway-managed
connections will not work. In these cases, it is difficult to find and maintain a secure
remote support connection because of dynamic port assignments and other network
challenges.

For these situations, PROXY Pro Gateway builds special firewall-friendly connections to
these Hosts. When Hosts are outside the domain, the Hosts are programmed to
automatically initiate contact with the Gateway. The Gateway will use this initial contact to
build a firewall-friendly connection to the Host. In this way, the remote Host outside the
domain will appear just like any Host inside the domain.

Terminal Services connections

PROXY Pro provides server-side support (screen capture, input control, screen
recording) for session-based virtual desktops hosted by Terminal Services (now called
"Remote Desktop Services") on Windows Server 2003, Window Server 2008, or
Windows Server 2012. Windows Server creates and hosts the Terminal Services (TS)
sessions like virtual machines. A presentation technology using a display protocol such
as RDP from Microsoft or ICA from Citrix is typically used to remote the session display,
as well as the keyboard and mouse input, to and from an end user device (such as a thin
client computer like a Wyse terminal).

PROXY Pro allows technicians to capture (and if desired, record) the session
presentation information at the Windows Server before it is remoted to the end user
device over the RDP or ICA display protocol. PROXY Pro is able to do this by injecting a
Host instance into each server-side TS session, which in turn captures and sends
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presentation information directly to PROXY Pro Gateway for recording and/or further
transmission to a PROXY Pro Master.

Note: Because TS sessions are captured at the Windows Server (and not at the end user
device), PROXY Pro Host effectively bypasses the technology used to remote the
sessions to the end users, and will therefore be compatible with Microsoft Terminal
Services clients as well as Citrix Presentation Server (now known as XenApp) clients.

Note: PROXY Pro only supports TS sessions created on server-class Windows operating
systems such as Windows Server 2003, Windows Server 2008, and Windows Server
2012.

See Terminal Services tab in PROXY Pro Host Guide for more specific configuration
and setup information.

Root Host for TS sessions

The “Terminal Services” (now called "Remote Desktop Services") feature of Windows
Server editions allows multiple virtual desktop sessions to be active simultaneously.
PROXY Pro provides remote access and remote control to these sessions on the
Windows Server by injecting a separate instance of the Host service into every new TS
session. A special version of the Host called the "root" Host must be loaded on the TS
server (a "root" Host is a standard Host with a special TS license key - see About tab in
the PROXY Pro Host Guide for more information); it will automatically spawn new Host
instances every time a new TS session is created.

Transient Hosts

Each TS instance of the Host will have its own unique workstationID and must be
configured to report to a Gateway. When it first reports to the Gateway Server, it will be
automatically managed and added to the “All Hosts” group. The TS Hosts are considered
transient, since they go away when the TS user logs out of his/her session. In order to
keep track of transient TS Hosts, the PROXY Pro Gateway will create a new Group
called "Terminal Services on <Servername>", and automatically insert transient Hosts
into this Group. They are automatically deleted from the Gateway when the TS session
ends. The main purpose of this Group is to allow security to be assigned to the Hosts and
TS sessions that belong to this Group, and to provide the correct and appropriate access
to the TS-based Host instances.

Note: PROXY Pro Host for Terminal Services works on Windows Server editions, and
requires a Gateway Server v6.10 or later.

Recording TS Hosts

Recordings are normally deleted from the Gateway database when their associated
workstation record is deleted. Transient TS Host workstation records are automatically
deleted from the Gateway when the TS user logs out of his/her session. However, to
prevent recordings of TS Hosts from being automatically deleted when the TS session
ends, the TS session recordings are reassigned to an artificial permanent workstation
record called "Recordings on <Servername>". All recordings of all TS Hosts on a given
TS server will be associated with this one record. This approach has the following
advantages:

€ Recordings are not orphaned

4 All recordings can be kept in one place,

€ TS recordings can be kept separate from console (root Host) recordings
.

Security can be configured separately for each recording.
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Limitations of TS Hosts

Due to technical limitations and the nature of Terminal Services sessions, the following
Host features are not supported.

€ Remote printing
¢ Keyboard and mouse suppression (requires kernel-based input stack intercept)
€ Screen blanking (requires kernel-based support and physical display to blank)

& Peer-to-peer connections: all protocols are disabled, and the only connections that
can be made are through a configured Gateway Server

& Kernel-mode screen capture (even on Windows Server 2003, requires kernel-mode
display support)

VDI connections

PROXY Pro provides a special version of the Host to run inside of virtual desktop images
(VDI) created from virtual desktop templates in environments such as Citrix XenDesktop.
If the regular Host is specified in the template, then the Host will automatically be
installed when the virtual desktops are created using this template.

This works fine with Peer-to-Peer connections to the Host in the VDI, but has some
complications when the Host is configured to report to one or more Gateway Servers:

€ The GWS must be configured to “automatically manage new Hosts” to have the Host
become available without any manual intervention.

& If the virtual desktop is discarded when the user logs out, the Host is effectively
destroyed as well, but the Gateway doesn’t know this. The Host remains known to the
Gateway (and managed, using a Managed Hosts license) until it is manually cleaned up
by an administrator, or until the Delete Hosts older than feature kicks in and deletes it.
(But note that setting is measured in days, default is set to 120, and setting that to a low
value runs the risk of deleting conventional installed Hosts that are simply offline for a
while.)

To address both of these problems, the Gateway Server supports a special version of the
Host for VDI that is “transient” in nature (similar to a Terminal Services Host session);
when the VDI Host is specified in the template, the following will occur:

€ A new group, “Transient VDI Hosts”, is automatically created at the Gateway when a
Host of this type first reports. All Hosts of this type are automatically managed
(independent of the “automatically manage Hosts” setting), and are added to this group.

¢ If the virtual desktop is discarded when the user logs out, the VDI Host, because of
its transient nature, will automatically be disconnected and removed from the Gateway,
freeing up a Managed Host license.

€ Similar to what happens when recording TS Host sessions, a new pseudo-host,
“Recordings of Transient VDI Hosts”, is created when any of these Hosts is recorded.
The recording of the VDI Host is associated with this pseudo-Host instead of with the
Host workstation, and will remain in there even after the virtual desktop is discarded

& If the Gateway is in Managed Hosts licensing mode, a new license key that limits the
maximum number of VDI Hosts that can be connected to the Gateway concurrently is
required
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VNC connections

PROXY Pro provides remote access and remote control to computers running a standard
version of VNC (Virtual Network Computing) server. A VNC server is built into recent
versions of the Mac OS X operating system from Apple Computer, and is also available
on many versions of the Linux operating system. When properly configured, technicians
can use PROXY Pro Master on Windows to connect to and take control of Mac and Linux
computers running standard VNC server.

PROXY Pro currently supports peer-to-peer connections to VNC servers.

See "VNC Hosts" in the PROXY Pro Master Guide for more information on configuring
and connecting to VNC servers.

Supported Platforms
PROXY Pro Master can interoperate with standard VNC servers on following platforms:
¢ Mac OS X

€ Linux (any) running VNC server

Host on Demand connections

PROXY Pro provides remote access and remote control to computers running a
streamlined version of the Host called Host on Demand (HoD). The Host on Demand can
be accessed from the Web Console landing page by any internet-accessible machine
and will enable end user to share his/her desktop instantly through the Gateway Server.

Supported Web Browsers

PROXY Pro Host on Demand is supported on following web browsers:
¢ Internet Explorer

& Firefox
¢ Chrome
*

Safari

Note that helper apps may be required to run certain features of the Web Console for
browsers other than Internet Explorer.

See the PROXY Pro Web Console Operating Guide for more information on enabling and
configuring Host on Demand.
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PROXY Pro security features

One of the most valuable aspects of PROXY Pro remote desktop solutions is the ability to
create and enforce fine-grained access control policies, and to easily modify them to
reflect changes in your organization.

PROXY Pro security features include the following:
€ “Authentication”

€ “Authorization”
¢ “Auditing”
*

“Encryption”

Authentication

In the PROXY Pro model, PROXY Pro applications that request information and services
are considered “clients” and those that provide information and services are considered
“servers”. For example, the PROXY Pro Master is considered a client when it connects to
and requests a list of Hosts from a PROXY Pro Gateway. In turn, the PROXY Pro
Gateway is considered a client when it connects to and requests information from a
PROXY Pro Host in the same domain.

Connection Client Server

Peer-to-peer Master Host

Gateway-managed (Gateway & Host are in same domain)

€ Master-Gateway relationship Master Gateway

@ ---Gateway-Host relationship Gateway Host

Gateway-managed (Gateway & Host are not in same domain)

¢ Master-Gateway relationship Master Gateway

¢ Gateway-Host relationship Host Gateway

When PROXY Pro Host is not in the same domain as the Gateway, the relationship is
automatically reversed: The Host is programmed to be the client and will reach out to the
Gateway (see “Firewall-friendly connections” for more information about PROXY Pro
firewall-friendly connections).

To guarantee security in the PROXY Pro environment, it is critical that PROXY Pro
components acting as servers validate the credentials of users of PROXY Pro
components acting as clients before they provide access or data. The burden is placed
on the client to authenticate itself to the server. PROXY Pro implements two types of
authentication to support this:
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€ ‘“Ildentity Authentication”
€ “Endpoint Authentication”

Identity Authentication

In general, this operation answers the following security question: How does the server
know who the client is? A PROXY Pro application acting as a server will not provide
access or information to any PROXY Pro application acting as a client until it can validate
that client’s identity. PROXY Pro provides the server three different methods of
authenticating the identity of the PROXY Pro client:

) Windows Simple Shared-
Connection S secret
authentication password
password
Peer-to-peer Yes Yes No
Gateway-managed (Gateway & Host are in same domain)
L 4 Master-Gateway Yes No No
relationship
€ Gateway-Host relationship Yes No Yes
Gateway-managed (Gateway & Host are not in same domain)
L 4 Master-Gateway Yes No No
relationship
€ Gateway-Host relationship No No Yes

¢ Windows authentication: By default, a PROXY Pro application acting as a server
uses Windows authentication to check the Windows credentials of the client application:

+ The Host will check the Windows credentials of the PROXY Pro Master user
in the case of a peer-to-peer connection;

+ The Gateway will check the Windows credentials of the PROXY Pro Master
users in the Master-Gateway part of a Gateway-managed connection;

+ The Host will check the Windows credentials of the user logged into the
Gateway in the Gateway-Host part of a Gateway-managed connection (when
Host and Gateway are in the same domain).

NOTE: If Host and Gateway are not in the same domain, Windows authentication will not
usually be available. In that case, Host and Gateway will rely on Shared secret password.

& Simple password: Prior to making a connection, a custom password can be created
on the Security tab of the Host and shared with PROXY Pro Master user. This feature
permits the PROXY Pro Master user to connect to a Host without regard to PROXY Pro
Master user's Windows credentials.

NOTE: Simple password applies only to peer-to-peer connections.
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€ Shared secret password: In the case that the Host does not share a domain
relationship with the PROXY Pro Gateway, or if the Host is outside of the network and
cannot contact its domain controller, Windows authentication will not usually be available.
Behind the scenes, the PROXY Pro Gateway and the Host will exchange a 16-byte
secret password that only they will know. As a result, in all subsequent connections, the
PROXY Pro Gateway and Host will have some measure of authentication when they are
not in the same domain. If the Host belongs to the same domain as the PROXY Pro
Gateway, and the Host is able to reach a domain controller, the Host will prefer to do
Windows authentication instead of shared secret password.

Endpoint Authentication

In general, this operation answers the following security question: How does the client
know it is connected to the right server? Identity authentication doesn't prohibit the client
from being fooled into connecting to a different server. In order to guarantee that
information and services are coming from the expected server, PROXY Pro supports
endpoint authentication using Secure Sockets Layer (SSL).

& SSL certificate authentication (PROXY Pro Gateway only): PROXY Pro has
implemented server endpoint authentication using SSL, which means the client will
request and validate a certificate from the server before providing requested information
or services. This ensures the client has connected to the right server. The following list
describes where SSL authentication can and cannot be used:

+ Peer-to-peer connections: SSL authentication is not available for peer-to-peer
connections. This would require each Host (acting as server) to carry its own
certificate, which would be unwieldy and costly to manage.

+ Gateway-managed connections (Host is in same domain as Gateway): SSL
authentication is available between Master (acting as client) and Gateway (acting
as server). Before connecting, the Master will request and validate a certificate
from the Gateway. In general, SSL between Master and Gateway would be most
useful when the Master is outside the LAN and/or coming in through a corporate
firewall to access the Gateway.

NOTE: SSL authentication is not available between the Gateway (acting as client) and the
Host (acting as server). As in peer-to-peer connections, this would require each Host to
carry its own certificate. SSL connections to the Host are generally not required because
the Host can be configured to use a reverse connection to the Gateway, which can use
SSL.

+ Gateway-managed connections (Host is not in same domain as Gateway):
When the Host is outside the LAN and/or behind a firewall or NAT-device, the Host
is the client and has responsibility to contact the Gateway. SSL authentication is
supported and would be appropriate to ensure that the Host is connecting to the
right Gateway. The Host will validate the Gateway Server certificate before
accepting the connection, ensuring that the Host is communicating with the correct
Gateway Server.

In summary, SSL can be used by the Master to authenticate a Gateway, and by a Host to
authenticate a Gateway when the Host is outside the domain:

Connection Client Server SSL
Supported
Peer-to-peer Master Host No
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Gateway-managed (Master & Host are in same domain)

€ Master-Gateway relationship Master Gateway Yes

€ Gateway-Host relationship Gateway Host No

Gateway-managed (Master & Host are not in same domain)

€ Master-Gateway relationship Master Gateway Yes

€ Gateway-Host relationship Host Gateway Yes

Authorization

One of the strongest features of PROXY Pro remote support solutions is the fine-grained
access control. For example, to perform remote support, you must have the following:

& Proper credentials with which to connect to the Host computer
€ Authorization to view the Host computer remotely
€ Authorization to control the Host computer remotely

Your credentials are established when you connect to a Host computer (or to a PROXY
Pro Gateway), and persist until the connection breaks. You can configure access and
other rights directly on the Host computer for peer-to-peer connections. Alternatively, you
can use the PROXY Pro Gateway to enforce custom access rights policies on PROXY
Pro Master users, roles, or groups for Gateway-managed connections.

Auditing

PROXY Pro Gateway provides a detailed log of connection attempts, actions and other
activities that occur in the network. This log is also customizable and exportable to 3rd
party reporting products using standard formats.

PROXY Pro Gateway also features screen recording for any Host in contact with a
Gateway, whether or not there is an active remote support connection. With this feature,
PROXY Pro Master users can keep a visual log of activities going on in the network.

Encryption

To ensure privacy of communications between PROXY Pro applications across the
network, PROXY Pro provides advanced encryption using Advanced Encryption
Standard (AES) block ciphers and Secure Hashing Algorithm (SHA-1). This protection
will be automatic and transparent every time two PROXY Pro 5.20 components or later
are communicating with each other.

By default, PROXY Pro uses AES 256-bit encryption, however other encryption options
can be set, including:

€ AES encryption (256-bit key) with SHA1 hash
€ AES encryption (192-bit key) with SHA1 hash
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€ AES encryption (128-bit key) with SHA1 hash
& Triple-DES (3DES) encryption (192-bit key) with SHA1 hash
€ RC4-compatible encryption (128-bit key) with MD5 hash

NOTE: PROXY Pro 5.10 applications and older support only RC4 encryption; thus, this would be
the encryption option negotiated between a PROXY Pro 5.20 or later application (e.g. PROXY
Pro Master) and PROXY Pro 5.10 application (e.g. PROXY Pro Host).

Order of precedence

When two PROXY Pro components have different encryption options set, the first
encryption choice in common between the two is used (going down the list in order), with
preference set as follows:

& Preference set by the Host, when the Gateway requests connection to the Host

& Preference set by the Gateway, when the Master requests connection to a Host
through the Gateway
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PROXY Pro networking features

PROXY Pro remote desktop solutions support several standard transport protocols for
computer-to-computer communication, and two types of network addressing schemas.

Network protocols

PROXY Pro products support most of the standard networking and transport protocols,
including:

& |P: IP is a general-purpose protocol supported on a wide variety of networks and
servers. PROXY Pro components support communications using either the TCP or UDP
transport protocols running over IP. PROXY Pro has established the following standard
ports for use with either TCP or UDP:

+ PROXY Pro Host listens on port 1505 by default
+ PROXY Pro Gateway listens on port 2303 by default

€ SSL: The SSL protocol runs above TCP/IP and below higher-level protocols such as
HTTP or IMAP. Using TCP/IP on behalf of the higher-level protocols allows an SSL-
enabled server to authenticate itself to an SSL-enabled client, and then establish an
encrypted connection between the remote computers.

+ By default, PROXY Pro Gateway listens for incoming SSL connections on port
443, but it might be appropriate to note that this can be easily changed to avoid
conflicts with other server software installed on the same machine.

+ The PROXY Pro Gateway now ships with a Gateway Certificate Manager to
manage the creation and/or selection of a SSL security certificate for the PROXY
Pro Gateway.

€ WebSocket: The WebSocket protocol runs above HTTP or HTTPS. This provides a
web-proxy friendly and firewall-friendly transport. Only the Gateway Server accepts
WebSocket connections; the Host can report to the Gateway this way, and the Master
and other client software can connect to the Gateway this way.

+ The PROXY Pro Gateway listens for incoming Secure WebSocket connections
(WSS) when SSL is enabled, and uses the same port. It listens for WebSocket
connections (WS) when TCP is enabled, and uses the same port.

Network addressing schemas

The PROXY Pro UDP, TCP and SSL transport protocols support the use of either IPv4
(32-bit) or IPv6 (128-bit) addresses.

Wake-on-LAN support

PROXY Pro can be used to "wake-up" remote computers that have been shut down
(sleeping, hibernating, or soft off; i.e., ACPI state G1 or G2), with power reserved for the
network card, but not disconnected from its power source. The network card listens for a
specific packet containing its MAC address, called the magic packet ,that is broadcast on
the subnet or LAN.
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In order to execute this feature, both the MAC address and the last known IP address of
the remote computer must be known. Since the PROXY Pro Gateway knows both of
these pieces of information, it is in a position to send the Wake-on-LAN signal.

PROXY Pro implements this functionality in Gateway-managed connections in two ways:

& Implicit Wake-on-LAN: If Gateway is asked to make a connection to a remote
computer and the last status indicates that the remote computer is "Offline", the Gateway
will automatically attempt to wake up the remote computer by sending appropriately
configured WOL signal. If the remote computer was shut down in a state capable of
receiving WOL signal, it will wake up and report to the Gateway and a connection will be
established.

& Explicit Wake-on-LAN: A network administrator, using either PROXY Pro Master or
PROXY Pro Gateway Administrator, can attempt to wake up a remote computer by
explicitly sending the WOL signal to that machine. If the remote computer was shut down
in a state capable of receiving WOL signal, it will wake up and report to the Gateway and
a connection will be established.

See "Send Wake-on-LAN Signal" in the Proxy Pro Master Guide for more information.
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PROXY Pro documentation and technical support
Each of the four PROXY Pro components has its own guide:

PROXY Pro Master Guide

PROXY Pro Host Guide

PROXY Pro Gateway Server Guide

PROXY Pro Web Console Operating Guide

PROXY Pro Web Console Installation Guide

PROXY Pro Deployment Tool Guide

® 6 O 0 0 o

For more information about PROXY Pro documentation and technical support, see:
€ "Typographical conventions"

€ "Technical support options"

Typographical conventions in documentation

PROXY Pro documentation uses typographical conventions to convey different types of
information.

Computer text

Filenames, directory names, account names, IP addresses, URLs, commands, and file
listings appear in a plain fixed-width font:

You can use the default domain user account named ‘RemoteControlGateway’.

In examples, text that you type literally is shown in a bold font.
To run the installation program, type installme in the command line.

Screen interaction
Text related to the user interface appears in bold sans serif type.
Enter your username in the Login field and click OK.

Menu commands are presented as the name of the menu, followed by the > sign and the
name of the command. If a menu item opens a submenu, the complete menu path is
given.

Choose Edit > Cut.
Choose Edit > Paste As... > Text.

Variable text

Variable text that you must replace with your own information appears in a fixed-width
font in italics. For example, you would enter your name and password in place of
YourName and YourPassword in the following interaction.
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Enter your name: YourName
Password: YourPassword

File names and computer text can also be displayed in italics to indicate that you should
replace the values shown with values appropriate for your enterprise.

Key names

Names of keyboard keys appear in SMALL CAPS. When you need to press two or more
keys simultaneously, the key names are joined by a + sign:

Press RETURN.
Press CTRL+ALT+DEL.

Technical support options

If you have any problems installing or using the PROXY Pro remote support products,
information and support resources are available to help:

This manual and the Release Notes may contain the information you need to solve
your problem. Please re-read the relevant sections. You may find a solution you
overlooked.

Our technical support staff can be contacted by the following means:

€ Web: Fill out a support request at http://www.proxynetworks.com/support
and a case number will be automatically assigned to you

¢ Phone: (617) 453-2710
¢ Email: support@proxynetworks.com.

We offer a range of support options including support and maintenance contracts, and
time and materials projects. Consult our web site for the support plan that best meets
your needs. Go to http://www.proxynetworks.com and navigate to the Support
section of the web site for more information.
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To install PROXY Pro Master, the following requirements and recommendation should be
met:

€ "Requirements"”

& '"Display considerations"
€ ‘"Installation notes"

€ "Start options"
*

"Licensing"
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Requirements

PROXY Pro Master can be installed on any computer that runs a supported operating
system (OS) and meets the minimum requirements described in this section.

Operating system requirements
Supported operating systems are:
Windows XP

Windows Server 2003
Windows Vista

Windows Server 2008
Windows 7

Windows Server 2008 R2
Windows 8

Windows Server 2012
Windows 8.1

Windows Server 2012 R2

L JBE ZER 2 JEE 2R 2R JER R 2N 2

PROXY Pro applications are supported on both 32- and 64-bit editions of these operating
systems.

Hardware requirements
The hardware requirements are:

4 Minimum requirements — Same as those specified by Microsoft for your operating
system.

€ Recommended requirements — Same as those specified by Microsoft for your
operating system.

Other requirements

The following additional requirements are required or recommended for installation of
PROXY Pro Master:

€ Windows Installer 3.1 or later.
& Adobe Reader — Required for documentation.

€ Local Administrator access rights — Required for the user who is installing PROXY Pro
Master on the machine.

4 Additional memory — Required for each PROXY Pro Master Connection Window or
PROXY Pro Master Cycling Monitor window. The amount should be equal to the display
size of the Host. 3MB should be considered for each 1024x768 Host screen.
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€ Microsoft Core XML Services (MSXML) 6.0 — Required for Remote Management. If
the Master cannot find the redistributable MSXML6 system component, an error message
will appear in the Remote Management window. In this case, you must install MSXML6
and restart the Master. See http://www.microsoft.com for more information about the
redistributable msxml6.msi package.

Network requirements

PROXY Pro Master can operate over any type of network, including dial-up, Ethernet,
token ring, and FDDI, provided that the network supports the TCP/IP, UDP/IP, IPX or
SSL protocols.

The following conditions apply:

@ |P is a general-purpose protocol supported on a wide variety of networks and servers.
To enable communication using TCP or UDP over IP, you must enable the Microsoft
TCP/IP Protocol (or you can use another WinSock 2 compliant IP stack).

€ The SSL protocol runs above TCP/IP and below higher-level protocols such as HTTP
or IMAP. Using TCP/IP on behalf of the higher-level protocols allows an SSL-enabled
server to authenticate itself to an SSL-enabled client, and both machines to establish an
encrypted connection.

€ The WebSocket protocol runs above HTTP or HTTPS. PROXY Pro uses the binary
WebSocket protocol over HTTP (which in turn is over TCP) as well as over HTTPS
(which in turn runs over SSL). For plain WebSocket (WS) connections over HTTP,
PROXY Pro uses the same encryption used for TCP connections. For Secure
WebSocket (WSS) connections, the connection is encrypted and secured by the
underlying HTTPS/SSL connection.

& The PROXY Pro UDP, TCP and SSL transports fully support IPv4 and IPv6
addressing.
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Display considerations

To achieve the best color reproduction, the display capabilities of the computer on which
you run PROXY Pro Master must match or exceed those of the remote Host computer.

If the Host computer’s resolution exceeds that of the local computer, the Host computer
display includes scroll bars.

Support for multiple monitors

In the Windows OS, multiple monitors can be used to increase the size of the desktop. By
connecting more than one monitor, you can see more programs and windows
simultaneously without overcrowding the desktop on one monitor.

PROXY Pro Master supports multiple monitors so that you can access the entire desktop
remotely. For example, consider a Host computer that uses three monitors. PROXY Pro
Master shows everything that is displayed on each monitor when you connect to that
Host.

If the Host computer’s display configuration is non-rectangular, the following caveats
apply to the Master screen:

€ A bright border traces the non-rectangular edge of the multiple-monitor desktop.
@ The space outside of the multiple-monitor desktop appears in a dark color.

4 Additional Host monitors must be positioned below and to the right of the primary
monitor; any monitor space above and/or to the left of the primary monitor will be cut off
(this is a Windows restriction).

[1]
(2 |

3 ]

You can also choose to display just a single monitor of the remote desktop in order to
“zoom in” on it. This can be done through the connection window by using the “Select
Host Monitor” toolbar dropdown menu.

H-¢EE|hEe- HN 88
Entire Desktop (0, 0) (3200 x 1080)

Moniter 1 (0, 0) (1920 x 1080)
Monitor 2 (1920, 0) (1280 x 1024)
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Installation notes

If you plan to use PROXY Pro Master to make remote connections through a PROXY Pro
Gateway, see PROXY Pro Gateway Server Guide before installing PROXY Pro Master.

PROXY Pro Master is distributed using Internet download. It can also be deployed and
installed to large numbers of machines using PROXY Pro Deployment Tool.

Install via internet download

PROXY Pro applications are distributed as ZIP files available for download from
http://www.proxynetworks.com. Unzip the contents (while preserving the directory
tree structure) on your computer.

To install PROXY Pro Master, simply click on the Master .msi file.

Install via PROXY Pro Deployment Tool

PROXY Pro Deployment Tool can be used to install PROXY Pro Master on one or more
computers in your network. For detailed information, see the PROXY Pro Deployment
Tool Guide.
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Start options

Start PROXY Pro Master using any of the following options:
@ Choose Start > All Programs > Proxy Networks > PROXY Pro Master

& Choose Start > Run and enter proxy . exe. If you cannot open the application right
away, navigate to your product install directory from the command window before you run
Proxy.exe.

4 Double-click a PROXY Pro Master shortcut file that stores remote Host computer
connection information. The shortcut file ends with the . PRX4 extension. When you use
this method to start PROXY Pro Master, you establish a connection to a specified Host
computer immediately. For more information, see “Save as Shortcut”.

When PROXY Pro Master is started, the PROXY Pro Master Console appears.

=X PROXY Pro Master M=]

Jgnnnectiu:un Wiew OQphions Goto Help
| X8 % X
Peer-to-Peer Hosts

LD B-o-  o-
[ il

Protacal; IUDF‘.I'IF‘ vI itatiu:un:l j Connect! |
Port: Im Rgnge:l-::anal Metwork LUDPTPvd = j |_E|:|II ! | Manage. .. |
Display Mame | Protocol | Metwork Address | A|
VM-8 WK SE LDR/IP 222.738.1.67 [
WM-CR-SRY LIDP TP 222, 738.1.73
WM-CR-DC LIDP TP 222, 738.1.52
WM-OR-WES LIDP TP 222,738.1.57
WM-OR-SRY2 LIDRIP 222,738.1.66 LI
Peer-to-Peer Hosts .f{'. aateway Hosts h Active Connections .h History h Favarites }H. Cyeling Monitor Hos
29 Hosts, 0 selected i
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Licensing

If you download this software from the Proxy Networks’ web site on a 30-day trial basis
and want to continue using the product, you may purchase it by contacting a preferred
reseller, or by contacting Proxy Networks directly. Your purchase provides an appropriate
license key to use with PROXY Pro Master.

The software does not have to be reinstalled after you purchase it. The product package
contains a license key that you can add to your existing installation. This key converts
your 30-day trial software directly to an unlimited version.

Add a license key before your trial period expires

To add a license key before your 30-day trial expires, follow these steps:

1 Select Start > All Programs > Proxy Networks > PROXY Pro Master.

2 Select Help > About PROXY Pro Master from the PROXY Pro Master window.

3 When the About PROXY Pro Master window appears, click Add License. The Add
License Key window appears.

4 Enter the license key, and click OK.

Add License Key |

Wehen wau purchase PROEY Pro, you receive a License Key bo unlock the
software,

If wou have a version upgrade license key, wou must add both the original
produck license ke (if not already shown) and the upgrade license key to unlock
the software,

Please enter wour License Key exactly as you received it in the space below:

(04 I Cancel

Your license is activated immediately. PROXY Pro Master does not need to be restarted.

NOTE: If you are upgrading, then you will see both the original product license and the
upgrade license in the About PROXY Pro Master window.

Add alicense key after your trial period expires

If you attempt to run PROXY Pro Master after your trial period has expired, the message
Thank you for trying PROXY Pro appears. Within the message, click Add License and
enter your new license key.
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Your license is activated immediately. PROXY Pro Master does not need to be restarted.

Upgrade your license

If you are upgrading your license, you will receive an Upgrade license key, which you
should add using the instructions above. Both the original product license and the
upgrade license will be listed on the About tab.
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This section describes the components of the PROXY Pro Master window:

Double-click on any Host computer in either the Peer-to-Peer Hosts tab or the Gateway
Hosts tab of the PROXY Pro Master window in order to open a connection to that
computer. A Master Connection Window will open for that computer (see "Connection
Window Operation" for more information). You can have one or more Master Connection
Windows to different Host computers open at the same time.

=2 PROXY Pro Master =] E3
J Connection  Miew Gateway OQptions Gobo Help
| wm g EE s
Gateway Hosts
Gateway: ||Dca| j Manage. .. | ) Connected to local via UDPIR on 2303 at 127.0.0.1
Group: I.ﬁ.ll Hosts j Refresh |
Display Mame | |ser | Skation | Maching | Protocol il
Pru:uxy-gw adminmms Prosy-gw PRI -Gy LIDPYIP on
F‘ROX\"GF&TEWAV Administrakor PROEYGATEWAY PROEYGATEWAY LIDF/IP
=) bR o METWORK. . rgallager PROMYNETWORKS\rg...  SUPPORTZ LIDRJIF
=] = ppoRT Adrinistrator SUPPORT SUPPORT uppyip
-

4 | ’
Host Recordings X
Display Mame | Recorded at | Diurakion |

Pear-to-Peet Hosts hﬁateway Hosts .f{. Active Connections h Histaty ,]H. Favorites h Cycling Monitar Hosts {'

4 Hosts, 1 selected E_Af:‘:

The PROXY Pro Master window has a set of tabs to organize access to remote Host
computers in your network. These tabs are at the bottom of the window:

€ "Peer-to-Peer Hosts": Find and make peer-to-peer connections to remote machines with
PROXY Pro Host in this tab.

€ "Gateway Hosts": Choose a Gateway and a Gateway Group (by default, the Group is set
to All Hosts), and find and make Gateway-managed connections to remote machines with
PROXY Pro Host in this tab. Screen activity on the Host machine can also be recorded
(with or without an active connection) and played back in the "Playback Window".

€ "Active Connections": View and/or disconnect active peer-to-peer or Gateway-managed
connections in this tab.

€ "History": Review a list of recent peer-to-peer and Gateway-managed connections in
this tab. If the Hosts are still available, make connections to those Hosts in this tab.
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& 'Favorites": Keep a list of favorite peer-to-peer or Gateway-managed connections in this
tab.

€ "Cycling Monitor Hosts": Continuously monitor peer-to-peer or Gateway-managed
connections in this tab. Create a list of Host computers to monitor in a view-only mode by
cycling through the connections to each Host.

NOTE: Windows Firewall may prevent some Host computers from appearing in the Master
window. By default, PROXY Pro Host automatically adds the PROXY Pro Host service to
the list of Windows Firewall exceptions, but if this is turned off, then you may need to add
the PROXY Pro Host application (along with appropriate transport and port, e.g. UDP 1505
and/or TCP 1505) as an exception to Windows Firewall on that Host computer.

In addition to the tabs, the following additional features are available through the PROXY
Pro Master window:

4 Connecting to computers running VNC server (e.g. Mac, Linux). See “VNC Hosts”.
€ Menus for selecting features. See “Menu options”.

& Default Master window settings. See “Master Settings”.

Host status icons

Each Host computer that is listed in any of the tabs of the PROXY Pro Master window has
a workstation icon associated with it. The connection status and availability of the Host
computers is indicated by the color of the icon.

Icon Color Status

Host computer is available for

Blue .
connection.

Host computer is not currently
Gray available for connection, usually
because it is busy.

Light Are currently connected to this
green Host computer.

Are currently connected to and
Dark monitoring this Host computer in
green the PROXY Pro Master Cycling
Monitor window.

NOTE: When logged-in users are displayed on the managed Hosts tab, the icon resembles
a user (head in profile) rather than a workstation, but the color and status indicators are
identical to those listed above. See “Gateway Hosts” for information on logged-in users.
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Tool bar options

Table below summarizes the functions of icons on the tool bar in the PROXY Pro Master
window.

Icon Function

it Connects to the selected Host computer and
displays remote desktop only

E Connects to the selected Host computer with
the Remote Control tab selected.
)@ Connects to the selected Host computer with
the File Transfer tab selected.
% Connects to the selected Host computer with
the Remote Printing tab selected.
Connects to the selected Host computer with
=] the Remote Management tab selected.
oo Displays the available Host computers as
i large icons.
u-o- Displays the available Host computers as
e small icons.
= Displays the available Host computers as an

alphabetical list.

Displays the available Host computers as a
detailed list.

53



PROXY Pro Master Guide

Peer-to-Peer Hosts tab

If a Master can locate a Host in its network, the Host is known as a Peer-to-Peer Host and
will be listed on the Peer-to-Peer Hosts tab in the Master. Double-click on any remote Host
to establish a direct remote control connection (called a "peer-to-peer connection”); a
Master Connection Window will pop up showing the desktop of the remote Host (see
Connection Window Operation for more information).

With peer-to-peer connections, security and other configuration settings will be negotiated
between the Master and Host.

=2l PROXY Pro Master =]

Jg:unnectiu:un Wiew Opkions Goko  Help
[ 2 1, 359 2 e =
Peer-to-Peer Hosts

Pratacal; ILIDP.:'IP vI itatin:nn:l j Zomnect! |
Paork: I::Standaru:l:b vI Fla_nge:l-::anaI Metwiork DR TP = ~| |5k il | Mamage... |

Display Mame I Protocal | Metwork Address |

Peer-to-Peer Hosts .l'{. zabeway Hosts .h Aictive Conmections .r]\. History }'l. Fawarites }-.I Cycling Monitor Has
Palling 255.255.255.255 [ 29 Hosts ) i

From the Peer-to-Peer Hosts tab of the PROXY Pro Master window, you can find Hosts by
using one of the following 3 options:

& “Type the station or address”
€ "Select from automatic polling lists"

€ "Search with custom polling list"

Type the station or address

Sometimes polling for machines in the network with PROXY Pro Host is not ideal (such as
a network with a large number of machines distributed across multiple domains). In these
situations, polling by the Master may be slow and bandwidth-intensive.

Instead, if you know the IP address of the Host computer, you can initiate a connection by
typing its address in the Station field of the Peer-to-Peer Hosts tab.
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Ry

Jg:unnectinn Yiew Cphions Goto Help
| % % 9 X% =
Peerto-Peer Hosts

Protacol; ILIDPJ'IP vI §I:ati|:|n:|
Port; I-::Standard:b "I RQHQE:I{LDcaI Metwork LUDP TPy = | Manage... |

Display Mame | Protocaol | Metwork Address |

EE SeEe Bl
e

Peer-to-Peer Hoslts .-'{. Gateway Hosts }-.. Active Connections }1. Histary }1. Fawvarites h Cyeling Monitor Hos
Polling 255.255.255.255 { 29 Hosts | i

To manually specify a Host connection directly from the Peer-to-Peer Hosts tab, follow
these steps:

1 Choose UDP/IP, TCP/IP, or IPX from the Protocol list to specify the required Host
computer connection protocol.

2 If you do not choose the (default) standard PROXY Pro port, type the port number next
to Port to specify a port number.

NOTE: PROXY Pro Host uses port 1505 by default.

3 Type the network address or station name of the remote Host computer in the Station
field. You can also select recently typed stations or addresses from the drop-down list.

4 To establish a connection to the specified Host computer, use one of the following
methods:

& Click the Connect! button.
& Select Connect from the Connection menu.

€ Select Connect Special from the Connection menu if you want to connect for a particular
service, such as file transfer, or as another user.

When a connection is established to the Host computer, the PROXY Pro Master Connection
Window appears. For more information, see PROXY Pro Host Guide.

Select from automatic polling list

When PROXY Pro Master starts up and the Peer-to-Peer Hosts tab is selected, the Master
automatically starts polling the network for machines with PROXY Pro Host. Soon, a list of
all Host computers in your network will appear.

NOTE: The polling feature works with the UDP/IP and IPX protocols only. Polling does not
work with the TCP/IP protocol.

By default, when PROXY Pro Master is started, it polls for all Host computers using the
default search parameter in the Range list (by default, this is set to UDP/IP on local network
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segment). Automatic polling can be disabled in Options > Master Settings so that search for
computers is always initiated manually.

For each computer, the following information is provided:

€ An Icon to indicate connection status. For information on the icons, see “Master
Operation”.

€ Display Name
¢ Protocol
@ Network Address

To refresh the list, click Poll or to stop a polling operation, click Stop.

=2 PROXY Pro Master M=l

Jgnnnectin:nn Wiew Opkions Gaka Help
| % w8
Peer-to-Peer Hosts

EE e

Praokacal; ILIDP.:'IF' vI 5tatin:nn:| j Zomnect! |
Part: | <Standard > vI Range: |~=:ana| Metwork UDPJ IRy = j |_E|:ull ! | Manage. .. |
Display Mame | Prakacal | Metwork Address | 4|
WIM-OA -k S2 LDR/IP 222, 7368.1.67 —
WM-OA-SRY LIDRJIR Z22,738,1.73
WM-0A-DC LDR/IP Z22,738,1.52
WM-OA-WES LDFR/IP 222,738.1.57
WM-OA-3RYE LDR/IP 282,736,1.66 LI
Peer-to-Peer Hosts ;'{ Gateway Hosts h Active Connections }H. Histary h Favorites h Cycling Maonitor Hos
29 Hosts, 0 selected v

When you select a Host computer in the list, the Station field is updated to reflect your
selection. For display options for this field, see “Master Settings”.

Double-click a Host computer in the list to connect to it.

Search using custom polling list

When PROXY Pro Master starts up and the Peer-to-Peer Hosts tab is selected, the Master
automatically starts polling the network for machines with PROXY Pro Host.

To limit or expand the number of computers listed, adjust the range of addresses polled
with your own search criteria. From the Manage Polling Ranges dialog, create and save a
search to poll a range of network addresses or a single broadcast address. Once more
than one search is created and saved, you can create a group of searches to poll more
than one network segment at a time.

For more information about creating and managing searches, see:
& “Create a search for peer-to-peer Host computers”
& "Create a UDP/IP search"
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4 “Group one or more saved searches”

€ “Manual polling”

Create a search for peer-to-peer Host computers

By default, PROXY Pro Master searches only your local network segment when it starts to
poll for Host computers. To search for Host computers on a different network segment, a
named search must be created.

To create, edit, or remove a search, click Manage in the Peer-to-Peer Hosts tab. The
Manage Polling Ranges window appears.

Manage Polling Ranges

cal ; Mew ==
<Link Local Mebwork UDPTPyvG =

<5ite Local Metwork UDP/IPwG = Edit
<Local Metwork IP% = -

Remove

iy

Meve L

[ienve Do

Close

Help

dli

The Ranges list displays any searches that you have specified and saved, as well as the
default local network searches. The searches that can be saved include a single address, a
range of addresses, or a grouping of previously saved searches.

Four entries (<Local Network UDP/IPv4>, <Link Local Network UDP/IPv6>, <Site Local
Network UDP/IPv6>, and <Local Network IPX>) represent the local networks to which you are
connected. You cannot edit or remove any of them. You can edit or remove any other
searches listed:

4 Click Edit to change the definition of a selected search.
4 Click Remove to delete a selected search from the list.

A new search can be created using either a custom polling range or a custom group by
clicking New>>.

Create a UDP/IP search
Use UDP/IP to poll for Host computers using one of the following techniques:
Create a UDP/IP broadcast to IPv4 address

To locate a Host computer by polling a specific IPv4 address, follow these steps:
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1 From the Manage Polling Ranges window, select New > UDP/IP. The Polling Ranges
Definition window appears.

Polling Range Definition |

UDPAP Polling Fange |

% Broadeast ko IPv4 address

" Scan IPve address range

" Broadcast bo IPv link-local mulkicast address
" Broadeast ko IPvE site-local mulkicast address

" Poll single computer (&t one IPv6 address)

fddress: I':'-':'-':'-':'

Descriptive Mame: I

Port: I «<Standard = vI

™ Hide this range on the Peer-to-Peer Hosts page.

| ] 4 I Cancel Apply Help

2 Select Broadcast to IPv4 address.
3 Enter the Host computer network address that you want to poll in the Address field.
4 Enter a name for the search next to Descriptive Name.

5 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

6 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

7 Save your search using one of the following methods:
@ Click Apply to save changes and leave the Polling Range Definition window open.
@ Click OK to save changes and close the Polling Range Definition window.

NOTE: Select Broadcast to IPv4 address to search for remote Host computers by sending
a packet to a specific address. Note that broadcasts to other networks or subnets only work
if intervening routers are configured to forward broadcasts.

Create a UDP/IP scan IPv4 range of addresses
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To locate one or more Host computers by polling a range of IPv4 addresses, follow these
steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Polling Fange |

™ Broadcast ko IPv4 address

{* Scan IPv4 address rangei

" Broadcast ko IPv6 link-local mulkicast address
™ Broadcast ko IPv6 site-lacal multicast address

" Poll single computer (&t one IPv6 address)

First Address: I
Mumber of addresses: I 1
De=criptive Mame: I

Port: I «Standard = vI

[ Hide this range on the Peer-to-Peer Hosks page.

| ] 4 I Cancel Aoy Help

UDP/IP Polling Range - Scan IPv4 address range

2 Select Scan IPv4 address range.
3 Enter the first address in your desired network polling range next to First Address.

4 Specify the size of the range by entering the number of addresses to search beyond the
First Address next to Number of addresses.

5 Enter a name for the search next to Descriptive Name.

6 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

7 To omit the search from the Ranges list on the Peer-to-Peer Hosts tab, click Hide this
range on the Peer-to-Peer Hosts page.

8 Save your search using one of the following methods:

4 Click the Apply button to apply changes and leave the Polling Range Definition window
open to create and save more UDP searches.

4 Click the OK button to save changes and close the Polling Range Definition window.
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Create a UDP/IP broadcast to IPv6 link-local multicast address

IPv6 link-local addresses are used only on a particular local link (physical network),
typically for special purposes such as address resolution or neighbor discover. The link-
local broadcast address is FF02::1.

To locate a Host computer by polling a specific IPv6 multicast address on a local link, follow
these steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Polling Pange |

" Broadcast ko IPv4 address

i~ Scan IPv4 address range

{* Broadcast ko IPv6 link-local mulkicast address:

" Broadcast ko IPv6 site-local multicast address

i~ Poll single computer {at one IPwE address)

De=scriptive Mame: I

Port: I <Standard = vI

[ Hide this range on the Peet-ta-Peer Hosts page.

| k. I Cancel Apply Help

UDP/IP Polling Range - Broadcast to IPv6 link-local multicast address

2 Select Broadcast to IPv6 link-local multicast address.
3 Enter a name for the search next to Descriptive Name.

4 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

5 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

6 Save your search using one of the following methods:
4 Click Apply to save changes and leave the Polling Range Definition window open.

4 Click OK to save changes and close the Polling Range Definition window.
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Create a UDP/IP broadcast to IPv6 site-local multicast address

IPv6 site-local addresses allow data to be sent only to the devices within a site or
organization. The site-local broadcast address is FF05::4000:1.

To locate a Host computer by polling a specific IPv6 multicast address within a site or
organization, follow these steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Polling Pange |

" Broadcast ko IPv4 address
i~ Scan IPv4 address range

" Broadcast ko IPv link-local mulkicast address

{* Eroadcast ko IPv6 site-local multicast address:

i~ Poll single computer {at one IPwE address)

De=scriptive Mame: I

Port: I <Standard = vI

[ Hide this range on the Peet-ta-Peer Hosts page.

| k. I Cancel Apply Help

UDP/IP Polling Range - Broadcast to IPv6 site-local multicast address

2 Select Broadcast to IPv6 site-local multicast address.
3 Enter a name for the search next to Descriptive Name.

4 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505

5 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

6 Save your search using one of the following methods:
@ Click Apply to save changes and leave the Polling Range Definition window open.

4 Click OK to save changes and close the Polling Range Definition window.
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Create a UDP/IP Poll single computer (at one IPv6 address)
To locate a Host computer by polling a specific IPv6 address, follow these steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Polling Pange |

" Broadcast ko IPv4 address
™ Scan IPvd address range
" Broadcast ko IPv link-local mulkicast address

™ Broadcast ko IPv6 site-local multicast address

{* Pall single cormputer (at one IPv6 address)

Address: I

Descriptive MName: I

Part: I «Standard = vI

™ Hide this range on the Peer-to-Peer Hosts page.

| k. I Cancel Apply | Help |

UDP/IP Polling Range - Poll single computer (at one IPv6 address)

2 Select Poll single computer (at one IPv6 address).

3 Enter the address of the computer in your desired network polling range in the Address
box.

4 Enter a name for the search in the Descriptive Name box.

5 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

6 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

7 Save your search using one of the following methods:
@ Click Apply to save changes and leave the Polling Range Definition window open.

@ Click OK to save changes and close the Polling Range Definition window.

Group one or more saved searches
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Two or more searches can be grouped together to poll for Host computers. The result of
using a polling group is that the combined results appear in a single list on the Peer-to-Peer
Hosts tab. For example, polling groups can be used to combine the results of UDP/IP and
IPX searches. Searches must be created separately and saved, before they can be
combined into a group.

To create a group of searches for polling, follow these steps:

1 Select New > Group from the Manage Polling Ranges window. The Polling Range
Definition window appears.

Polling Range Definition |
Group Polling Range I

Select zegments ta include in Group:

[ <Local Metwark, UDPAPvds

[ <Link Local Network, UDPAPE:
[ <Site Local Network UDP/PvE:
[ <Local Network, [P

Descrptive Mame; I

| ] 4 I Cancel | Aoy Help

2 Click the check box to select any previously created searches to include in the polling
group.

3 Enter a name for the polling group in the Descriptive Name field.
4 Save your polling group using one of the following methods:

@ Click Apply to apply changes and leave the Polling Range Definition window open to
create more groups.

@ Click OK to save changes and close the Polling Range Definition window.

Manual polling

Saved searches can be used to manually poll for Host computers, even if the Master is
configured for automatic polling.

To use a saved search to poll for Host computers, follow these steps:

1 Use the Range list to select a search. This list includes two default searches through
your local network and any searches you create using the Manage Polling Ranges window.
Note the following:

€ When you select a new search from the list, polling begins automatically.
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@ Click Poll to refresh the current list of Host computers. This list reflects the search that is
currently listed next to Range.

€ The search for Host computers might take some time. New Host computers are added
to the list as they are found.

2 The Poll button changes its title to Stop Polling when polling begins. You can click Stop
Polling to terminate the search and leave the current results in the display.
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Gateway Hosts tab

When a remote Host computer is configured to report to a PROXY Pro Gateway, the Host
is known as a Gateway Host. To find a Gateway Host, follow these steps:

Gateway Hosts
Gateway: I j Manage... |
Group; I j Refresh |

€ Choose a Gateway from the Gateway drop-down list. Add/modify/delete Gateway entries
by clicking on the Manage button (see "Add a Gateway" for more information).

€ Choose a group from the Group drop-down list. By default, this value is initially set to the
All Hosts group. To add/modify/delete custom groups, please see Gateway Server Guide.

Once you choose a group, all the Gateway Hosts in that group will appear in the main
Master window. The list of Gateway Hosts can be refreshed at any time to reflect any
changes to the group or Gateway by clicking Refresh or choosing Gateway > Refresh Host
List from the menu.

=2 PROXY Pro Master =] E3
J Connection  Miew Gateway OQptions Gobo Help
| ¥ w5
Gateway Hosts
Gateway: ||Dca| j Manage. .. | ) Connected to local via UDPIR on 2303 at 127.0.0.1
Eroup: IF'.II Hosts j Refresh |
Display Mame | |ser | Skation | Maching | Protocol il
Pru:uxy-gw adminmms Prosy-gw PRI -Gy LIDPYIP on
PROXVGATEWAV Administrakor PROEYGATEWAY PROEYGATEWAY LIDF/IP
=) bR o METWORK. . rgallager PROMYNETWORKS\rg...  SUPPORTZ LIDRJIF
=] = ppoRT Adrinistrator SUPPORT SUPPORT uppyip
-

4 | ’
Host Recordings X
Display Mame | Recorded at | Diurakion |

Pear-to-Peet Hosts hﬁateway Hosts .f{. Active Connections h Histaty ,]H. Favorites h Cycling Monitar Hosts {'

4 Hosts, 1 selected E_Af:‘:
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From the Gateway Hosts tab of the PROXY Pro Master window, you can:
“Connect to a Gateway Host”

“Record screen activity on a Gateway Host”

“Play a recording”

“‘Add a Gateway”

“Manage access rights to a Gateway Host”

“Send Wake-on-LAN Signal”

L 2BR BN JEE 2R JER 2

Connect to a Gateway Host

You can establish a remote control connection through the selected Gateway (called a
"Gateway-managed connection") to one or more Gateway Hosts using any of the following
methods:

¢ Double-click the Host.
¢ Select the Host and choose Connection > Connect.

& Select the Host and choose Connection > Connect Special, and then choose Remote
Control, File Transfer, Remote Printing or Remote Management to specify the default tab to
display whenever you connect to that Host computer.

& Select the Host and choose Connection > Connect Special > Connect As, and then type
the Username and Password to log in as a different user.

A separate Master Connection Window will pop up showing the desktop of the remote Host
(see Connection Window Operation for more information):

ey o i Ffon GWS) v ’_’:' PPORT M _IDL&I

Connection Edit View Options Goto Help

wgsE 0 BT [NecEs gaac s

'

Recycle Bin  Web,config -
Shortcut

Computer Windows
Management Update

f\ Remote Control /{ File Transfer )\ Remote Management /
For Help, press F1 7/
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The benefit of a Gateway-managed connection is that security and other configuration
options can be enforced by the Gateway on all Hosts in a particular Gateway group or on
all Gateway Hosts. These settings will override any individual settings at the Host level.

Record screen activity on a Gateway Host

From the Gateway Hosts tab of the PROXY Pro Master console window, screen activity on
any managed Host can be recorded, even if there is not active remote control connection.
When PROXY Pro Master initiates a recording session, screen data from managed Host is
streamed to a file on the PROXY Pro Gateway. The Gateway can support multiple
recording sessions at the same time. Consult the screen recording hardware requirements
for scalability information.

Host Recordings list

To set up the Gateway Hosts tab to display a list of recordings, click View > Host Recordings.
The Host Recordings portion of the tab lists the following information:

€ Display Name — Shows the name of the Host computer on which you recorded screen
activity, followed by the data and time that you began to record it.

€ Recorded at — Shows the date and time that you began to record.

€ Duration — Shows the duration of the recording in seconds

Begin recording

To record activity on a Host computer, you must be connected to the PROXY Pro Gateway
that manages the Host, but you do not have to be connected to the Host computer itself.
One or more recording sessions can occur at the same time.

To record screen activity:

1 Connect to the PROXY Pro Gateway that manages the Host computers on which you
want to record screen activity.

2 Inthe list of managed Hosts, select each Host on which you want to record activity.

3 Right-click and choose Record, or choose Connection > Record from the menu. The
Record Selected Host(s) window opens.

4 In the Record Selected Host(s) window, specify the Recording Span in minutes. The
default setting is 5.

5 Click OK to begin recording.

As soon as the recording begins, it is listed in Host Recordings. When a recording has
finished, it remains listed in Host Recordings but the icon changes.
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=2 PROXY Pro Master H=] B
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The following icons indicate the status of a recording:

L 4 in the Gateway Hosts list indicates a Host on which a recording is in process.
2 @ in the Host Recordings list indicates a recording in process.

2 @ in the Host Recordings list indicates a recording that has finished.

Adjust the time span for recording
When a recording is in process you can adjust its recording time.

1 Inthe Host Recordings list, select each recording for which you want to change the
recording span.

2 Right-click and choose Adjust Recording Time.

3 Inthe Record Selected Host(s) window, select a different Recording Span in minutes
and click OK.

Stop recording
A recording can be stopped at any time:
1 Inthe Host Recordings list, select each recording that you want to stop.

2 Right-click and choose Stop Recording Time or choose Connection > Stop Recording
from the menu. The recording stops immediately.

68



Master Operation

Play a recording
Recordings can be played back in the following ways:
& From the PROXY Pro Gateway, which streams the recording to the Master.

& From a PROXY Pro recording file, that has been saved with the . PrxRec extension to a
local drive.

The recording plays in the PROXY Pro Master Playback window. For more information, see
“Playback Window Operation”.

Play a recording from the PROXY Pro Gateway
To play a recording from the PROXY Pro Gateway:
1 Select the recording you want to play.

2 Right-click the recording and choose Playback Recording or choose Connection >
Playback Recording from the menu.

The Playback window opens and the recording begins to play.

Play a recording from a file

Use this feature to either copy to a disc or email a recording file to a location that may not
be able to access the PROXY Pro Gateway. The recordings are stored by the PROXY Pro
Gateway at a location configured by the Gateway Administrator (which may or may not be
accessible through a network share).

Delete a recording
Delete a recording from the Host Recordings list and the PROXY Pro Gateway.
1 Inthe Host Recordings list, select each recording that you want to delete.

2 Right-click and choose Delete Recording or choose Connection > Delete Recording from
the menu. The recording is removed from the Host Recordings list and deleted from the
PROXY Pro Gateway.

NOTE: If you save a PROXY Pro recording file to a local drive, you must use Windows
Explorer to delete the . PrxRec file.

Add a Gateway

To make a connection from PROXY Pro Master to a Gateway Host computer, the PROXY
Pro Gateway must be added to the drop-down list of PROXY Pro Gateways.

To add a PROXY Pro Gateway:

1 From the Gateway Hosts tabs, click Manage, or choose Gateway > Manage Gateway List
from the menu. The Manage Gateways window opens.
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Manage Gateways

Gateways

Edit...

Bemove

Cloze

i Ier |

Help

2 Click New. The Gateway Connection Properties window opens.

Gateway Connection Properties |

Connection | Connect e I

— Gakteway

Display Mame: I G|

Protocal; IUD'F'."IF' TI Port: I-::Standard:: vI

Gateway Specifier: I 152.1.1.1

Skation Mame: I

tetwork Address: I

¥ Use encryption

Find Gatewary... |

k. I Canicel Apply | Help |

3 Inthe Connection tab, follow these steps:
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& Enter a name for the PROXY Pro Gateway in the Display Name box.
€ Select a connection protocol from the Protocol list.
€ Select a standard Port or type in a port number.

NOTE: The default port number for SSL protocol is 443. Both TCP and SSL cannot listen
on the same port, and must therefore be configured for distinct ports. The default
<Standard> PROXY Pro Gateway port number for TCP and UDP is 2303.

¢ Identify the PROXY Pro Gateway in the Gateway Specifier text box with either of the
following methods:

+ Type the server name, DNS name, or network IP address

+ Click Find Gateway to open the Find Gateway Wizard, which walks you through the
steps to find a PROXY Pro Gateway.

4 If you want to change the default Protocol or Port, select another choice from the list.
See “Connection tab” for details.

5 In the Connect As tab, there are two login options for connecting to the PROXY Pro
Gateway:

& Leave the default, Use logged-in username and password, to accept the existing user
login credentials.

@ Select Use the following username and password and type a different User name and
Password to change the login credentials.

Gateway Connection Properties |

Connection  Connect Az |

%' Use logged-in uzemame and password

i~ Uze the following username and passwaord:

I zer name: I

Pazzword: I

M ate: viou will =till be prompted if the zelected security
mode iz not accepted by the remote Host or if some of
the login parameters are mizzing.

] I Cancel Lpply Help
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6 Click OK to close the Gateway Connection Properties window. The PROXY Pro Gateway
is now listed in the Manage Gateways window.

7 Modify/delete Gateways in the Manage Gateways window:

& Select a PROXY Pro Gateway in the list and click Edit to edit its properties.
€ Select a PROXY Pro Gateway in the list and click Remove to remove it.

@ Click Close to return to the PROXY Pro Master window.

Manage access rights to a Gateway Host

For auditing purposes, your network administrator may require that all remote control
connections be established through a PROXY Pro Gateway. If this is the case, your remote
control access rights for Gateway Hosts are determined by the credentials you use to
connect to the PROXY Pro Gateway. Usually, these are your Windows credentials.

If your administrator has restricted your access rights, the remote control functionality on a
Gateway Host may be limited or denied. See your administrator if you are unable to
connect to either a PROXY Pro Gateway or a Host computer.

Note: If you connect to a Gateway using an Administrative account (see PROXY Pro Web
Console Operating Guide) and all available Administrative licenses are already in use, you
will be placed in Restricted Administrative Mode, and a message to that effect will appear
on right side of the page header on the Gateway Hosts tab. In this mode you have no
rights to see any Groups or Hosts. Use the Gateway Administrator or the PROXY Pro Web
Console to login and resolve any concurrent usage or licensing issues.

Send Wake-on-LAN Signal

When a Master attempts to connect through the Gateway to a remote computer with a
Host, and the last Host status in the Gateway indicates that the Host is offline, PROXY Pro
assumes that the remote computer is asleep, and will automatically send the Wake-on-LAN
signal (based on its MAC address and last known IP address). If the Gateway doesn’t think
the Host is offline, this step is skipped.
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Conneck

Connect Special g
Connect bo YMC Server...

Send Wake-On-LAR Signal

Record. ..
Stop Recarding

EBlaw Recarding
Delete Recording

Export Recording

Add to Favorites
add to Cycling Monitor Hosts

Save As Shorkcuk

Properties

Play Recaording fram Eile. ..

Plaw Recording via URL. ..

Exit

If the remote computer was asleep, and wakes up in a timely manner, the Master
connection attempt will be successful (although it may take longer than if the computer
were already awake). If the computer doesn’t wake up in a timely manner, the connection
attempt will fail, but the computer will now be awake so if the Master attempts a connection
again, it should be successful.

The Master user can also explicitly try to wake up an offline computer by selecting a Host
with offline status in the Gateway Hosts tab and then invoking the Send Wake-on-LAN
Signal command from the console menu bar (Connection > Send Wake-on-LAN Signal)
or Gateway Hosts tab context menu. If a Host is not selected, the Send Wake-on-LAN
Signal command will not be active.
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Active Connections tab

View active remote connections from the Active Connections tab of the PROXY Pro Master
window.

=X PROXY Pro Master H=]

Jgnnnectiu:un Wi Opkions Goko Help

| % M % X

Active Connections

LD &
oo

Display Mame Connected at | Prokocol Gateway | Mekw.,. | Recorded at Dt akion
=l prowys 8/25/2007 ...  LDP/IP 192....
S ym-pRORYLD 8/25/2007 ... UDP/IP 192....

Peer-to-Pear Hosts h Gabeway Hosts }H.Acl:i\re Connections lr'-r.. History ,}H. Favarites h Cyeling Monitor Hosts {'
2 Hosts, 0 selected o

View active connections as follows:

& Each Host computer to which you establish a remote control connection is listed
separately.

@ If you establish a cycling connection, then the corresponding currently active Host
computer is listed with a dark green icon.

Select the Active Connections tab to view concise information about each of the current
connections in five columns:

€ The Display Name column indicates the name by which the connection is identified.

¢ The Connected at column indicates the time and date at which the connection is
established.

€ The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or
IPX protocol.

€ The Gateway column indicates the PROXY Pro Gateway (if any) that manages the
connection.

€ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

€ The Recorded at column indicates the time when a recording session on the Host
computer was started

€ The Duration column indicates how long the recording session lasted

Double-click an entry to return to the associated connection activity (remote control or
cycling).
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Connection menu from the Active Connections tab

When one of the entries in the Active Connections list is selected, the following Connection
menu items are available:

€ Use Show Window to move the associated connection activity to the foreground.
& Use Disconnect to terminate a selected active connection.

€ Use Add to Favorites to add a selected remote Host computer to the list of favorite Host
computers. See “Favorites”.

4 Use Add to Cycling Monitor Hosts to add a selected Host computer to the list on the
Cycling Monitor Hosts tab of the PROXY Pro Master window. See “Cycle through the
Cycling Monitor Hosts list”.

€ Use Save as Shortcut to create a shortcut file (with the extension . PrRx4) for the
selected Host computer.

€ Use Properties to display information about a selected remote connection.
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History tab

View a list of the most recent Host computers to which you have connected through the
History tab of the PROXY Pro Master window.

«ZX PROXY Pro Master M=l E3
J Conneckion Edit Yiew Options Goko Help
| 3 %) W) & |88 EE

Display Name Connecked at | Disconnecte,,, | Proktocol Gakteway Recorded at Dirz &

&) Er7oEy1

=) bR O NETWORK. .
&) crwhER-PC

@ ps

=Lz
@C:\,ngram Filesh...
@ ez

=) E17DEy1

a

6/17/2008 1...
6/17/2008 1..,
B/17/2008 1...
B/2}2005 11...
5/5/2008 11..,
5/5/2008 7:...
SiS/2005 11,
4}26/2008 2...

11)212008 3...
10)7/2008 5...
61712005 1.,
6172005 1..,
6172005 1.,
B2/2008 11..,
5/5/2008 11..,
5152008 7.
5/5/2008 1:...
4/28/2005 3.,

FILE

FILE
UDP/IP
UDP/IP

local

local
local
local
suppork
suppork

10472005 3.,

5/5/2008 21,

4

Peer-to-Peer Hosts .h gakeweay Hosts }". Active Connections hHistnry .f{. Fawarites }". Cycling Monitor Hosts !r

12 Hosts, 1 selected

A

Select the History tab to view concise information about each of your most recent

connections:

€ The Display Name column indicates the name by which the connection is identified.

¢ The Connected at column indicates the time and date at which the connection is

established.

€ The Disconnected at column indicates the time and date at which the connection was

terminated.

¢ The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or

IPX protocol.

€ The Gateway column indicates the PROXY Pro Gateway (if any) that manages the

connection.

@ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

€ The Recorded at column indicates the time when a recording session on the Host

computer was started

€ The Duration column indicates how long the recording session lasted

The following tasks can also be performed:
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@ Sort history information: Sort the information displayed in the History tab according to
the values of any column heading by clicking the column heading. For example, click
Display Name to sort the items in the list alphabetically by name.

€ Open a connection to a Host computer: Open a connection to any Host computer listed
in the History tab by double-clicking the Host computer name.

& Clear items in the history list: Select Edit > Clear History from the History tab of the
PROXY Pro Master console window to clear the history list.

NOTE: See “Master Settings” for information on settings relevant to the History tab.
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Favorites tab

Save information about the most common or important connections that you make, and list
these connections on the Favorites tab of the PROXY Pro Master window.

For see specific properties of Hosts listed on Favorites tab, see "Properties of favorite Host
computers".

«Z5 PROXY Pro Master [_ O]

Jg:unne-:tiu:un Wiew Ophions Goto Help

E2 Y EL

(wYe] G- &-
(=) n}

Display Mame Prokocol Gakenay Met,., | Recorded at Dk akian
QHM-F‘RDX\"ID DR|TP 192,..,
QPROK\"I DP|TP 192....
MF'.LONE'\" DRI 192....

Peer-to-Peer Hosts }H. Gateway Hosts }-.. Active Connections h Hiskory hFa\rurites lr'-r.. Cycling Monitor Hosts f

3 Hosts, 0 selected A

Select the Favorites tab to view concise information about each of your favorite
connections:

€ The Display Name column indicates the name by which the connection is identified.

¢ The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or
IPX protocol.

€ The Gateway column indicates the PROXY Pro Gateway (if any) that manages the
connection.

€ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

€ The Recorded at column indicates the time when a recording session on the Host
computer was started

€ The Duration column indicates how long the recording session lasted

Connection menu from the Favorites tab
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When one of the entries in the Favorites list is selected, the following Connection menu
items are available:

€ Use Connect to connect to a favorite Host computer

€ Use Connect As to connect to a favorite Host computer with credentials other than your
Windows user name and password.

€ Use Remove to delete a favorite Host computer from the list of favorites
€ Use Rename to assign a new name to a favorite Host computer

€ Use Add to Cycling Monitor Hosts to add a favorite Host computer to the list on the
Cycling Monitor Hosts tab of the PROXY Pro Master control panel. See “Cycle through the
Cycling Monitor Hosts list”.

€ Use Save as Shortcut to create a shortcut file (with the extension .PRX4) for the favorite
Host computer.

€ Use Properties to display information about a favorite Host computer.

Properties of favorite Host computers

Use Connection > Properties from the Favorites tab of the PROXY Pro Master console
window to view or edit connection parameters for a selected Host computer.

Connection tab
Use the Connection tab to set and display the settings for favorite Host computers.

If the favorite computer you select is a peer-to-peer Host computer (originally listed on the
Peer-to-Peer Hosts tab), the Connection tab displays information similar to the following:
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¥M-PROXYE Properties

Connection | Connect .i‘-.sl Startupl Femate I:-:untrl:ull Effectsl File Transferl

—Peer-to-Peer Host

Display Mame:

Protocol; IUDF"I'IP "I Port: I::Standaru:l:b vI

Skation Specifier; I 292,262,123 PROxYG

Station Name: | PROXYE

Metwork Address: | 202,262.1,23

[ Use encrypkion

k. I Cancel Amply Help

The following Host computer connection properties can be edited:
€ Connection protocol: Select a Protocol from this list.
4 Connection port: Select the standard Port or type in a port number.

€ Type in the Station Specifier or other items using the following syntax:
network address:machine network name. A station specifier is an optional network
specifier followed by a colon, and a station name (which can include wild cards). It can be:

+ a protocol-specific network address prefixed with ‘@’
+ a DNS name (for UDP and TCP)
+ a PROXY Pro station specification

& Check or uncheck Use encryption.

If the favorite computer you select is a managed Host computer (originally listed on the
managed Hosts tab), the connection properties of a managed Host computer displays.
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FRONTDESK Properties |
Connection |
—iaateway Hosk
Display Name: ROMTDESK
Host key: I w={_DF0BF7F-72F0-4821-B322-22AF1C311
Protocal; I LIDR/IP Part: IISDE—
Station Mame: I FROMNTDESE

Metwork Address: I 192.168.1.102

Wiorkskation ID: I {9CD70EF7-72F0-4821-E322-22AF1C31 1EDe

Uszet: I

Gateway, .. |

] I Cancel Lpply Help

Edit the Host key, which is the key used by the PROXY Pro Gateway to specify the Host
computer address.

When Gateway is clicked, the following information relevant to your local connection to the
PROXY Pro Gateway appears.

81



PROXY Pro Master Guide

Gateway Properties |

Connechion | Connect .ﬁ.sl

—aateway

Display Mame: I (W5

Protocol; IUDP."IF' vI Fort: I::Standard:: vI

Gateway Specifier; I 152.1.1.1

Station Mame: | WS

Metwork Address: I 152.1.1.1

[T use encryption

Find Gateway. .. |

] I Cancel Apply | Help |

Connect As tab

Specify credentials to use when connecting to a Host computer for peer-to-peer
connections or to a PROXY Pro Gateway.

Select the following options from the Connect As tab:

€ Select Use logged-in username and password to log in with the username and password
for your local computer.

€ Select Use the following username and password to log in to the associated Host
computer with other credentials (username and password). Enter the appropriate
credentials in the fields provided.

If you do not enter the required username and/or password, the Enter Network Password
window appears when you attempt to connect. See “Connecting with different credentials”
for more information.

Startup tab

From the Startup tab, choose the name of one of the PROXY Pro Master Connection
Window tabs from the Make the following tab active at connect list. The name you
choose is the default tab you view when you connect to a Host computer.

For more information, see the Startup tab on the "Default Connection Window Settings"
page.

Remote Control tab
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Specify the default behavior for remote control connections from the Remote Control tab.

For more information, see the Remote Control tab on the "Default Connection Window
Settings" page.

Effects tab

Use the options on the Effects tab to provide default settings for enabling and disabling
certain visual effects when connecting to a Host computer. By disabling any of the listed
visual effects, you can reduce the amount of screen data that needs to be captured and
transmitted over the network.

For more information, see the Effects tab on the "Default Connection Window Settings"
page.
File Transfer tab

Use the File Transfer tab to provide default settings for remote file transfer.

For more information, see the File Transfer tab on the "Default Connection Window
Settings" page.
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Cycling Monitor Hosts tab

The Cycling Monitor allows you to serially check in on a set of remote Host computers to
monitor the activity of those Hosts but not to take control of them. The Cycling Monitor has
its own window, similar to the Master Connection Window, except that it is view-only mode
at all time (see “Cycling Monitor Window Operation” for more information). The Cycling
Monitor window will show the desktop of each remote Host listed on the Cycling Monitor
Hosts tab for a predetermined period of time.

=2l PROXY Pro Master Mi=] E3

Jg:unnectiu:un Edit Wiew Opkions Goto Help

| m P g
Cycling Monitor Hosts

[m]s]
=]

Display Mame Prokocol Gakeway Metw. ..
Elprowys LIDR TP 192,,.,
MF'.LDNE\" IIDPIP 192...,
QVM-PROX'\"ID DR TP 192...,
=) ym-con-sRy LIDP TP 192,

Peer-to-Pear Hosts h Gateway Hosts }1. Active Connections ,]'1. Histary }-.. Favorites }-..Eytling Monitor Hosts [

For Help, press F1 i

In the Cycling Monitor Hosts tab, you can perform the following tasks:
€ “Add Host computers”

“Sort Host computers”

“Connect to Host computers”

“Cycle through the Cycling Monitor Hosts list”

“Open Cycling Monitor”

“‘Remove Host computers”

® 6 ¢ O o o

“Clear all Host computers”

Select the Cycling Monitor Hosts tab to view concise information about any Host you want
to monitor:

€ The Display Name column indicates the name by which the connection is identified.
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& The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or
IPX protocol.

€ The Gateway column indicates the PROXY Pro Gateway (if any) that manages the
connection.

€ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

Connection menu from the Cycling Monitor Hosts tab

When the Cycling Monitor Hosts tab of the PROXY Pro Master console window is selected,
the Connection menu options change. The following additional options appear:

4 Show Window — Use Connection > Show Window to open the Cycling Monitor window to
view the activities of that Host computer and other Host computers on the cycling list.

¢ Remove — To remove a Host computer listed on the Cycling Monitor Hosts tab, select it
and then select Connection > Remove.

€ Rename — To change the displayed name for a Host computer listed on the Cycling
Monitor Hosts tab, select it and then select Connection > Rename.

Add Host computers

Add to the list of Host computers in the Cycling Monitor Hosts tab by selecting a Host
computer on any other tab of the PROXY Pro Master console window, and then choose
Connection > Add to Cycling Monitor Hosts.

When you add a Host computer to the list in the Cycling Monitor Hosts tab, the PROXY Pro
Master Cycling Monitor window is automatically moved to the top (and opened, if it has not
yet been opened) if the Activate if a new object has been appended option in the Cycling
Monitor Settings window is selected.

Sort Host computers

Sort the list of Host computers on the Cycling Monitor Hosts tab of the PROXY Pro Master
console window by selecting one of the column titles (such as Display Name or Network
Address). The listed Host computers are sorted alphabetically or numerically, according to
the type of information that is displayed in the selected column.

Connect to Host computers

Double-click a Host computer listed on the Cycling Monitor Hosts tab to monitor its activity
through the PROXY Pro Master Cycling Monitor window.

Cycle through the Cycling Monitor Hosts list

The default for the PROXY Pro Master Cycling Monitor window is to cycle through the Host
computers in the list one at a time. Change the cycle rate using Options > Cycling Monitor
Settings or the tool bar. Freeze the monitoring process from the Connection menu.

As you cycle through monitoring Host computers in the PROXY Pro Master Cycling Monitor
window, view the connection status for each Host computer from the icons listed on the
Cycling Monitor Hosts tab.
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Open Cycling Monitor

To open the PROXY Pro Master Cycling Monitor window, double-click a selected Host
computer on the Cycling Monitor Hosts tab.

Remove Host computers

To remove a selected Host computer from the list on the Cycling Monitor Hosts tab, right-
click and select Remove.

Clear all Host computers

To clear all Host computers from the Cycling Monitor Hosts list, select Edit > Clear Cycling
Monitor Hosts.
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VNC Hosts

In addition to Peer-to-Peer Hosts and Gateway Hosts, PROXY Pro Master can reach and
establish remote control connections to remote computers running a standard version of
the Virtual Network Computing (VNC) server ("VNC Hosts"). PROXY Pro Master includes a
proprietary implementation of the VNC Remote Frame Buffer (RFB) protocol, enabling it to
function as a VNC client that can connect to and interoperate with any standard VNC
server.

PROXY Pro Master supports connections to VNC server running on the following operating
systems:

€ Apple Macintosh (when the built-in screen sharing is configured to allow VNC
connections, or when an alternative VNC server is installed and configured). The following
specific configurations are supported:

+ 0OSX10.5+

€ Linux (when a VNC server is installed and configured). The following configurations are
supported:

¢ Linux (any) running the VNC server

Peer-to-Peer Connections to VNC Server

PROXY Pro Master console includes a menu item Connection > Connect to VNC
Server... to initiate a peer-to-peer connection to a VNC server:

Conneck

Connect Special g
Connect bo YMC Server...

Send Wake-On-LAR Signal

Record. ..
Stop Recarding

EBlaw Recarding
Delete Recording

Export Recording

Add to Favorites
add to Cycling Monitor Hosts

Save As Shorkcuk

Properties

Play Recaording fram Eile. ..

Plaw Recording via URL. ..

Exit
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A dialog box will appear to prompt for the information required to connect to the server:

Enter ¥YMC Server Mame or Address | x| |

Please enter the name or address of the YWHC Server you wish bo connect to:

Server: I 292.2621.23 j

Protocal: = =] Pty [ 5900 |

Cptionally, enter a passwaord:

Passwiard: I |

Ik I Zancel |

As illustrated, the required information is the server name (DNS name or IP address), the
protocol (currently the only option is TCP), and the port (default is set to port 5900).

VNC servers normally require a password for authentication. This password can be entered
in the dialog box. If no password is entered, but the VNC server requires one, a dialog box
will appear to collect the password:

Enter Network Password Ed |
% Please type the password Far this Haost,

Huosk: 292 262.1.23

Passwaord:

(4 I Cancel Help

Once connected, the remote display of the computer running the VNC server appears in a
standard Master Connection Window.

The Connection Window for a VNC server has the following limitations:

4 Only the Remote Control service is supported at this time. Menu options and icons for
other services such as File Transfer, Remote Printing, Remote Management and Chat are
disabled.

4 Other configuration options are not applicable
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€ Some shortcut commands are not applicable, depending on which OS platform the VNC
server is running; see table below for more detail

Shortcut Command MacOS Windows Linux

Ctrl-Alt-Del No Yes No

Windows-L No Yes No

F11 Yes Yes Yes
No but

PrintScreen & Alt-PrintScreen Alt+Shift+3+Mouse No No

will work instead

Command Line Support for VNC Hosts

Connections to VNC servers can be invoked from the Master command line utility using the
following option:

* “/v” indicates that the specified Host is a VNC server. This switch can be used in
conjunction with the /p (protocol), /s (station specifier), and /x (password) switches to fully
specify a VNC server to connect to. See "Command line options” for more detail.
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Menu options

Use the following menus to manage configuration settings for PROXY Pro Master:
€ Select “Connection” to see detailed list of all remote connection options

& Select “Edit” to modify the list of Host computers on the History or Cycling Monitor Hosts
tab

& Select “View” to show or hide parts of the PROXY Pro Master window

& Select “Gateway” to operate the Manage and Refresh buttons on the Gateway Hosts tab
@ Select “Options” for modify default display options for various windows

@ Select “Goto” to select tabs on the PROXY Pro Master window

& Select “Help” to obtain help on the product

NOTE: The menus change according to which tab you select in the PROXY Pro Master
window.

Connection

Use the following Connection menu options on the Peer-to-Peer Hosts and Gateway Hosts
tabs of the PROXY Pro Master console window:

Conneck

Connect Special L
Connect bo YMC Server., ..

Send Wake-COn-LAN Signal

Record...

Stop Recording

Elay Recarding
Delete Recording

Export Recording

Add ko Favorites
add to Cvcling Monitor Hosts

Save As Shortouk
Properties

Play Recording from Eile. ..
Play Recording via URL. ..

Exit

¢ “Connect”
& “Connect Special’
¢ “Connect to VNC Server...”
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“Send Wake-on-LAN Signal”
“Record...”

“Stop Recording”

“Play Recording”

“Delete Recording”

“Export Recording”

“Add to Favorites”

“Add to Cycling Monitor Hosts”
“Save as Shortcut”
“Properties”

“Play Recording from File...”

L R 2K JEE JEE JER JEE JEE JER JEE R R 4

“Play Recording via URL...”

See also the following Connection menu options that become available depending on which
tab you select:

4 “Connection menu from the Cycling Monitor Hosts tab”
€ “Connection menu from the Active Connections tab”

¢ “Connection menu from the Favorites tab”

Connect

Select Connection > Connect from any tab other than Active Connections to connect to a
selected Host computer. A PROXY Pro Master Connection Window appears.

Use the PROXY Pro Master Connection window to view or control a remote Host
computer. Establish simultaneous connections to one or more Host computers by repeating
this procedure.

Connect Special

Use Connection > Connect Special to choose from the following connection options when
you connect to a Host computer:

€ Select Remote Control to connect to a selected Host computer and open the PROXY
Pro Master Connection Window with the Remote Control tab selected. See “Remote
Control”.

€ Select File Transfer to connect to a selected Host computer and open the PROXY Pro
Master Connection Window with the File Transfer tab selected. See “File Transfer”.

€ Select Remote Printing to connect to a selected Host computer and open the PROXY
Pro Master Connection Window with the Remote Printing tab selected. See “Remote
Printing”.

€ Select Connect As to connect to a selected Host computer with credentials other than
your Windows user name and password.

Connecting with different credentials

When you connect to a Host computer, you are usually authenticated with the same user
name and password with which you logged in to your local computer. Select Connection >
Connect Special > Connect As to connect to the Host computer with different credentials.
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When you initiate a connection to a Host that requires a different username and/or
password, the Enter Network Password window appears.

Enter Network Password |

@ Fleaze lpe pour uzer name and pazsword.

Hozk: prosygakeway

Uszer Mame: I

Pagzzword: I

[T Savethese credentialz permanemntly

] I Cancel Help

Enter Network Password window

Enter an authorized username and/or password for the Host computer (fill in all blank
fields) and click OK.

Record...

On the managed Hosts tab, select Record... to start a recording for any Gateway-managed
Host computer that is selected.

Stop Recording

On the managed Hosts tab, select Stop Recording to stop any active recording for any
Gateway-managed Host computer that is selected.

Play Recording

On the managed Hosts tab, select Play Recording to activate the Master Playback window
and play back a recording selected from the Hosts recordings list in the Master Console.

Delete Recording

On the managed Hosts tab, select Delete Recording to delete a recording selected from the
Hosts recordings list in the Master Console.

Export Recording

On the managed Hosts tab, select Export Recording to save a recording selected from the
Hosts recordings list in the Master Console in Microsoft .wmv format The following dialog
box will popup during and that the completion of the recording:
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3 Conversion complete [_ [} |

Caonverting wia Gateway 127.0.0,1
SessionlD: {7F2C040E-3BAC-4EC0-9100-02FFEES4EFS 3}

|

Conversion completed successFully

Drestination:
Ci\Documents and SettingstAdmini. . wirkual-2008-01-02-16-09-10-372 . WY

[ Close this dialog box when corrersion is complete

Play Cpen Eolder

Add to Favorites

Select Add to Favorites to add a selected peer-to-peer or Gateway-managed Host
computer to the list of favorite Host computers. The list of favorite Host computers appears
when you select the Favorites tab on the PROXY Pro Master console window. See
“Favorites”.

Add to Cycling Monitor Hosts

Select Add To Cycling Monitor Hosts to add a selected Host computer to the list on the
Cycling Monitor Hosts tab. This is the list of Host computers you intend to supervise using
the PROXY Pro Master Cycling Monitor window.

NOTE: If you check Activate if a new object has been appended under the General tab
of the Cycling Monitor Settings window, cycling monitor connections are automatically
activated when you add a Host computer to the Cycling Monitor Hosts list.

Save as Shortcut

To save connections that you access frequently as shortcut files on your desktop, use
Connection > Save As Shortcut. The shortcut file, which has the extension . PRX4, provides
an easy way to connect to a selected Host computer for the purpose of remote control, file
transfer, or remote printing.

Alternatively, drag and drop connections to your desktop to create a shortcut.

Use a shortcut file to establish a connection to its associated Host computer by double-
clicking the shortcut file from the desktop.

The shortcut file saves information about the connection to the Host computer. You can
view information about your Host computers by right-clicking the shortcut file from your
desktop and selecting Properties. This information includes the following:

€ The protocol used to access the Host computer
€ The Host computer network address
€ The Host computer station name

See “Properties of favorite Host computers” for more information.
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PROXYE.prx4 Properties |

Effects | File Transfer I SecLrity I Custam I Summary I
General Connection I Connect s I Startup I Remate Control

— Peer-to-Feer Host

Dizplay Mame:

Protocal; ILIDF'.-'IP' vI Part: |<Standard> vI

Station Specifier; IEEIE.EEE.'I 23PROXYE

Station Mame: IF"H 07

Metwork Address: IEEIE.EEE.'I .23

[™ Use encivption

k. I Cancel Spply

Properties

Use Connection > Properties to display the connection information for a selected Host
computer.

When a Host computer is selected from the Favorites or Cycling Monitor Hosts tabs, you
can edit the properties that appear. Editable properties also appear when you right-click a
shortcut file that is saved to your computer and select Properties.

When a Host computer is selected from the Peer-to-Peer Hosts or managed Hosts tabs, you
cannot edit the properties that appear. The following Properties window is for a managed
Host and is not editable.
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FRONTDESK Properties |

Connechion |

—iaateway Hosk
Display Name: ROMTDESK
Host key: I w={_DF0BF7F-72F0-4821-B322-22AF1C311
Protocol: IW Fark: IISDE—
Station Mame: I FROMNTDESE

Metwork Address: I 192.168.1.102

Wiorkskation ID: I {9CD70EF7-72F0-4821-E322-22AF1C31 1EDe

Uszet: I

Gateway, .. |

] I Cancel Lpply Help

NOTE: When you view properties for a Host computer listed on the managed Hosts tab,
the protocol and port specified indicate those used for the connection between the remote
Host computer and the PROXY Pro Gateway.

Click Gateway... to see properties for the connection between the PROXY Pro Gateway and
the Master computer.
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Gateway Properties |

Connechion | Connect .ﬁ.sl

—aateway

Display Mame: I (W5

Protocol; IUDP."IF' vI Fort: I::Standard:: vI

Gateway Specifier; I 152.1.1.1

Station Mame: | WS

Metwork Address: I 152.1.1.1

[T use encryption

Find Gateway. .. |

] I Cancel Apply | Help |

Edit

Select Edit > Clear History from the History tab of the PROXY Pro Master console window
to clear the history list.

Select Edit > Clear Cycling Monitor Hosts from the Cycling Monitor tab of the PROXY Pro
Master console window to clear the Cycling Monitor Hosts list.

View

Modify display options for the PROXY Pro Master console window by using the View menu.
The View menu is organized into three sections:

€ Top section - user interface elements in the PROXY Pro Master window

¢ Middle section - tabs in the PROXY Pro Master window

€ Bottom section - icon viewing options
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User interface elements in the PROXY Pro Master console window

Toggle the appearance of the following elements in the PROXY Pro Master console

window by checking or unchecking items on the View menu:

¢ Menu Bar
¢ Tool Bar

& Page Header, the heading displayed for each selected tab

¢ Status Bar
¢ Tabs

Tabs in the PROXY Pro Master console window

Control the appearance of the following tabs by checking or unchecking the tab names

listed on the View menu:
& Peer-to-Peer Hosts
managed Hosts
Active Connections
History

Favorites

® 6 ¢ o o

Cycling Monitor Hosts

Icon viewing options

When a Host computer icon is selected on any tab, the display option for icons can be set

by using the View menu:
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€ Select Large Icons to display Host computer icons as large icons, with the name of the
remote Host computer as the title. The icons are arranged left to right, and then top to
bottom, sorted alphabetically according to Host computer name.

€ Select Small Icons to display Host computer icons as small icons.

& Select List to display Host computer icons as small icons, sorted alphabetically, and
placed top to bottom, and then left to right.

€ Select Details to display Host computer icons in a vertical scrolling list, along with other
details, such as the IP address of each Host computer.

Gateway

Use the Gateway menu from the Gateway Hosts tab of the PROXY Pro Master console
window to select the following commands:

® Refresh Host List refreshes the list of Host computers on the Gateway Hosts tab.

€ Manage Gateway List opens the Manage Gateways window from the managed Hosts tab.
See “Add a PROXY Pro Gateway”.

Options

Use the Options menu to set the following options:
& “Master Settings”

“Keyboard Mapping”

“Default Connection Window Settings”

“Cycling Monitor Settings”

“Default Playback Window Settings”

* 6 o o

Master Settings
Select Options > Master Settings to set certain preferences for the following features:

& “Peer-to-Peer Hosts” - to set automatic polling options and station specifier construction
options for the Peer-to-Peer Hosts tab.

€ “Gateway Hosts” - to set some options that may limit the way Host computers display on
the Gateway Hosts tab.

& “History” - to set some options for how Host computers display on the History tab.

4 “Clipboard” - to set option to include or not include the mouse pointer on Host computer
in screen capture.

Peer-to-Peer Hosts

Select the Peer-to-Peer Hosts tab in the Master Settings window to adjust the following
settings:
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Master Settings |

Feer-to-Peer Hosts I Gateway Hu:ustsl Histu:uryl I:Iipl:u:uardl

Congtruct station specifiers:

£~ from DMS name or by netwaork and station name

% ‘from network. and station name only

” from network connection address only

v Poll automatically on startup

| k. I Cancel Apply Help |

€ Construct station specifiers: Specify the way that station specifiers (connect strings) are
constructed for polled Hosts by selecting one of the following options:

+ From DNS name, or by network and station name specifies Host computers either
by computer name or by DNS name. With this option, a reverse DNS lookup is
attempted using the network address. A reverse DNS lookup can take a long time
depending on the network configuration, and may cause performance problems if
there is a large number of Host computers. If the reverse DNS lookup succeeds,
the station specifier is the DNS name. Otherwise, the network address and station
name are used.

+ From network and station name only specifies Host computers by network
address and station name using the address : name syntax.

+ From network connection address only specifies Host computers network
address.

€ Check Poll automatically on startup to poll for Host computers when you start PROXY
Pro Master. With this option, PROXY Pro Master searches for all computers listed next to
Range on the Peer-to-Peer Hosts tab. This is useful if the polling range is small. If the
polling range is large, automatic polling may slow PROXY Pro Master’s startup significantly.

Gateway Hosts

Use the managed Hosts tab of the Master Settings window to control how items are
displayed on the Gateway tab.
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Master Settings |

Peerto-Peer Hosts  Gateway Hosts | Histu:uryl I:Iipl:u:uardl
™ Show Users

" Show Workstations

+ fllow duplicates
£ Hide any Warkstation that is a duplicate of a User

£~ Hide any User that is a duplicate of a Waorkstation

| k. I Cancel Help |

Specify which type of Gateway-managed Host computers to display:
€ Select Show Users to display the set of Gateway-managed users who are logged in.
€ Select Show Workstations to display the target set of Gateway-managed workstations.

€ Select Show both to display all logged-in users and workstations in the set of Gateway-
managed Hosts. You can specify how you want duplicates handled when both a
workstation and a user logged into that workstation are potential Hosts. You can select one
of the following:

+ Allow duplicates: Allow both the logged-in user and corresponding workstation to
display (although they resolve to the same physical Host computer).

+ Hide any workstation that is a duplicate of a user: Display only the logged-in user.

+ Hide any user that is a duplicate of a workstation: Display only the workstation on
which the logged-in user is working.

NOTE: This is an advanced feature. Do not change the default options unless you know
how your PROXY Pro Gateway is configured.

History

Use the History tab of the Master Settings window to control the way that items are
recorded on the History tab:

€ Always: All of your connections to Host computers are reported on the History tab.

€ Only if tab is not hidden: Your connections to Host computers are reported on the
History tab only when the tab is visible.

€ Never: Your connections to Host computers are not reported on the History tab.
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Master Settings |

Peer-to-Feer Hnstsl Gateway Hosts  History | I:Iipl:u:uardl

Record history:
" Always
* ol if tab is not hidden;
i Mever

Maximurn number of connections ko skore:

20 =

| k. I Cancel Help |

Also, you can limit the number of connections to save on the History tab by specifying a
value for Maximum number of connections to store (default = 20).

Clipboard

Use the Clipboard tab of the Master Settings window to specify whether or not the mouse
pointer on the remote Host screen should be captured:

Master Settings |

F'eer-tu:u-F'eerH-:ustsI (3 ateway Hu:ustsl Histary  Clipboard |

[ Capture Host pointer when using Copy Graphics:

| k. I Cancel Help |
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Keyboard Mapping

Certain key combinations perform special functions on a computer. Because of Windows
features, the following key combinations can apply to the local computer only:

¢ CTRL+ALT+DEL
& CTRL+ESC
€ Any key combination that includes the Windows key

To create a key combination that applies to the remote Host computer, select Options >
Keyboard Mapping.

Keyboard Mapping |
—Commands —Selected Command
Toggle Full Screen Toggles Full Screen mode For
Remote Chrl+alt+Del Conneckion Window and Plavback
Remote Alk+PrinkScreen YWindow

Remate Printacreen
Arcceleratar;

F11

Special Hok Key... |

Reskare Default

Eemove |

Reskare Al (s Zancel | Help |

There are five sections in the Keyboard Mapping window:
4 “Commands”

“Accelerator and Special Hot Key”

“Restore Default”

“‘Remove”

“Restore All”

* 6 o o

Commands

The Commands list shows the commands available for mapping. A text description of the
currently selected command is shown under Selected Command. The currently mapped
key, which when pressed will invoke the command, is described under Accelerator.

Figure above illustrates the TOGGLE FULL SCREEN accelerator key combination mapped to
the Remote F11 command. This means that when a PROXY Pro Master Connection
Window has the focus and the user presses the F11 key, the Host computer will be sent
F11, which will have the effect of opening the full screen on the Host computer.
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Accelerator and Special Hot Key

To modify the key combination in the Accelerator field, place the cursor in the Accelerator
field and simple press the desired key combination. The text description of the key
combination will automatically appear. To specify special hot key combinations, which you
cannot normally type because the system will immediately interpret them using the default
meaning, such as ALT+TAB, CLICK Special Hot Key to open the Special Hot Key window.

special Hot Key |
— Key Defintion
Lo ]
SyzReq/FrintScreen j
MHaone = Cancel |
Tab —
Ezcape
Delete = Help |

In the Keyboard Definition section, select the keys you want to use and click OK to return to
the Keyboard Mapping window. The Accelerator field shows the new key combination.

Remove

To remove a key mapping, select the command in the Commands list and click Remove.

Restore Default

To restore a key mapping to its default setting, select the command in the Commands list
and click Restore Default.

Restore All

To restore all key mappings to the default settings, click Restore All.

Default Connection Window Settings

Use Options > Default Connection Window Settings to set initial parameters for remote
connections and specify a configuration template for new PROXY Pro connections.

NOTE: You can change most of these settings for a particular connection once it is
established. To do so, select Options > Connection Window Settings from the PROXY Pro
Master Connection Window.

Set five types of default Connection Window settings can be set:
“Connection”

“Startup”

“‘Remote Control”

“Effects”

“File Transfer”

* ¢ 6 o o

Connection
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In version 4.0 and later, the Host computer supports encryption. From the Connection tab of
the Default Connection Window Settings window, require data encryption for data transfer.

Default Remote Desktop Window Settings |

Connectian | Startupl Femate Eu:untru:ull Effectsl File: Transferl

[ se enceyption (for peer-to-peer connections i

k. I Carnicel Smply Help

Check Use encryption to require data encryption for data transfer.

NOTE: Host computer encryption requirements override this option. The connection is
encrypted if the Host computer requires encryption, even if you uncheck Use encryption.

Startup

From the Startup tab of the Default Connection Window Settings window, choose the nhame
of one of the PROXY Pro Master Connection Window tabs from the Make the following tab
active at connect list. The name you choose is the default tab you view when you connect to
a Host computer.
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Default Remote Desktop Window Settings |

Connection  Startup I Femote D:untn:ull Effectsl File Transferl

Make the Following kab active at connect:

k. I Cancel Apply Help

Remote Control

Specify the default behavior for remote control connections from the Remote Control tab of
the Default Connection Window Settings window.
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Default Remote Desktop Window Settings |

I:l:unne-:til:unl Statup  Remote Control |Effect$| File Transferl

— Yiewer Setktings

[~ Full Screen % Fit ko window
[ Wiew Only " Fit 1-to-1

—Huost Opkions (iF allowed/supported by Host)
[™ sSuppress kevboard and mouse

— Auto-scroll
v Cursor (text-mode anly) [+ Maouse (bext & graphics modes)

—Text-mode Display ————— 1~ Text-mode Mouse

Fort:  [prowy Gx 14 | [ Left button clicks
[T Right button dlicks

Texk refresh rate

Foreground: IFast vI % Mo mouse mation

" absolute mouse mation

Backaround: I 1 second vI ™ Relative mouse maotion

k. I Cancel | Apply Help

Modify the following options:

€ Use Viewer Settings to specify default settings for the remote display:

+ Select Full Screen to fill the entire screen of the local computer with a view of the
Host computer monitor in the PROXY Pro Master Connection Window.

+ Select View only to allow users of PROXY Pro Master to view the display without
taking control of the Host computer.

+ Select Fit to window to scale the display of the Host computer to fit into the
PROXY Pro Master Connection Window.

+ Select Fit 1-to-1 to have each pixel on the Host computer display correspond to
one pixel on the Master computer.

+ Select Halftone to improve the quality of the display when the Master is in Fit to
Window mode.

Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.

4 Modify the Host Options to specify the operation of the remote Host computers when
you establish PROXY Pro Master Connections:
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+ Select Suppress keyboard and mouse to request that the remote Host computer
mouse and keyboard be disabled at connection time. If this request is granted, no
one can operate the mouse and keyboard located at the Host computer at any time
during the PROXY Pro Master Connection. Note that even if you select this option,
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it is possible that the remote Host computer is configured so as not to allow
keyboard and mouse suppression.

NOTE: These options are not currently supported on Vista platforms.

€ Modify Auto-scroll group options to specify whether you want the window to scroll when
the cursor (for text-only screens) or mouse reaches a boundary:

+ Select Cursor (text-mode only) to automatically scroll when the cursor comes to
an edge of the PROXY Pro Master Connection Window when you hold the CtrL
key down.

+ Select Mouse (text & graphics mode) to automatically scroll when the mouse
comes to an edge of the PROXY Pro Master Connection Window when you hold
the Ccrrr key down.

€ Modify Text-mode Display options for Host computers that display text screens, rather
than graphical screens:

+ Use the Font drop-down list to select the typeface and type size to use for
viewing remote connections locally. By changing the font, you can increase or
decrease the size of the Host computer screen displayed in the PROXY Pro Master
Connection Window. A smaller font lets you see more of the Host computer
display. A larger font improves readability. You can preview the fonts from each
entry in the Font list. The names of the fonts consist of a typeface name and a size.
Text fonts called PROXY are fonts that are included with this software package.
Fonts with other typeface names are Windows fonts that are also suitable for text
display.

+ Use the Text refresh rate settings to specify the rate at which changes in the text
display are updated on your screen. This allows you to find a suitable compromise
between “refresh rate” and the amount of computation time and network resources
spent in updating the text display. Note the following:

- The Foreground setting rate you select applies when the Connection
Window is active.

- The Background setting rate you select applies when the Connection
Window is not active.

In general, if you have sufficient computational power and a speedy connection, you should
leave both refresh rates set to Fast.

€ Modify the Text-mode Mouse group to control how information from the mouse on the
local computer is transmitted to a remote Host computer when it operates in text mode:

+ Check Left button clicks to ensure that left mouse button clicks are sent to the
remote Host computer.

+ Check Right button clicks to ensure that right mouse button clicks are sent to the
remote Host computer.

+ There are three different ways in which the motion of the mouse on the Master
can be interpreted and sent to the remote Host computer:

- If you select No motion, then the mouse does not move at all.

- If you select Absolute motion, then the Host computer is provided an
absolute mouse position [for example, a coordinate such as (44,13)].

- If you select Relative motion, then only the differential motion of the mouse
(up, down, left, or right from current position) is sent to the Host computer.

Effects
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Use the options on the Effects tab of the Default Connection Window Settings window to
provide default settings for enabling and disabling certain visual effects when connecting to
a Host computer. By disabling any of the listed visual effects, you can reduce the amount of
screen data that needs to be captured and transmitted over the network.

Default Remote Desktop Window Settings |

Eu:unnectiu:unl Startupl Fiemate Control  Effects I File: Transferl

¥ Flequest Wisual Effects to be disabled as Follows:

—Wizual Effects to be Digabled

¥ #ero Glass [desktop composzition]

¥ Backaground wallpaper or pattern

V' Mouze shadows and trails

W Fant smoathing and ClearT ype

¥ Menu shadows and window animations
¥ Show window contents while dragging

¥ Screen Saver

k. I Carnicel Smply Help

All visual effect options are enabled by default. Check Request Visual Effects to be disabled
as follows to enable or disable specific graphical effects. Check the visual effects options
that you want to disable under Visual Effects to be Disabled. Leave the visual effects options
that you want to enable unchecked.

File Transfer

Use the File Transfer tab of the Default Connection Window Settings window to provide
default settings for remote file transfer.
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Default Remote Desktop Window Settings |

I:l:unne-:til:unl Startupl Femate D:untn:ull Effects  File Transfer |

[~ Wiew file attributes
[T View hidden & system files

— Left Pane Settingz
Starting directany:

% Yiew local file system Sort files by:
™ iew remate file system Mame j

— Right Pane Settingz
Starting direchany:

™ Wiew local file system Sort filez by:

= Wiew remate file system INE""'IE j

k. I Cancel | Apply | Help |

Select the following:

@ View file attributes: An extra column that provides file attribute information appears on
both the left and right sides of the File Transfer tab.

€ View hidden & system files: Hidden and system files are added to both the left and right
sides of the File Transfer tab.

Specify the following default settings:
& Default starting directories for local and remote computers

€ The location for local and remote computer files. For example, select View local file
system under Left Pane Settings to view local files on the left side of the File Transfer tab
and the remote files on the right side.

& The category by which the files on each side are sorted:
+ Choose Name to sort files by file name
+ Choose Size to sort files by file size

+ Choose Modified to sort files by the file modification date

Cycling Monitor Settings
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Use the PROXY Pro Master Cycling Monitor to serially check on multiple remote
connections in the PROXY Pro Master Cycling Monitor window. On the PROXY Pro Master
window, use Options > Cycling Monitor Settings to control the behavior of this window.

General

Use the General tab to specify preferences for the PROXY Pro Master Cycling Monitor
window.

Cycling Monitor Settings |

General | Cycling Monitor |

Enter O seconds to disable I

Cyeling span:
|V 10 = seconds cyveling.

[ Always on top

¥ activate if a new object has been appended

k. I Cancel Apply Help

Set the following preferences:

€ Set the number of seconds to display each connection in the PROXY Pro Master
Cycling Monitor window using Cycling span. Select 0 to disable the automatic cycling
through Host computers. This also disables the Connection > Start Cycling and Connection
> Stop Cycling menu commands in the PROXY Pro Master Cycling Monitor window.

@ If you check Always on top, the PROXY Pro Master Cycling Monitor window is always
the top window.

@ If you check Activate if a new object has been appended, the PROXY Pro Master Cycling
Monitor window is moved to the foreground as soon as you add a new Host computer to
the list on the Cycling Monitor Hosts tab and attempt to establish a connection with that
Host computer.

If you do not check Activate if a new object has been appended, remote Host computers are
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silently added to the Cycling Monitor Hosts list without attempting to establish a connection
in the PROXY Pro Master Cycling Monitor window.

Cycling Monitor Settings

Control the display of the PROXY Pro Master Cycling Monitor window using the Cycling
Monitor Hosts tab.

Cycling Monitor Settings |

General  Cocling Monitor |

— Yiewer Settings

[~ Full Screen % Fit ko window
" Fit 1-to-1

— futo-scroll

¥ Cursor (text-mode anly) [+ Mouse (kext & graphics modes)

— D05 Sessions

Font: |P'r|:|>c~;f gx14 |

] I Cancel Apply Help

Select the following:
€ Use Viewer Settings to specify how a remote computer is displayed by default:

+ Select Full Screen to fill the entire screen of the local computer with a view of the
Host computer monitor in the PROXY Pro Master Cycling Monitor window.

+ Select Fit to window to scale the display of the remote computer to fit into the
PROXY Pro Master Cycling Monitor window.

+ Select Fit 1-to-1 to have each pixel on the remote display correspond to one pixel
on the local computer.

+ Select Halftone to improve the quality of the display when the Master is in Fit to
Window mode.

Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.
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€ Modify the Auto-scroll group options to specify whether you want the window to scroll
when the cursor or mouse reaches a boundary:

+ Select Cursor (text-mode only) to scroll automatically when the cursor comes to
an edge of the PROXY Pro Master Connection Window when you hold the CtrL
key down.

+ Select Mouse (text & graphics mode) to scroll automatically when the mouse
comes to an edge of PROXY Pro Master Connection Window when you hold the
ctry key down.

€ Modify text mode screen options in DOS Sessions:

The Font drop-down list allows you to select the typeface and type size used to display the
remote Host computer screen in the PROXY Pro Master Cycling Monitor window.

By varying the font, you can increase or decrease the size of the Host computer screen
displayed in the PROXY Pro Master Cycling Monitor window. If you use a small font, you
can display more of the Host computer in a small window. To improve readability (but
require a larger window), use a large font.

The fonts in the list are previewed as they actually appear. The names of the fonts are
composed of a typeface name and a size. PROXY Pro text fonts are included with the
software package. Fonts with other typeface names are Windows fonts that are also
suitable for text display.

Default Playback Window Settings

When playing back a PROXY Pro screen recording, the display of the PROXY Pro
Playback window can be controlled using the Playback Window Settings tab.
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Default Playback Window Settings |

Playback. |

— Yiewer Setktings

[~ Full Screen % Fit ko window V¥ Halftone:
" Fit 1-to-1

— futo-scraoll

¥ Cursor (text-mode anly) [ Maouse (text & graphics modes)

— D05 Sessions

Font: |F'r|:|><~;f G 14 |

k. I Cancel Apply Help

Select the following:
€ Use Viewer Settings to specify how a remote computer is displayed by default:

+ Select Full Screen to fill the entire screen of the local computer with a view of the
Host computer monitor in the PROXY Pro Master Cycling Monitor window.

+ Select Fit to window to scale the display of the remote computer to fit into the
PROXY Pro Master Cycling Monitor window.

+ Select Fit 1-to-1 to have each pixel on the remote display correspond to one pixel
on the local computer (set by default).

+ Select Halftone to improve the quality of the display when the Master is in Fit to
Window mode.

Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.

€ Modify the Auto-scroll group options to specify whether you want the window to scroll
when the cursor or mouse reaches a boundary:

+ Select Cursor (text-mode only) to scroll automatically when the cursor comes to
an edge of the PROXY Pro Master Connection Window when you hold the Ctry
key down (set by default).

+ Select Mouse (text & graphics mode) to scroll automatically when the mouse
comes to an edge of PROXY Pro Master Connection Window when you hold the
ctrL key down (set by default).
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4 Modify text mode screen options in DOS Sessions:

The Font drop-down list allows you to select the typeface and type size used to display the
remote Host computer screen in the PROXY Pro Master Cycling Monitor window (set to
"PROXY Pro 8x14" by default).

By varying the font, you can increase or decrease the size of the Host computer screen
displayed in the PROXY Pro Master Cycling Monitor window. If you use a small font, you
can display more of the Host computer in a small window. To improve readability (but
require a larger window), use a large font.

The fonts in the list are previewed as they actually appear. The names of the fonts are
composed of a typeface name and a size. PROXY Pro text fonts are included with the
software package. Fonts with other typeface names are Windows fonts that are also
suitable for text display.

Goto

Use the Goto menu to change tabs in the PROXY Pro Master console window:
Peer-to-Peer Hosts Page

Gateway Hosts Page

Active Connections Page

History Page

Favorites Page

* 6 6 O O o

Cycling Monitor Page

Help

The Help menu contains commands to invoke the Help system, provide access to special
webpages on the Internet, and display information about your PROXY Pro Master license
and configuration.

Press the F1 key or click a Help button (in the windows that offer one) to access context-
sensitive online help.

The Help menu has the following commands:

“Help Topics”

“Proxy Networks Home Page”

“Check for Updates and Maintenance Releases”
“Purchase Additional Licenses”

“Order Technical Support Contract”

“About PROXY Pro Master”

* 6 6 O 0 o

Help Topics
Select Help > Help Topics to access the table of contents for the PROXY Pro Master online
help system. You can display help for any topics you select.

Proxy Networks Home Page
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Select Help > Proxy Networks Home Page to connect to the Proxy Networks Home page,
where you can get access to upgrades, patches, product news, product information, and
technical notes relevant to your PROXY Pro products.

Check for Updates and Maintenance Releases

Select Help > Check for Updates and Maintenance Release to connect to the Proxy Networks
Support page, where you can request information about the latest upgrades, patches and
maintenance releases for PROXY Pro products.

Purchase Additional Licenses
Select Help > Purchase Additional Licenses to connect to the Proxy Networks Store page,
where you can purchase additional licenses of PROXY Pro products.

Order Technical Support Contract

Select Help > Order Technical Support Contract to connect to the Proxy Networks Support
page, where you can order a Maintenance & Support contract your product. These
contracts will provide you access to live technical support and free upgrades during the
contract period for all new maintenance and new feature releases.

About PROXY Pro Master

Select Help > About PROXY Pro Master to display details about the PROXY Pro Master
software that is installed on your computer.

About PROXY Pro Master |

About PROKY Pro |

'FEE‘ PRO=Y Pro Masker

Version 8,0.0,1500

Copyright € 2006-2011 Prosxy Metwarks, Inc, Certain parkions
copyright by Funk Software, a division of Juniper Metworks, Inc,
All Rights Reserved.

Yaur trial period will expire on Saturday, January 14, 2012
30 dayis) remaining.

Licensels)

add License, .. | System Information. . |

| Ik I Help |
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The About PROXY Pro tab displays the following information:
€ The name and version number of your software

& Copyright information

€ The company and user to whom the software is registered
# License key(s) registered with the package

Some features available with PROXY Pro Master are specified by the license key(s) you
purchase. Only the features that you have licensed for use are available to you. You may
have entered one or more licenses. These appear in the License(s) list.

There are two buttons in the About PROXY Pro window:

€ Add License: Add more license keys by clicking Add License and entering your license
number in the Add License Key window. See “Licensing” for more information.

& System Information: Click on System Information to generate a detailed report about the
configuration of your workstation. This report is saved as a text file named
Yourcomputername_Config.txt on your desktop.
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The PROXY Pro Master Connection Window has the following tabs:

4 Select "Remote Control tab" to monitor activity, run applications remotely, and
troubleshoot Host computers using remote control.

€ Select "File Transfer tab" to quickly and securely transfer files between two computers
using the PROXY Pro file transfer feature.

€ Select "Remote Printing tab" (seen only if available to your remote desktop) to print
locally from applications you run on a remote computer.

¢ Select "Remote Management tab" to send view information on hardware and software
resources on a remote computer, and to view/change system settings.

NOTE: Your remote control access rights for Gateway-managed or peer-to-peer
connections are determined by the credentials you use to make the connection. If your
administrator has restricted your access rights, remote control functionality may be
denied or limited.

=101 ]
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Remote Control tab

Select the Remote Control tab on the Master Connection Window to view and operate the
remote Host computer as if you were its local user. Take control of the mouse and
keyboard, or simply monitor remote Host computer activity, without interrupting a local
user on the Host computer.

=10 x|

sy Q |HleEw [Heo®s e o e

Recycle Bin  Web,config -
Shortcut

Computer Windows
Management Update

f\ Remote Control A File Transfer )\ Remote Management /
For Help, press F1 7

Control operations on the remote Host computer using the keyboard and mouse on your
local computer.

Toolbar options

Table below summarizes the functions of icons available on the tool bar when the Master
Connection Window is set to the Remote Control tab.

Icon Function
Q Connects to the selected Host computer with the
Remote Control tab selected.

Connects to the selected Host computer with the File
Transfer tab selected.

Connects to the selected Host computer with the
Remote Printing tab selected.

@ | =

Connects to the selected Host computer with the
Remote Management tab selected.
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Closes Master Connection Window and disconnects
from Host computer.

Displays the screen output from the remote Host
computer using either the entire desktop or the
current monitor screen on the local computer. To
return to the local computer display, click the Full
Screen button on the floating palette, or press F11 in
the Master Connection Window.

Scales the image of the Host computer display to fit
the size of the Connection Window.

Specifies that one pixel of the Host computer display
corresponds to exactly one pixel on the display of the
local computer.

Allows selection of a single monitor, of a multi-
monitor Host, to be selected and “zoomed in” on.

Gives keyboard and mouse control of the Host
computer to the remote user of a PROXY Pro
Gateway-managed connection.

Sends a CTRL-ALT-DEL key sequence to the Host.

Sends a predefined key combination to the Host
computer as though it were entered on the keyboard
of the remote Host computer when you are
connected to it for remote control. This is useful for
sending special key combinations such as CTRL-ALT-
DEL.

]

Tells the Host to disable visual effects.

p
bk

Suppresses keyboard and mouse input at the Host.

o

Automatically copies the contents of the clipboard
between the remote Host computer and the local
computer when you view the Remote Control tab.

A

Copies the contents of the clipboard on the remote
Host computer to the clipboard on your local
computer when you view the Remote Control tab.

Copies the contents of the clipboard on your local
computer to the clipboard on the remote Host
computer when you view the Remote Control tab.

Opens a Chat window in which text messages can be

= sent to Host and to any other Masters connected to
that Host.
Copies a selected region of the Host computer display
ﬂ]’ in the Master Connection Window to the clipboard on

your local computer from the Remote Control tab.
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Displays the Connection Window Settings dialog,
which contains settings for the Remote Control tab.

Copy information to the remote clipboard

Transfer text, graphics, or other information from the clipboard on your local computer to
the clipboard on the Host computer.

To copy information to the remote clipboard:

1 Select the text or graphic on your local computer that you want to transfer to your Host
computer. For example, if you use a Paint program, you might select a portion of a
drawing you are making on your local computer.

}" Panorama.bmp - Paint [_ O] X]

File Edit View Image Colors Help

a Panorama.psp [1:4] [Layeﬂ] =] B3

Fr [ IR [ O I

— | 7 I O o I 5

lFor Help, click Help Topics on the Help Menu, 167,50

Selection to transfer from local computer

2 Copy the information that you want to move to the Host computer to the clipboard on
your local computer; for example, use an application’s Cut or Copy command.

3 To transfer the information from the clipboard on the local computer to the clipboard
on your Host computer, return to the PROXY Pro Master Connection Window and select
Edit > Send Clipboard to Host. You can also click the Send Clipboard tool bar button.

4 Inthe PROXY Pro Master Connection Window, paste the text or graphic into an
application that you are running remotely on the Host computer.
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- PROXYGATEWAY via SUPPORT - PROXY Pro Master ...
J Connection Edit View Options Goto Help

Y )

[EE0| e |8 e o | & H

=4 untitled - Paint

File Edit View Image Colors Help

\'
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I\Remole Control 4 File Transfer A Remote Printing # Remote Managemen

For Help, press F1 2

Selection transferred to Host computer

Copy information from the remote clipboard

Transfer text, graphics, or other information, from the clipboard on the remote Host
computer to the clipboard on your local computer.

To copy information from the remote clipboard:

1 Select the text or graphic you want to transfer from an application running on your Host
computer. For example, if you are using a word processing program, you might select a
sentence or a paragraph that you want to transfer.

2 Copy the desired information to the clipboard on the Host computer. Most programs let
you copy information to the clipboard by choosing Edit > Copy or by pressing CTRL+C.

3 Transfer the information from the clipboard on the Host computer to the clipboard on
your local computer by choosing Edit > Get Clipboard from Host, or by clicking the Get
Clipboard button on the tool bar.

4 Paste the text or graphic into an application running on your local computer.

NOTE: PROXY Pro supports clipboard formats by value rather than by reference. The
actual data that you paste, such as text, must be in the clipboard. If the clipboard
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contains only a reference to the data, such as a file name, PROXY Pro displays a
message that the clipboard does not contain a supported format.

Operate your mouse on the remote Host computer
During remote control sessions, the mouse can exist in the following states:

€ When the mouse cursor is inside the PROXY Pro Master Connection Window, the
mouse is remote and all movements and clicks are transmitted to the Host computer.

€ When the mouse cursor is anywhere else, the mouse is local and any mouse
operation affects your local Windows session only.

Fit-to-Window

The Fit-to-Window display option in the Master preserves the Host screen aspect ratio, and
centers the display in the available space. Also, text mode screen will be centered in available
space in all display modes.

# SUPPORT via SUPPORY - PROXY Pro Master Connection =13 |

| Gonoection Edt Yew Opbons Goto Mep ,
LPBE O El-fero® [O)e o me.q o =g

AL
TR L L
wo v ey

| Remote Control A Fila Tracufer te Pricting 2 >
For Help, press F1 | S

To improve the quality of display in Fit-to-Window mode, choose Options > Connection
Window Settings and select the Halftone checkbox.

Note: The Halftone option affects only the way the screen is rendered by the Master, and
may increase CPU usage on the Master.

Resize the PROXY Pro Master Connection Window
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Resize the PROXY Pro Master Connection Window by dragging its border. When the
View > Fit 1-to-1 display option is used, you cannot resize the window larger than the Host
computer screen size. If you hold down the CTRL key when you resize the window, it
retains the aspect ratio of the Host computer display.

Request/release input control

When connected to a Host computer, two input control states are possible:
4 With input control, you control the mouse and keyboard of the Host.

4 Without input control, you monitor the Host computer but do not control it.

For a peer-to-peer connection, there can be only one Master connected to a Host. In this
case, you might want to toggle the state to have or not have input control of the Host.

For a Gateway-managed connection, multiple users can be connected to the same Host.
In this case, another user may request input control of the Host. Provided you have the
proper access control rights, you can request or relinquish input control to the other user.

Toggle the input control state by clicking an icon in the toolbar of the PROXY Pro Master
Connection window. The icon you click depends on the type of connection you have to
the Host computer.

To toggle input control of a Host computer:

L

& Click o) or choose Edit > Input Control from the menu.

Open chat window

When connected to a chat-enabled Host (i.e. PROXY Pro Host 6.0 or later), you will
automatically join a chat room including the Host end-user and any other Master users
connected to that host. A chat window can be opened to send and receive text messages

with the user at the Host machine by clicking on & icon on the tool bar. When you type
a text message and click Send, the message will be sent to a similar chat window on the
Host display. If the chat window is not already up on Host display, it will automatically be
started to display the message.

If you are using a Gateway-managed connection to the Host, and there are other PROXY
Pro Master users connected to the same Host via the same Gateway, any text messages
will automatically be sent to all the other Master displays as well.

NOTE: Chat support requires that all components (Host, Master, Gateway) be version
6.0 or later.

Capture a screen image from the Host computer display

All or part of the Host display can be captured and copied to the clipboard on your local
computer. After copying a region of the Host computer display, paste the image into a
document or image processing application that you have running on your local computer.

To copy screen images to the clipboard on your local computer, follow these steps:
1 From the Remote Control tab of the PROXY Pro Master Connection Window,
choose Edit > Copy Graphics Screen or click the r_ icon on the tool bar. The cursor

changes to a top left corner angle icon r_ to indicate where to place the first anchor of
the selection.
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2 Move to the top left corner of the rectangle to the top left corner of the graphic or
region of the screen that you wish to copy and hold down the left mouse button at that
location.

3 While holding down the left mouse button, drag the cursor to the bottom right corner of
the region you want to capture. As you move your mouse, the area you select is indicated
visually on the screen.

4 When you have selected the area you want, release the mouse button.

The captured graphic is copied to the clipboard on your local computer and you can
paste the image into a graphics or word processing document.

Copy text from the Host computer display

When the Host computer is operating in full-screen text mode, copy text from your remote
Host computer to the system clipboard of your local computer. To do so, follow these
steps:

1 From the Remote Control tab of the PROXY Pro Master Connection Window, choose
Edit > Copy Text Screen. The cursor changes its shape to indicate that you can start
selecting text.

2 Use your mouse to select the text that you want to capture from the Host computer.

3 When you select the text, the copy text mode is complete and the text is copied into
the clipboard on your local computer. You can paste it into any application you open on
your local computer.

Use CTRL-ALT-DEL and other special keys on the remote
computer

Send special key combinations that would normally be intercepted by your local computer
to the remote computer. To send a key combination to the Host computer, select Edit >
Send Keystroke from the PROXY Pro Master Connection Window., and then select the
key combination.

For example, select Edit > Send Keystroke > Remote Alt+Ctrl+Del to send CTRL-ALT-DEL t0
your Host computer.

Special key combinations are also interpreted by the Host according to the values that
you specify in the PROXY Pro Master console window when you select Options >
Keyboard Mapping. For more information, see “Keyboard Mapping”.
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File Transfer tab

Use the File Transfer tab on the Master Connection Window to transfer files between your
local computer and the remote Host computer. Other file maintenance tasks can be
performed on either computer.

& "File transfer resume"

€ "Manipulate files and folders for file transfer"

% PROXYGATEWAY via SUPPORT - PROXY Pro Master Connecti  [lj[m]

J_u:unnectiu:un Wiew Options Goto Help

2R E= =0 |9 X|aEn

W TEMPYgraphicsy™ ™ o itemph e
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=) TEMP =0 temp
) graphics LI T j|
M ame | a
background. brap 4 lient
check_x=.bmp evalCertz. exe

client_authenticated.ico T || MYE brap -
4| | > 1] | >

I‘H. Fernote Contraol ,]H.File Transfer l.-{. Femate Printing h Fernote Management {r
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The file transfer display is split into four adjustable panels. By default, files for your local
computer are on the left, and those for your remote Host computer are on the right. The
following defaults apply:

€ The top left panel displays the folder hierarchies on the local computer. Use these
panels to browse your local and remote directories to select folders.

& A text field at the top of the tab, one for the left side and another for the right, indicates
the full path name of the currently open or selected folder. Use this text field to navigate
directly to a specific location on a local or remote file system.

€ The bottom left panel shows the files in any folder that you select in the top left panel.
Follow these steps to transfer files between the local and remote computers:

1 From files located on the lower panel of the File Transfer tab, select one or more files to
be transferred:

+ Select from the left side if you plan to transfer files from your local Master
computer to the remote Host computer.

+ Select from the right side if you plan to transfer files from the remote Host
computer to your local Master computer.
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2 Select a target folder on the local or remote computer from the top panel. This is the
computer to which you plan to transfer files.

3 Drag and drop the files from your source to your target directory, or right-click the
selected files you plan to transfer:

€ Select Get to transfer files from the Host computer to the local computer. Selected files
are copied from the Host computer to the directory you select in the upper panel of the
local computer directory listing.

€ Select Put to transfer files from the local computer to the Host computer. Selected files
are copied from the local computer to the directory you select in the upper panel of the
Host computer directory listing.

Tool bar options

Table below summarizes the functions of icons available on the tool bar when the Master
Connection Window is set to the File Transfer tab.

Icon Function
E Connects to the selected Host computer with
the Remote Control tab selected.

Connects to the selected Host computer with
the File Transfer tab selected.

Connects to the selected Host computer with
the Remote Printing tab selected.

@f | =

Connects to the selected Host computer with
the Remote Management tab selected.

3

Closes Master Connection Window and
disconnects from Host computer.

Get selected file or folder from the other
directory.

L I T %

Put selected file or folder in the other directory.

s

Deleted selected file or folder.

E‘jfi Create a new directory or subdirectory.
> Move selected file or folder to a new folder on
the same computer.
Rename selected file or folder.
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File transfer resume

Occasionally while transferring files, your connection may be interrupted, leaving some
files only partially transferred. If the files are large, retransmitting them from the beginning
again could prove very expensive. For this reason, PROXY Pro Master provides a File
transfer resume feature, which allows you to resume interrupted transfers exactly where
you left off.

After a connection is interrupted (or if you manually cancel an in-process transfer), the
next time you connect to the same Host and select the File Transfer tab in the Connection
Window, PROXY Pro Master scans both the local machine and the remote Host machine
for records of interrupted file transfers. The list of any such resumable file transfers is
then automatically presented in the Confirm Copy Resume window:

Confirm Copy Resume !E[ |

The Following files were in progress, Select those you wish to resume
and click "Resume", or click "Cancel” ko discard:

&5% [V ci\Documents and Settingstadmin.doc
r

-
-

Resume Cancel

File transfer resume - Confirm Copy Resume dialog

Check or uncheck each file you wish to resume, and then click the Resume button. At that
point, file transfers for the selected files are resumed, and the transfers will run either to
completion, or until the connection is again interrupted.

File transfers for any files that you uncheck will not be resumed, and their partial contents
will be discarded. Also if you click Cancel instead of Resume, all partial contents will be
discarded, and the record of those transfers will be deleted. Thus you have only one
chance to resume a set of interrupted transfers.

NOTE: PROXY Pro Master does not resume the transfer of an entire directory or
directory tree, only the individual files that were in process at the time the connection was
lost.

NOTE: PROXY Pro Master only allows transfers in one direction or the other (to or from
the Host) at a time, so the list of resumable file transfers will always consist of only files to
be sent to the Host, or only files to be received from the Host. PROXY Pro Master does
maintain a separate list of resumable file transfers for each Host.
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Manipulate files and folders for file transfer
The following file and folder information is listed on the File Transfer tab:

€ The top panels display the folder hierarchy, but only reveal the contents of the nodes
of the tree that you explicitly open.

€ No files appear in the top panels, nor do any folders appear in any bottom panels.

& A drive, folder, or one or more files must be selected before you can perform most file
transfer operations.

When you double-click a computer, drive or folder, a list of all of the folders (or devices)
that it contains displays in the top panel. The single files are listed in the bottom panel.
Display the files within any folder by selecting the folder in the top panel and choosing the
List Directory command from the right-click menu.

€ Use standard Windows mouse and keyboard controls to browse your directory
listings.

& Perform the following directory organization tasks on either computer by right-clicking
one or more files or a folder, and selecting one of the following commands:

*

Delete - to delete selected files or folders.
+ Rename - to rename files or folders.

+ Create Directory - to create folders by entering the folder path.

*

Move - to move files or folders by entering the folder path.

+ Copy - to copy files or folders by entering the folder path.
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Remote Printing tab

Print remote applications on printers local to your machine using the Remote Printing tab
on the Master Connection Window. An active remote control connection must be
maintained between the Host computer and the local computer to complete the remote
printing process.

4 "Configure a Host computer for printing"
4 "Configure a local computer for printing"
€ "Print your remote printing job"
2

"Cancel a remote print job"

=% PROXYGATEWAY via SUPPORT - PROXY Pro Master Connection  [[=] [E3

Conneckion  Miew Options Goko Help

|
wgs w0
Localprirter: [N - |

Diriveer:
Part:

Statuz: Connected to SUPPORT
Currently printing:

T otal pages:
CanzelJob |

Femote Control }". File Tramsfer }-.IRemute Printing lHr

For Help, press F1 L

Tool bar options

Table below summarizes the functions of icons available on the tool bar when the Master
Connection Window is set to the Remote Printing tab.

Icon Function
E Connects to the selected Host computer with
the Remote Control tab selected.

’E Connects to the selected Host computer with
the File Transfer tab selected.
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i}

Connects to the selected Host computer with
the Remote Printing tab selected.

Connects to the selected Host computer with
the Remote Management tab selected.

(%} Closes Master Connection Window and
disconnects from Host computer.

Configure a Host computer for printing

After you install PROXY Pro Host, a printer port named PROXY Pro: is listed in
Windows as a port that can be associated with a printer when you select Start > Control
Panel > Printers and Faxes. To print from a remote application to a printer that is
accessible from your local computer, the Host computer must have the following:

& A print driver that is compatible with the local printer must be installed.
€ The driver must be associated with the PROXY Pro: port.

For optimal results, you should select the same printer as the one you use for local print
jobs.

NOTE: You must install a printer driver and associate it with the PROXY Pro: printer port
on your local computer before using this service. See the PROXY Pro Host Guide for
more details.

Configure a local computer for printing
The following options are available for remote printing:

€ Select a local printer from the Local printer drop-down list. Make sure that you select
the local printer of the same type whose driver you map to the PROXY Pro port of your
remote Host computer.

4 View information about a current print job.

4 Cancel current print job.

Print your remote printing job

Once you configure the Host and local computers for printing, you can perform remote
printing any time you establish a remote connection.

Note the following:

€ To execute a print job from a remote application, use the printing option associated
with that application when you are connected to it on the remote Host computer.

€ Make sure that the printer that you select for the remote print job is the same one that
you map to the PROXY Pro port of your remote Host computer.

€ Your print job is routed to the local printer that you select on your local computer using
the Local printer drop-down list on the Remote Printing tab of the PROXY Pro Master
Connection Window.

Cancel aremote print job
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To cancel a current remote print job, click Cancel Job on the Remote Printing tab of the
PROXY Pro Master Connection window. This clears the print queues on both the
local and Host computers. Canceling a print job does not affect your connection.

However, if you disconnect your connection to the Host computer, any active print job is
cancelled.
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Remote Management tab

Use the Remote Management tab on the Master Connection Window to view and manage
information about hardware, software, system settings, services, processes, events and
more on the remote Host computer.

“Hardware Manager”
“Software Manager”
“System Manager”

“Shared Resource Manager”
“Account Manager”

“Service Manager”

“Process Manager”
“Registry Manager”

“Event Manager”

® 6 6 O 6 O 6 O 0o

“Power Manager”

2 PROXY Pro Master M=l

Jgannecticun Wiew Options Goto  Help

Y R

= j Remate Computer Management
Hardware Manager
Software Manager

Swsbem Manager

Remote Computer Management

Marne

Hardware Manager

Shared Resource Manager %SDHW”E Manager
Accourt Manager 2] System Manager
g Service Manager & Shared Resource Manager
Process Manager g.ﬁ.cmunt Manager
! Registry Manager Service Manager
+ Event Manager F‘ru:ucess [Manager
- Iy Power Manager | Registry Manager

Event Manager
35 Power Manager

F.ernobe Control )-.. File Transfar }-.. F.ernoke Printing _J‘-..Remnte Management jr
For Help, press F1 =

NOTE: PROXY Pro uses Microsoft Windows Management Instrumentation (WMI) to
request, receive and modify management information on the remote Host computer.
Because PROXY Pro uses the secure PROXY Pro connection to transport WMI
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(Remote Procedure Call) or file/print sharing to be enabled on the remote Host computer

in order to operate.

NOTE: If the Master cannot find the redistributable MSXML6 system component, an error
message will appear in the Remote Management window. In this case, you must install

MSXMLG6 and restart the Master. See http://www.microsoft.com for more information

about the redistributable msxml6.msi package.

Tool bar options

Table below summarizes the functions of icons available on the tool bar when the Master
Connection Window is set to the Remote Management tab.

Icon

Function

Connects to the selected Host computer with
the Remote Control tab selected.

Connects to the selected Host computer with
the File Transfer tab selected.

Bf | o

Connects to the selected Host computer with
the Remote Printing tab selected.

Connects to the selected Host computer with
the Remote Management tab selected.

%)

Closes Master Connection Window and
disconnects from Host computer.

[

Refresh result pane by resending WMI
command to selected Host computer.

Transpose columns and rows in result pane.

Filter:Basic shows limited set of attributes and
values for any selected component.

Filter:Default shows a default set of attributes
and values for any selected component.

Filter:All shows full set of attributes and values
for any selected component.

Hardware Manager

Hardware Manager provides you with a graphical view of physical devices and resources
available on the remote Host computer.

133



PROXY Pro Master Guide

% PROXY Pro Master

Jgnnnecticun View ©Ophions Goto Help

wgsEy Q

= j Rermoke Computer Managemenk
; WHardware Manager

+

Software Manager

-- Swskern Manager

shared Resource Manager
g Account Manager

-- Service Manager

-- Process Manager

; ! Registry Manager

Ewent Manager

_,5 Power Manager

=

Hardware Manager

Marne

j Bus

< Cache Mermary

wis CDROM Drive
P

S Logical Disk,

S Logical Disk Changes
i Memory Devices
Modem

& Metwork Adapker Configuration
ENetwnrk Adapters
_§'PCMCIA Devices
S Physical Disk

<t Physical Mernary

Q Prinker

J§scsl

& system Enclosure
&2 USE Parts

'\-'ideu:u Conkroller

W video Monitar

Fernote Control }.' File TramsFer }.' Ferncte Printing }\'Remnle Management lf

For Help, press F1

€ Select "BIOS" to view details about Basic Input/Output System (BIOS) on remote Host

computer.

€ Select "Bus" to view details about the physical system bus on remote Host computer.

€ Select "Cache Memory" to view details about internal and external cache memory on

the remote Host computer.

& Select "CDROM Drive" to view details about the CDROM drive on the remote Host

computer.

€ Select "CPU" to view details about the CPU(s) on the remote Host computer.

@ Select "Logical Disk" to view details about data source(s) that resolve to actual local
storage device(s) on the remote Host computer.

# Select "Logical Disk Changes" to view details about network storage devices that are
mapped as logical disks on the remote Host computer.

& Select "Memory Devices" to view details about memory devices on the remote Host

computer .

€ Select "Modem" to view details about any POTS (Plain Old Telephone Service)

modems on the remote Host computer.

€ Select "Network Adapter Configuration” to view details about extra properties and
methods that support the management of the TCP/IP and Internetwork Packet Exchange
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(IPX) protocols that are independent from the network adapters on the remote Host
computer.

& Select "Network Adapters" to view details about network adapters on the remote Host
computer.

& Select "PCMCIA Devices" to view details about PCMCIA devices on the remote Host
computer.

€ Select "Physical Disk" to view details about physical disk drives on the remote Host
computer.

€ Select "Physical Memory" to view details about for physical memory on the remote Host
computer.

& Select "Printer" to view details about for printers connected to the remote Host
computer.

& Select "SCSI" to view details about SCSI devices connected to the remote Host
computer.

€ Select "System Enclosure" to view details about the system enclosure for the remote
Host computer.

& Select "USB Ports" to view details about the universal serial bus for the remote Host
computer.

€ Select "Video Controller" to view details about the video controller on the remote Host
computer.

€ Select "Video Monitor" to view details about the video monitor connected to the remote
Host computer.

BIOS

BIOS provides you with a graphical view of settings for the BIOS running on the remote
Host computer system.

BIOS has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

. Name

. BIOS Characteristics
o BIOS Version

° Build Number

. Caption

J Code Set

. Current Language

o Description

° Identification Code

° Installable Languages
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. Language Date
° List of Languages
] Manufacturer
o Other Target OS
° Primary BIOS
o Release Date
. Serial Number
. SMBIOS BIOS Version
° SMBIOS Major Version
° SMBIOS Minor Version
° SMBIOS Present
[ Software Element ID
° Software Element State
] Status
] Target Operating System
. Version
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve BIOS information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class
BIOS Win32_BIOS
Bus

Bus provides you with a graphical view of settings for the bus on the remote Host
computer system.

Bus has the following attributes (double-click on any attribute to get a popup window with
table of attributes and values):
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° Name

. Bus Type

. Device ID

. System Name

° Description

° Availability

] Bus Num

] Caption

° Config Manager Error Code

° Config Manager User Config

° Creation Class Name

° Error Cleared

. Error Description

o Install Date

o Last Error Code

. PNP Device ID

. Power Management

Capabilities

. Power Management Supported

. Status

° Status Info

° System Creation Class Name
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Bus information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class

Bus Win32_Bus
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Cache Memory

Cache Memory provides you with a graphical view of settings for internal and external
cache memory on the remote Host computer system.

Cache Memory has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Name

. Block Size

. Installed Size

. Max Cache Size

[ Device ID

[ Cache Type

° Number of Blocks

° Cache Speed

° Install Date

. Location

] System Name

° Write Policy

. Access

o Additional Error Data
o Associativity

° Availability

° Caption

° Config Manager Error Code
° Config Manager USer Config
J Correctable Error

J Creation Class Name

. Current SRAM

J Description
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Ending Address

Error Access

o Error Address

° Error Cleared

. Error Correct Type
. Error Data

° Error Data Order

° Error Description

° Error Info

° Error Methodology

. Error Resolution

° Error Time

. Error Transfer Size
. Flush Timer

o Last Error Code

o Level

. Line Size

. Other Error Description
o PNP Device ID

° Power Management
Capabilities

. Power Management Supported
. Purpose

° Read Policy

° Replacement Policy
° Starting Address

] Status

. Status Info

J Supported SRAM

Connection Window Operation
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WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Cache Memory information
from the remote Host computer. Please consult this class for more detailed information

System Creation Class Name

System Level Address

about the specific attributes and values available.

Component

WMI Class

Cache Memory

CDROM Drive

CDROM Dirive provides you with a graphical view of settings for the CDROM drive on the

remote Host computer system.

CDROM Dirive has the following attributes (double-click on any attribute to get a popup

window with table of attributes and values):
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Availability

Capabilities

Capability Descriptions
Caption

Compression Method

Config Manager Error Code
Config Manager User Config
Creation Class Name
Default Block Size
Description

Device ID

Drive

Drive Integrity

Win32_CacheMemory



Error Cleared

Error Description

Error Methodology

File System Flags

File System Flags Ex

ID

Install Date

Last Error Code
Manufacturer

Max Block Size

Maximum Component Length
Max Media Size

Media Loaded

Media Type

Mfr Assigned Revision Level
Min Block Size

Name

Needs Cleaning

Number of Media Supported
PNP Device ID

Power Management

Capabilities

Power Management Supported
Revision Level

SCSI Bus

SCSI Logical Unit

SCSI Port

SCSI Target ID

Serial Number

Connection Window Operation
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WMI Class

Size

Status

Status Info

System Creation Class Name
System Name

Transfer Rate

Volume Name

Volume Serial Number

PROXY Pro uses the following WMI Class to request/retrieve CDROM Drive information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class
CDROM Drive Win32_CDROMDrive
CPU

CPU provides you with a graphical view of settings for the CPU(s) on the remote Host
computer system.

Each CPU has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):
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Name

Processor Type
Version

CPU Status

Current Clock Speed
Address Width
Architecture

Availability



Caption

Config Manager Error Code
Config Manager User Config
Creation Class Name
Current Voltage
Data Width
Description

Device ID

Error Cleared

Error Description
Ext Clock

Family

Install date

L2 Cache Size

L2 Cache Speed

L3 Cache Size

L3 Cache Speed

Last Error Code
Level

Load Percentage
Manufacturer

Max Clock Speed

Number of Cores

Number of Logical Processors

Other Family Description
PNP Device ID

Power Management

Capabilities

Power Management Supported

Connection Window Operation
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° Processor ID
] Revision
° Role
° Socket Designation
] Status
o Status Info
° Stepping
o Status Info
. System Creation Class Name
. System Name
° Unique ID
° Upgrade Method
° Voltage Caps
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve CPU information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class
CPU Win32_CPU
Logical Disk

Logical Disk provides you with a graphical view of settings for data source(s) that resolve
to actual local storage device(s) on the remote Host computer system.

Logical Disk has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Name
o Description
. Media Type
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Free Space

Total Size

File System

Install Date

System Name

Status Info

Purpose

Access

Availability

Block Size

Caption

Compressed

Config Manager Error Code
Config Manager USer Config
Creation Class Name

Device ID

Drive Type

Error Cleared

Error Methodology

Last Error Code

Maximum Component Length
Number of Blocks

PNP Device ID

Power Management Capabilities
Power Management Supported
Provider Name

Quotas Disabled

Quotas Incomplete

Quotas Rebuilding

Connection Window Operation
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WMI Class

Status

Supports Disk Quotas

Supports File Based Compression
System Creation Class Name
Volume Dirty

Volume Name

Volume Serial Number

PROXY Pro uses the following WMI Class to request/retrieve Logical Disk information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component

WMI Class

Logical Disk Win32_LogicalDisk

Logical Disk Changes

Logical Disk Changes provides you with a graphical view of settings for network storage
devices that are mapped as logical disks on the remote Host computer system.

Logical Disk Changes has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):
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Access

Availability

Block Size

Caption

Compressed

Config Manager Error Code
Config Manager User Config

Creation Class Name



Description

Device ID

Error Cleared

Error Description

Error Methodology

File System

Free Space

Install Date

Last Error Code

Maximum Component Length
Name

Number of Blocks

PNP Device ID

Power Management Capabilities
Power Management Supported
Provider Name

Purpose

Quotas Disabled

Quotas Incomplete

Quotas Rebuilding

Session ID

Size

Status

Status Info

Supports Disk Quotas
Supports File Based Compression
System Creation Class Name
System Name

Volume Name

Connection Window Operation
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° Volume Serial Number

WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Logical Disk Changes
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component WMI Class

Logical Disk

Changes Win32_MappedLogicalDisk

Memory Devices

Memory Devices provides you with a graphical view of settings for memory devices on
the remote Host computer system.

Memory Devices has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Access

o Additional Error Data

. Availability

o Block Size

. Caption

° Config Manager Error Code
o Config Manager User Config
[ Correctable Error

. Creation Class Name

o Description

° Device ID

. Ending Address

° Error Access

. Error Address
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PROXY Pro uses the following WMI Class to request/retrieve Memory Device information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Error Cleared

Error Data

Error Data Order

Error Description

Error Granularity

Error Info

Error Methodology

Error Resolution

Error Time

Error Transfer Size
Install Date

Last Error Code

Name

Number of Blocks

Other Error Description
PNP Device ID

Power Management Capabilities
Power Management Supported
Purpose

Starting Address

Status

Status Info

System Creation Class Name
System Level Address

System Name

Connection Window Operation
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Component WMI Class
Memory Devices Win32_MemoryDevice
Modem

Modem provides you with a graphical view of settings for any POTS (Plain Old
Telephone Service) modems on the remote Host computer system.

Modem has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

° Answer Mode

° Attached To

° Availability

. Blind Off

. Blind On

. Caption

. Compatibility Flags

. Compression Info

. Compression Off

. Compression On

° Config Manager Error Code
o Config Manager User Config
. Configuration Dialog
. Countries Supported]]
° Country Selected

. Creation Class Name

° Current Passwords]|]

. DCB[]

. Default[]

. Description

[ Device ID

° Device Loader

o Device Type

o Dial Type

° Driver Date

. Error Cleared

. Error Control Forced
° Error Control Info
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Error Control Off

Error Control On

Error Description

Flow Control Hard

Flow Control Off

Flow Control Soft
Inactivity Scale
Inactivity Timeout
Index

Install Date

Last Error Code

Max Baud Rate To Phone
Max Baud Rate To Serial Port
Max Number Of Passwords
Model

Modem Inf Path

Modem Inf Section
Modulation Bell
Modulation CCITT
Modulation Scheme

Name

PNP Device ID

Port Sub Class

Power Management Capabilities[]
Power Management Supported
Prefix

Properties|]

Provider Name

Pulse

Reset

Responses Key Name
Rings Before Answer
Speaker Mode Dial
Speaker Mode Off
Speaker Mode On

Speaker Mode Setup
Speaker Volume High
Speaker Volume Info

Speaker Volume Low
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° Speaker Volume Med
] Status
° Status Info
° String Format
o Supports Callback
. Supports Synchronous Connect
. System Creation Class Name
. System Name
° Terminator
o Time Of Last Reset
. Tone
° Voice Switch Feature
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Modem information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component WMI Class

Modem Win32_POTSModem

Network Adapter Configuration

Network Adapter Configuration provides you with a graphical view of settings for extra
properties and methods that support the management of the TCP/IP and Internetwork
Packet Exchange (IPX) protocols that are independent from the network adapters on the
remote Host computer system.

Network Adapter Configuration has the following attributes (double-click on any attribute
to get a popup window with table of attributes and values):

° Arp Always Source Route
J Arp Use Ether SNAP

° Caption

o Database Path

o Dead GW Detect Enabled
° Default IP Gatewayl[]

° Default TOS
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Default TTL

Description

DHCP Enabled

DHCP Lease Expires

DHCP Lease Obtained

DHCP Server

DNS Domain

DNS Domain Suffix Search Order|[]
DNS Enabled For WINS Resolution
DNS Host Name

DNS Server Search Order|[]
Domain DNS Registration Enabled
Forward Buffer Memory

Full DNS Registration Enabled
Gateway Cost Metric[]

IGMP Level

Index

Interface Index

IP Address/[]

IP Connection Metric

IP Enabled

IP Filter Security Enabled

IP Port Security Enabled
IPSec Permit IP Protocols/[]
IPSec Permit TCP Ports[]
IPSec Permit UDP Ports/[]

IP Subnet[]

IP Use Zero Broadcast

IPX Address

IPX Enabled

IPX Frame Typel]

IPX Media Type

IPX Network Number/[]

IPX Virtual Net Number

Keep Alive Interval

Keep AliveT ime

MAC Address

MTU

Num Forward Packets
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o PMTUBH Detect Enabled
° PMTU Discovery Enabled
. Service Name
° Setting ID
° Tcpip Netbios Options
° Tcp Max Connect Retransmissions
. Tcp Max Data Retransmissions
. Tcp Num Connections
] Tcp Use RFC1122 Urgent Pointer
o Tcp Window Size
° WINS Enable LM Hosts Lookup
° WINS Host Lookup File
. WINS Primary Server
] WINS Scope ID
o WINS Secondary Server
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Network Adapter
Configuration information from the remote Host computer. Please consult this class for
more detailed information about the specific attributes and values available.

Component WMI Class

Network Adapter

Configuration Win32_NetworkAdapterConfiguration

Network Adapters

Network Adapters provides you with a graphical view of settings for network adapters on
the remote Host computer system.

Network Adapters has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):

° Adapter Type

o Adapter Type ID
. Auto Sense

° Availability

o Caption
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] Config Manager Error Code
° Config Manager User Config
. Creation Class Name
° Description
. Device ID
o Error Cleared
. Error Description
] GUID
. Index
o Install Date
° Installed
° Interface Index
o Last Error Code
o MAC Address
o Manufacturer
o Max Number Controlled
o Max Speed
° Name
[ Net Connection ID
° Net Connection Status
° Net Enabled
° Network Addresses]|]
o Permanent Address
. Physical Adapter
° PNP Device ID
. Power Management Capabilities|]
. Power Management Supported
° Product Name
° Service Name
° Speed
[ Status
° Status Info
] System CreationClass Name
. System Name
o Time Of Last Reset
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Network Adapter
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.
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Component WMI Class

Network Adapters Win32_NetworkAdapter

PCMCIA Devices

PCMCIA Devices provides you with a graphical view of settings for PCMCIA devices on
the remote Host computer system.

PCMCIA Devices has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Availability
. Caption
° Config Manager Error Code
° Config Manager User Config
° Creation Class Name
° Description
[ Device ID
o Error Cleared
. Error Description
o Install Date
o Last Error Code
o Manufacturer
° Max Number Controlled
. Name
° PNP Device ID
. Power Management Capabilities[]
° Power Management Supported
. Protocol Supported
. Status
o Status Info
J System Creation Class Name
. System Name
° Time Of Last Reset
WMI Class
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PROXY Pro uses the following WMI Class to request/retrieve PCMCIA information from
the remote Host computer. Please consult this class for more detailed information about

the specific attributes and values available.

Component

WMI Class

PCMCIA Devices

Win32_PCMCIAController

Physical Disk

Physical Disk provides you with a graphical view of settings for physical disk drives on
the remote Host computer system.

Physical Disk has the following attributes (double-click on any attribute to get a popup

window with table of attributes and values):

Availability
Bytes Per Sector
Capabilities|]

Capability Descriptions]|]

Caption

Compression Method
Config Manager Error Code
Config Manager User Config

Creation Class Name

Default Block Size
Description
Device ID

Error Cleared
Error Description
Error Methodology
Firmware Revision
Index

Install Date
Interface Type
Last Error Code
Manufacturer

Max Block Size
Max Media Size
Media Loaded

Media Type
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WMI Class

Min Block Size

Model

Name

Needs Cleaning

Number Of Media Supported
Partitions

PNP Device ID

Power Management Capabilities[]
Power Management Supported
SCSI Bus

SCSI Logical Unit

SCSI Port

SCSI Target Id

Sectors Per Track

Serial Number

Signature

Size

Status

StatusInfo

System Creation Class Name
System Name

Total Cylinders

Total Heads

Total Sectors

Total Tracks

Tracks Per Cylinder

PROXY Pro uses the following WMI Class to request/retrieve Physical Disk information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component

WMI Class

Physical

Disk Win32_DiskDrive

Physical Memory

Physical Memory provides you with a graphical view of settings for physical memory on
the remote Host computer system.
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Physical Memory has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

WMI Class

Bank Label

Capacity

Caption

Creation Class Name
Data Width
Description

Device Locator

Form Factor

Hot Swappable
Install Date
Interleave Data Depth
Interleave Position
Manufacturer

Memory Type

Model

Name

Other Identifying Info
Part Number
Position In Row
Powered On
Removable
Replaceable

Serial Number

SKU

Speed

Status

Tag

Total Width

Type Detail

Version

PROXY Pro uses the following WMI Class to request/retrieve Physical Memory
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.
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Component WMI Class
Physical Memory Win32_PhysicalMemory
Printer

Printer provides you with a graphical view of settings for printers connected to the remote
Host computer system.

Printer has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

. Attributes

° Availability

° Available Job Sheets]|]

. Average Pages Per Minute
° Capabilities]|]

. Capability Descriptions|]
. Caption

. Char Sets Supportedl[]

] Comment

° Config Manager Error Code
° Config Manager User Config
. Creation Class Name

. Current Capabilities]]

° Current Char Set

o Current Language

° Current Mime Type

° Current Natural Language
o Current Paper Type

] Default

o Default Capabilities]]

o Default Copies

° Default Language

° Default Mime Type

° Default Number Up

o Default Paper Type

. Default Priority

J Description

. Detected Error State
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Device ID

Direct

Do Complete First

Driver Name

Enable BIDI

Enable Dev Query Print
Error Cleared

Error Description

Error Information(]
Extended Detected Error State
Extended Printer Status
Hidden

Horizontal Resolution
Install Date

Job Count Since Last Reset
Keep Printed Jobs
Languages Supported[]

Last Error Code

Local

Location

Marking Technology

Max Copies

Max Number Up

Max Size Supported

Mime Types Supportedl]
Name

Natural Languages Supported][]
Network

Paper Sizes Supported[]
Paper Types Availablel[]
Parameters

PNP Device ID

Port Name

Power Management Capabilities[]
Power Management Supported
Printer Paper Names]|]
Printer State

Printer Status

Print Job Data Type
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o Print Processor
° Priority
. Published
o Queued
o Raw Only
° Separator File
. Server Name
] Shared
° Share Name
. Spool Enabled
° Start Time
[ Status
o Status Info
] System Creation Class Name
] System Name
. Time Of Last Reset
. Until Time
° Vertical Resolution
° Work Offline
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Printer information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class
Printer Win32_Printer
SCSI

SCSI provides you with a graphical view of settings for SCSI devices connected to the
remote Host computer system.

SCSI has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

° Availability
J Caption
. Config Manager Error Code
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Config Manager User Config
Controller Timeouts
Creation Class Name
Description

Device ID

Device Map

Driver Name

Error Cleared

Error Description
Hardware Version
Index

Install Date

Last Error Code
Manufacturer

Max Data Width

Max Number Controlled
Max Transfer Rate
Name

PNP Device ID

Power Management Capabilities[]

Power Management Supported
Protection Management
Protocol Supported

Status

Status Info

System Creation Class Name
System Name

Time Of Last Reset

Connection Window Operation

PROXY Pro uses the following WMI Class to request/retrieve SCSI information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component

WMI Class

SCSI

Win32_SCSIController
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System Enclosure

System Enclosure provides you with a graphical view of settings for the system enclosure
for the remote Host computer system.

System Enclosure has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):

. Audible Alarm

° Breach Description

o Cable Management Strategy
° Caption

. Chassis Types|]

° Creation Class Name

° Current Required Or Produced
[ Depth

° Description

° Heat Generation

. Height

o Hot Swappable

o Install Date

o Lock Present

o Manufacturer

° Model

. Name

° Number Of Power Cords
° Other Identifying Info
o Part Number

° Powered On

° Removable

. Replaceable

U Security Breach

U Security Status

° Serial Number

. Service Descriptions|[]
o Service Philosophy[]

. SKU

] SMBIOS Asset Tag

] Status

. Tag

. Type Descriptions](]
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° Version
° Visible Alarm
° Weight
° Width
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve System Enclosure
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component WMI Class
System Enclosure Win32_SystemEnclosure
USB Ports

USB Ports provides you with a graphical view of settings for the universal serial bus for
the remote Host computer system.

USB Ports has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Availability

. Caption

° Config Manager Error Code
o Config Manager User Config
° Creation Class Name

. Description

. Device ID

o Error Cleared

. Error Description

] Install Date

o Last Error Code

[ Manufacturer

° Max Number Controlled

. Name

° PNP Device ID

J Power Management Capabilities[]
. Power Management Supported
° Protocol Supported

165



PROXY Pro Master Guide

] Status
o Status Info
. System Creation Class Name
. System Name
. Time Of Last Reset
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve USB information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class

USB Ports Win32_USBController

Video Controller

Video Controller provides you with a graphical view of settings for the video controller on
the remote Host computer system.

Video Controller has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Accelerator Capabilities|[]
o Adapter Compatibility

° Adapter DAC Type

L Adapter RAM

. Availability

. Capability Descriptions/]
. Caption

o Color Table Entries

] Config Manager Error Code
. Config Manager User Config
. Creation Class Name

o Current Bits Per Pixel

. Current Horizontal Resolution
o Current Number Of Colors

J Current Number Of Columns
J Current Number Of Rows

. Current Refresh Rate
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Current Scan Mode
Current Vertical Resolution
Description

Device ID

Device Specific Pens
Dither Type

Driver Date

Driver Version

Error Cleared

Error Description

ICM Intent

ICM Method

Inf Filename

Inf Section

Install Date

Installed Display Drivers
Last Error Code

Max Memory Supported
Max Number Controlled
Max Refresh Rate

Min Refresh Rate
Monochrome

Name

Number Of Color Planes
Number Of Video Pages
PNP Device ID

Power Management Capabilities|]

Power Management Supported

Protocol Supported

Reserved System Palette Entries

Specification Version
Status

Status Info

System Creation Class Name
System Name

System Palette Entries
Time Of Last Reset

Video Architecture

Video Memory Type

Connection Window Operation
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WMI Class

Video Mode
Video Mode Description

Video Processor

PROXY Pro uses the following WMI Class to request/retrieve Video Controller
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component

WMI Class

Video Controller Win32_VideoController

Video Monitor

Video Monitor provides you with a graphical view of settings for the video monitor
connected to the remote Host computer system.

Video Monitor has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):
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Availability

Bandwidth

Caption

Config Manager Error Code
Config Manager User Config
Creation Class Name
Description

Device ID

Display Type

Error Cleared

Error Description

Install Date

Is Locked

Last Error Code

Monitor Manufacturer
Monitor Type

Name

Pixels Per X Logical Inch
Pixels Per Y Logical Inch



Connection Window Operation

. PNP Device ID
° Power Management Capabilities[]
. Power Management Supported
° Screen Height
. Screen Width
] Status
° Status Info
. System Creation Class Name
. System Name
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Video Monitor information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class

Video Monitor Win32_DesktopMonitor

Software Manager

Software Manager provides you with a graphical view of the software applications that
are installed on the remote Host computer.
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Each software application has the following attributes (double-click on any service to get
a popup window with table of attributes and values):

. Identifying Number
o Product Name

] Manufacturer

. Product Version

° File Path

° Assignment Type

° Caption

° Description

° Install Date and Time
° Install State

J Help Link

. Help Telephone

. Install Source

° Language
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WMI Class

Connection Window Operation

Local Package
Package Cache
Package Code
Package name
Product ID

Reg Owner

Reg Company
SKU Number
Transforms

URL Info About
URL Update info

Source File Image Type (WordCount)

PROXY Pro uses the following WMI Class to request/retrieve information about software
applications installed on the remote Host computer:

Component

WMI Class

Products

Win32_Products

System Manager

System Manager provides you with a graphical view of various configuration settings on
the remote Host computer.
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= PROXY Pro Master
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€ Select "Computer System" to view details about system settings on remote Host
computer.

€ Select "Desktop" to view details about desktop on remote Host computer.

€ Select "Event Log Files" to view details about event log files system on remote Host
computer.

€ Select "Network Login Profile" to view details about network login profiles on remote
Host computer.

€ Select "Operating System" to view details about the operating system on remote Host
computer.

€ Select "Operating System Updates (QFE)" to view details about operating system
updates on remote Host computer.

€ Select "Page File" to view details about page file on remote Host computer.

€ Select "Page File Usage" to view details about current usage profile of page file on
remote Host computer.

& Select "Tasks Scheduled" to view details about current scheduled tasks for the remote
Host computer.

& Select "TCP/IP Settings" to view details about TCP/IP connections to the remote Host
computer.

€ Select "Time Zone" to view details about time-related settings for the remote Host
computer.

Computer System

Computer System provides you with a graphical view of system settings for the remote
Host computer system.
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Computer System has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):

° Name

. Admin Password Status

° Automatic Reset Boot Option
° Automatic Reset Capability
] Boot Option On Limit

o Boot Option On Watch Dog

° Boot ROM Supported

U Bootup State

° Caption

. Chassis Bootup State

. Creation Class Name

. Current Time Zone

. Daylight In Effect

. Description

. DNS Host Name

° Domain

o Domain Role

° Enable Daylight Savings Time
o Front Panel Reset Status

° Infrared Supported

. Initial Load Info

. Install Date

J Keyboard Password Status

J Last Load Info

] Manufacturer

o Model

U Name Format
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WMI Class

174

Network Server Mode Enabled
Number of Processors

OEM Logo Bitmap

OEM String Array

Part Of Domain

Pause After Reset

Power Management Capabilities
Power Management Supported
Power On Password Status
Power State

Power Supply State

Primary Owner Contact

Reset Capability

Reset Count

Reset Limit

Roles

Status

Support Contact Description
System Startup Delay

System Startup Options
System Startup Setting
System Type

Thermal State

Total Physical Memory

User Name

Wake Up Type

Workgroup



Connection Window Operation

PROXY Pro uses the following WMI Class to request/retrieve Computer System
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component WMI Class
Computer System Win32_ComputerSystem
Desktop

Desktop provides you with a graphical view of settings for the desktop on the remote
Host computer.

Desktop has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

. Name

o Wallpaper

. Cursor Blink Rate

° Icon Title Size

. Screen Saver Timeout
o Border Width

. Caption

U Cool Switch

. Description

. Drag Full Windows

. Grid Granularity

° Icon Spacing

o Icon Title Face Name
° Icon Title Wrap

° Pattern

] Screen Saver Active
o Screen Saver Executable
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WMI Class

Screen Saver Secure
Setting ID
Wallpaper Stretched

Wallpaper Tiled

PROXY Pro uses the following WMI Class to request/retrieve Desktop information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component

WMI Class

Desktop

Win32_Desktop

Event Log Files

Event Log Files provides you with a graphical view of currently available Event Log Files
for the remote Host computer.

Each Event Log File has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):
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Caption

Access Mask

Archive

Compressed

Compression Method
Creation Class Name
Creation Date

CS Creation Class Name
CS Name

Description

Drive



Eight Dot Three File name
Encrypted
Encryption Method
Extension

File Name

File Size

File Type

FS Creation Class Name
FS Name

Hidden

Install Date

In Use Count

Last Accessed

Last Modified

Log File Name
Manufacturer

Max File Size

Name

Number Of Records
Overwrite Outdated
Overwrite Policy
Path

Readable

Sources

Status

System

Version

Writeable

Connection Window Operation
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WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Event Log File information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class

Event Log Files Win32_NTEventLogFile

Network Login Profile

Network Login Profile provides you with a graphical view of currently available Network
Login Profiles for the remote Host computer.

Each Network Login Profile has the following attributes (double-click on any attribute to
get a popup window with table of attributes and values):

° Name

° Description

° Maximum Storage

° Account Expires

° Authorization Flags
] Bad Password Count
. Caption

] Code Page

. Comment

o Country Code

o Flags

° Full Name

° Home Directory

° Home Directory Drive
. Last Logoff

° Last Logon
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WMI Class

Logon Hours
Logon Server
Number of Logons
Parameters
Password Age
Password Expires
Primary Group ID
Privileges
Profile

Script Path
Setting ID

Units Per Week
User Comment
User ID

User Type

Workstations

Connection Window Operation

PROXY Pro uses the following WMI Class to request/retrieve Network Login Profile
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component

WMI Class

Network Login

Profile

Win32_NetworkLoginProfile

Operating System

Operating System provides you with a graphical view of settings for the Operating
System on the remote Host computer.

Operating System has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):

179



PROXY Pro Master Guide
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Caption

Manufacturer

Boot Device

Build Number

Build Type

Code Set

Country Name

Creation Class Name

CS Creation Class Name

CSD Version

CS Name

Current Time Zone

Data Execution Prevention Available
Data Execution Prevention 32 Bit Applications
Data Execution Prevention Drivers
Data Execution Prevention Support Policy
Debug

Description

Distributed

Encryption Level

Foreground Application Boost

Free Physical Memory

Free Space in Paging Files

Free Virtual Memory

Install Date

Large System Cache

Last Boot Up Time

Local Date Time



Connection Window Operation

Locale

Max Number of Processes
Max Process Memory Size
Name

Number of Licensed Users
Number of Processors
Number of Users
Organization

O0S Language

OS Product Suite

0S Type

Other Type Description

PAE Enabled

Plus Product ID

Plus Version Number
Primary

Product Type

Quantum Length

Quantum Type

Registered User

Serial Number

Service Pack Major Version
Service Pack Minor Version
Size Stored in Paging Files
Status

Suite Mask

System Device

System Directory

System Drive
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° Total Swap Space Size
] Total Virtual Memory Sizez
] Total Visible Memory
. Version
° Windows Directory
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Operating System
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component WMI Class

Operating System Win32_OperatingSystem

Operating System Updates (QFE)

Operating System Updates (Quick Fix Engineering) provides you with a graphical view of
updates applied to the Operating System on the remote Host computer.

Each Operating System Update has the following attributes (double-click on any attribute
to get a popup window with table of attributes and values):

. Name

° Caption

. CS Name

. Description
. Fix Comments
. Hot Fix ID

] Install date
o Installed By
° Installed On
° Service Pack In Effect
] Status
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Connection Window Operation

WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Operating System Update
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component WMI Class

Operating System

Updates (QFE) Win32_QuickFixEngineering

Page File

Page File provides you with a graphical view of the Page File for the remote Host
computer.

The Page File has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Name

° Access Mask

° Archive

° Caption

° Compressed

° Compression Method

. Creation Class Name

. Creation Date

o CS Creation Class Name
. CS Name

. Description

o Drive

o Eight Dot Three File name
° Encrypted

° Encryption Method

° Extension

° File Name
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° File Size

° File Type

° Free Space

. FS Creation Class Name

] FS Name

. Hidden

. Initial Size

o Install Date

° In Use Count

° Last Accessed

° Last Modified

[ Manufacturer

° Maximum Size

° Path

° Readable

. Status

. System

o Version

° Writeable
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Page File information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component WMI Class

Event Log Files Win32_PageFile

Page File Usage

Page File Usage provides you with a graphical view of the current usage profile of the
Page File for the remote Host computer.
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Connection Window Operation

Page File Usage has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Name
° Install Date
. Allocated Base Size
° Caption
. Current Usage
] Description
° Peak Usage
[ Status
° Temp Page File
WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Page File information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component WMI Class

Page File Usage Win32_PageFileUsage

Tasks Scheduled

Tasks Scheduled provides you with a graphical view of current scheduled tasks for the
remote Host computer.

Each scheduled task has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):

° Caption

] Command

o Days Of Month
° Days Of Week
J Description
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WMI Class

Elapsed Time

Installed Date

Interact With Desktop

Job ID

Job Status
Name

Notify

Owner

Priority

Run Repeatedly
Start Time
Status

Time Submitted

Until Time

PROXY Pro uses the following WMI Class to request/retrieve scheduled task information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component

WMI Class

Scheduled Tasks

Win32_ScheduledJob

TCP/IP Settings

TCP/IP Settings provides you with a graphical view of settings for TCP/IP connections to
the remote Host computer.

Each Event Log File has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):
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WMI Class

Description
Connectionless Service
Guarantees Delivery
Guarantees Sequencing
Install date

Maximum Address Size
Maximum Message Size
Message Oriented
Minimum Address Size
Pseudo Stream Oriented
Status
Supports Broadcasting
Supports Connect Data
Supports Disconnect Data
Supports Encryption
Supports Expedited Data
Supports Fragmentation
Supports Graceful Closing
Supports Guaranteed Bandwidth
Supports Multicasting

Supports Quality Of Service

Connection Window Operation

PROXY Pro uses the following WMI Class to request/retrieve TCP/IP Setting information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component

WMI Class

TCP/IP Settings

Win32_NetworkProtocol
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Time Zone

Time Zone provides you with a graphical view of time-related settings for the remote Host
computer.

Time Zone has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

o Caption

. Bias

° Daylight Bias

o Daylight Day

. Daylight Day of Week
° Daylight Hour

° Daylight Millisecond
. Daylight Minute

° Daylight Month

° Daylight Name

. Daylight Second

. Daylight Year

. Description

. Setting ID

. Standard Bias

] Standard Day

L Standard Day Of Week
[ Standard Hour

. Standard Millisecond
° Standard Minute

o Standard Month

J Standard Name

J Standard Second

J Standard Year

188



Connection Window Operation

WMI Class

PROXY Pro uses the following WMI Class to request/retrieve Time Zone information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component WMI Class

Time Zone Win32_TimeZone

Shared Resource Manager

Shared Resource Manager provides you with a graphical view of currently available
shared resources (Shares) and any current network users with connections (Sessions) to
the remote Host computer to access the shared resources.

2 PROXY Pro Master Mi=] E3

Jgjnnection ‘iew Options Goko Help

EEEEI

B j Remote Computer Management [WM| class Win32 Share]
Hardware Manager Caption Shared Falder Shared Path
Software Manager 2 Remote 1PC e
System Manager h-? Emate : ¥
o Shared Resource Managsr b=t Remate Admin ADMINE CHMIRDOWS
‘h';? Sessions k= Defaulk share Cf i
-- Account Manager
-- Service Manager
L@ Process Manager
[+ ! Registry Manager
-- Event Manager
j Power Manager
dl | o
Rermcte Cantrol _}H. File Transfer h Rerncte Printing ,]\Remnte Management IH'
For Help, press F1 E v

Shares

A shared resource can be a disk drive, printer, interprocess communication, or other
shareable device. Each shared resource has the following attributes (double-click on any
shared resource to get a popup window with table of attributes and values):

o Caption
° Shared Folder
° Shared Path
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. Comment
* Type
. Access Mask
. Allow Maximum
o Install date
. Maximum Allowed
] Status
Sessions

Each session has the following attributes (double-click on any session to get a popup
window with table of attributes and values):

° Active Time
° Caption
° Client Type
] Computer Name
. Description
° Idle Time
o Install Date
. Name
° Resources Opened
. Session Type
[ Status
. Transport name
° User Name
WMI Class

PROXY Pro uses the following WMI Classes to request/retrieve Shared Resource
information from the remote Host computer. Please consult these classes for more
detailed information about the specific attributes and values for Shares or Sessions.
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Component WMI Class
Shares Win32_Share
Sessions Win32_Session

Account Manager

Account Manager provides you with a graphical view of currently available user, group
and system accounts on the remote Host computer.
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Groups

Each group account has the following attributes (double-click on any group to get a
popup window with table of attributes and values):

. Name

J Caption

J Description
. Domain

. Install Date
. Local
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Account

. SID

. SID Type
] Status

System Accounts

Each system account has the following attributes (double-click on any system account to
get a popup window with table of attributes and values):

. Name

° Caption

° Description

. Domain

o Install Date
o Local Account
. SID

] SID Type

[ Status

Users

Each user account has the following attributes (double-click on any user to get a popup
window with table of attributes and values):

. Name

o Domain

° Account Type
. Description
J Caption

° Disabled

° Full Name

° Install Date
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° Local Account
° Lockout
. Password Changeable
° Password Expires
° Password Required
. SID
. SID Type
] Status
WMI Class

PROXY Pro uses the following WMI Classes to request/retrieve account information from
the remote Host computer. Please consult these classes for more detailed information
about the specific attributes and values available for each account type.

Component WMI Class

Groups Win32_Group
System Accounts Win32_SystemAccount
Users Win32_UserAccount

Service Manager

Service Manager provides you with a graphical view of currently available services and
system drivers on the remote Host computer.
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Services

Each service has the following attributes (double-click on any service to get a popup
window with table of attributes and values):

. Service Name

. Display Name

o Accept Pause

. Accept Stop

. Check Point

. Creation Class Name
. Description

° Desktop Interact
o Display Name

° Error Code

° Exit Code

° Install Date
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Connection Window Operation

Path Name

Process ID

Service Specific Exit Code
Service Type

Started

Startup Type

Start Name

State

Status

System Creation Class Name
LogOn As

Tag ID

Wait Hint

You can apply any of the following commands by right-clicking on any service and
selecting the command from the context menu:

Command Description

Start Start a service that is currently stopped

Stop Stop a service that is currently started

Restart Stop and then start a service that is currently started

System Drivers

Each system driver has the following attributes (double-click on any service to get a
popup window with table of attributes and values):

Name
Description
Path Name

Accept Pause
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° Accept Stop
° Display Name
] Creation Class Name
o Desktop Interact
° Caption
o Error Control
. Exit Code
o Install Date
° Service Specific Exit Code
. Service Type
° Started
° Start Mode
o Start Name
] State
] Status
] System Creation Class Name
o System Name
. Tag ID
WMI Class

PROXY Pro uses the following WMI Classes to request/retrieve Service and System
Driver information from the remote Host computer. Please consult these classes for more
detailed information about the specific attributes and values available for each service.

Component WMI Class
Services Win32_Service
System Drivers Win32_SystemDriver
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Process Manager

Connection Window Operation

Process Manager provides you with a graphical view of currently running processes on

the remote Host computer.
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Each process has the following attributes (double-click on any process to get a popup
window with table of attributes and values):

o Process ID

. Name

] Command Line

] Started

. Description

[ Executable Path
° Parent Process ID
U Session ID

° Priority

° Handle Count

. Thread Count
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Commands

You can apply any of the following commands by right-clicking on any process and
selecting the command from the context menu:

Kernel Mode Time

User Mode Time
Current Working Set
Minimum Working Set
Maximum Working Set
Peak Working Set

Page File Usage

Peak Page File Usage
Virtual Bytes

Virtual Bytes Peak
Read Operation Count
Write Operation Count
Other Operation Count
Read Transfer Count
Write Transfer Count
Other Transfer Count
Page Faults

Private Page Count

Command

End Process

WMI Class

PROXY Pro uses the following WMI Class to request/retrieve process information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available for each process.
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Connection Window Operation

Component

WMI Class

Process Scan

Win32_Process

Registry Manager

Registry Manager provides you with a graphical view of currently available Registry keys

on the remote Host computer.
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Registry keys are organized into the following hives:

¢ "HKEY_CLASSES_ROOT"
¢ "HKEY_LOCAL_MACHINE"
¢ "HKEY_USERS"

¢ "HKEY_CURRENT_CONFIG"

Each Registry key has the following attributes (double-click on any Registry key to get a
popup window with table of attributes and values):

. Name

. Type
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(] Data

Commands

You can apply any of the following commands by right-clicking on any Registry key and
selecting the command from the context menu:

Command Description

Delete Delete an existing registry key

Modify Modify attributes of an existing registry key
New > Key Create a new registry key

New > String Value

Specify String Value for a new registry key

New > Dword Value

Specify Double Word Value for a new registry key

New > Expanded String

Specify Expanded String Value for a new registry key

Event Manager

Event Manager provides you with a graphical view of the Application, Security and
System logs kept on the remote Host computer.
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Event Logs

A Windows computer records events in three kinds of logs:

€ Application Log: The application log contains events logged by applications or
programs. For example, a database program might record a file error in the application

log. Program developers decide which events to monitor.

& Security Log: The security log records events such as valid and invalid logon
attempts, as well as events related to resource use such as creating, opening, or deleting
files or other objects. An administrator can specify what events are recorded in the
security log. For example, if you have enabled logon auditing, attempts to log on to the

system are recorded in the security log.

€ System Log: The system log contains events logged by Windows system
components. For example, the failure of a driver or other system component to load
during startup is recorded in the system log. The event types logged by system
components are predetermined by Windows.

Event Records

Each event recorded in the logs has the following attributes (double-click on any event
record to get a popup window with table of attributes and values):

. Event Type

° Time Generated
° Source name

. Category

° Event Code
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WMI Class

User

Computer Name
Logfile

Message

Category String
Data

Event Identifier
Insertion Strings
Record Number

Time Written

Type

PROXY Pro uses the following WMI Classes to request/retrieve event log information
from the remote Host computer. Please consult these classes for more detailed
information about the specific attributes and values available for each event record.

Component

WMI Class

Application Log

Win32_NTLogEvent

Security

Log

Win32_NTLogEvent

System Log

Win32_NTLogEvent

Power Manager

Power Manager provides you with a graphical view of power management options on the
remote Host computer.
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Jgannecticln Wiew Opkions Goto Help

Connection Window Operation

=] B3

wPsE O

= j Remoke Compuker Managemenk
i, Hardware Manager
Software Manager

Sywskem Manager

Shared Resource Manager
Ig Account Manager

-- Service Manager

- Process Manager

- ! Reqiskry Manager

-- Event Manager

El ‘j Power Manager

{8 Power Summary

: j Shut Down Manager
[~ Power Scheme Manager

[+]-

Power Manager

Marne

k:? Pawer Surmmary
3} Shut Down Manager
j Power Scheme Manager

Remate Contral }\ File Transher }\ Rernote Printing }\Remute Management lﬂr

For Help, press F1

8

€ Select "Power Summary" to view summary of current power settings on remote Host

computer.

€ Select "Shutdown Manager" to view options to shutdown, reboot or logoff current

console user on remote Host computer.

& Select "Power Scheme Manager - XP" to view and edit power scheme settings for
various users on remote Host computer running Windows XP or Windows Server 2003.
In general, each user account has its own power scheme.

€ Select "Power Scheme Manager - Vista/Win7" to view and edit power scheme settings for
remote Host computer running Windows Vista, Windows 7 or Windows Server 2008. In
general, the computer has a single power scheme that applies to all the user accounts on

the system.

Power Summary

Power Summary provides you with a graphical view of the current power settings for the

remote Host com puter.
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& PROXY Pro Master Connection

ngunnectiu:un Wiew Options Goto  Help

Y EEIG)

= j Remate Computer Management
|-, Hardware Manager

4 Software Manager

Swstem Manager

Shared Resource Manager
Account Manager

Service Manager

-j Power Manager
: ‘:gi’ Power SUmmary

-j Shut Down Manager
B ! Power Scheme Manager

Power Summary
Display Marme

Display Yalue

[WhI class PowerSummary]

er Bukkon Present
\.?Sleep Butkon Present
"}Lid Present
TQSIeep state 51 Supported
\.?Sleep state 52 Supported
k:?ShEED state 33 Supported
T;Sleep state 54 (hiberbate) Supported
\\?Sleep state 55 Supported
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L:;LIF‘S Present
\.?Disk Spin Down Supported
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False
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False
Falze
False
True
False
False
Falze
Crline
&7
3600

Remote Control }\' File Tranzfer }\ Femnote Printing }.'Remnte Management l{[

For Help, press F1

8 »

Power Summary has the following attributes:

o Power Button Present

. Sleep Button Present

. Lid Present

o Sleep state S1 Supported
o Sleep state S2 Supported
o Sleep state S3 Supported
° Sleep state S4 (hibernate) Supported
° Sleep state S5 Supported
° Wake Supported

° Video Dim Supported

] APM BOPS Present
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. UPS Present

° Disk Spin Down Supported
. Batteries Are Present

. Batteries Are Short Term
° Hybrid Sleep Supported

] AC Status

° Current Idle Level

° Idle Time Remaining

Power Management Structure

PROXY Pro uses the following Power Management Structure to request/retrieve power
capabilities of the remote Host computer. Please consult this structure for more detailed
information about the specific attributes and values available.

Component Structure

Power Management Structures System_Power_Capabilities

Shutdown Manager

Shutdown Manager provides you with a graphical view of the options available to
shutdown, reboot or logoff the console user from the remote Host computer.
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g AKIM - PROXY Pro Master Connection (Trial Yersion)

ngunnectiu:un Wiew Options Goto  Help

Y EEIG)

b=

= j Remate Computer Management
Hardware Manager
i Software Manager

@] system Manager
[+ Shared Resource Manager
% Account Manager

Service Manager
Process Manager
| Registry Manager
Ewent Manager
E| j Power Manager

{87 Power Summary

4

! Power Scheme Manager

Shut Down Manager

System Shut Down Options

Log OFf Console User

Restart Computer

Shutdown Computer |

Power OFf Compuker

[ Force operation: performs operation immediakely

1

| B

Remote Control }\' File Tranzfer }\ Femnote Printing }.'Remnte Management l{[

For Help, press F1

8 »

Commands

You can apply any of the following commands to the remote Host computer by clicking on

the corresponding button:

Command

Description

Log Off Console
User

Stop current session for logged on user on remote
Host computer

Shutdown Computer

Shutdown remote Host computer

Restart Computer

Shutdown and restart remote Host computer

Power Off Computer

Shutdown and power off remote Host computer

Select the Force operation option to make the selected command apply immediately and

without response from logged on user.

Power Scheme Manager - XP
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Power Scheme Manager - XP provides you with a graphical view of the current settings
for power schemes for various user accounts on a remote Host computer running
Windows XP or Windows Server 2003.

In general, power settings on Windows XP or Windows Server 2003 fall into one of 3

categories:

€ Global settings which apply across the system

@ User account-specific settings defined in a power scheme

¢ User account-specific settings not defined in a power scheme

Note: Changes to power settings will not take affect until after current user logs out and

logs back in.

Global Settings

If Power Scheme Manager detects any global power settings, a Global node will appear
under Power Scheme Manager in the navigation tree. If this Global node is selected, a
list of global power settings and their current values will be presented:

& PROXY Pro Master Connection

Jgonnectinn Wieww  Ophions Goto  Help

EY EE)

= j Remate Computer Management
il, Hardware Manager
Software Manager

Syskem Manager

Shared Resource Manager
g Accounk Manager

-- Service Manager

- Process Manager

' Reqgistry Manager

+ - Ewvent Manager

B-  Power Managet

3? Power Summary

¢ Shut Down Manager

| Power Scheme Manager

o

-

i | Fax

- GLOBAL

'Ol S

ettings For: GLOBA

Save Settings |

l

Walue:

forF

Rermate Control }\ File Transfer }\ Remaote Printing )\Remole Management fr

For Help, press F1

| Setting | Plugged In [ Global | O Batter
b | Hibernation enabled

& 4

To edit a global setting, highlight the setting and select a value from the dropdown box
that appears at the bottom. An asteric will appear in the first column next to any values

that have been changed. Click the Save Settings box to apply the changes.

User Account Settings - Not in Power Scheme
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Some power settings are user account-specific but are not defined in power schemes. To
view/edit these settings, click on a user account node in the navigation tree under Power
Scheme Manager and a list of these settings will appear.

& PROXY Pro Master Connection

Jgonnection Wiew Options Goto Help

LEHEE O

B _,5 Remate Computer Management
+ Hardware Manager
Software Manager
[@] system Manager
&= Shared Resource Manager
% Account Manager
Service Manager
Process Manager
#-_| Redqistry Manager
Event Manager
B- '§ Power Manager
; ",; Fower Summary

“- g Shut Down Manager
! Pawer Scheme Manager

| fax

0 Adminiskr skar

L8 Home/OFfice Desk
Partable/Laptop
Presentation

Always On

Minimal Power Managem:
Max Batkery

Saye Sethnas Apply Settings To All Users |

I Setting I Plugged In | Global I On Batter
Require a password on wakeup an {1
Lid close action Standbey Skandbey
Piower butbon ackion Shukdown Shutdown
Sleep bukton action Standbey Skandbey
Critical batkery level I
Critical battery alarm enable on A
Critical battery action Hibernate A
Critical battery display message on A
Critical battery sound alatm OFfF A
Low battery level 10 % A
Low battery alarm enable on A
Low battery action Do Mathing A
Low battery display message on A
Low battery sound alarm Off A

Yalue: I 3
b
« | _»lJ d | r
Rernote Contral }\ File TramzFer )\ Rermate Printing }\ Remote Management jr
Far Help, press F1 E v

Any changes to these settings can be applied just to the selected user account (Save
Settings) or to all user accounts (Apply Settings to All Users).

User Account Settings - Power Scheme

Under each user account node, a list of default and custom power scheme configurations
will appear. Click on one of these schemes to view/edit the settings:

208




& PROZY Pro Master Connection

Jgonne-:tic-n View Options Goto Help
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| uPpEw O

= j Remote Computer Management

: Hardware Manager

Software Manager

System Manager

= Shared Resource Manager

g Account Manager

- Service Manager

- Process Manager

- Registry Manager

- Evenk Manager

B j Power Manager
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_'5 Shut Down Manager

! Power Scheme Manager

| fax
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Partable/Laptop
Presentation
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i P Max Battery
H- ) GLOBAL

Apply Settings To All Users
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) Delete Duplicate
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Al Users
These setkings apply only ko this user
I Setting I Plugged In { Global I Cn Batker:
Turn off hard disks after 0 Seconds 1500 Seconds

Turn off monitor after 1200 Seconds 900 Seconds
Sleep after 0 Seconds 0 Seconds
Pluggedin: | 1zo0 On Battery:  [anp
These settings apply to all users of this scheme
| Setting | Pluaged In | Global | on Bakker
Hibernate after 0 Seconds 0 Seconds

< |

Femote Control }\ File Transfer }\ Remote Printing )\Remnle Management f"

Far Help, press F1

B

Power scheme settings are divided into two subgroups:

& Power scheme settings that apply only to this user account

& Power scheme settings that apply all user accounts that use this power scheme

You can view/edit settings in either subgroup as described above.

Commands

You can apply any of the following commands to the power scheme by clicking on the

corresponding button:

Command

Description

Active Scheme

Make this the active power scheme for this user
account

Activate Scheme for
All Users

Make this the active power scheme for all user
accounts on this system
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Delete Scheme Delete this power scheme from this user account

Create a new custom power scheme with the same

Duplicate Scheme
values

Power Scheme Manager - Vista/Win7

Power Scheme Manager - Vista/Win7 provides you with a graphical view of the current
settings for power schemes on a remote Host computer running Windows Vista or
Windows 7.

In general, the computer has a single power scheme that applies to all the user accounts
on the system.

Power Scheme Settings

Under the Power Scheme Manager node, the system name will appear. Under this node,
a list of default and custom power scheme configurations will appear. Click on one of
these schemes to view/edit the settings:
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g PROXY Pro Master Connection =] E3
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Power Saving Mode
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Sleep after
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Hibernate after

Allow Standby States
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Lid close action
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Start menu power butkon

Link State Power Management
Processor power CState settings
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Processor power PerfState settings
Maximum processor state

Power Savings Mode
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Sleep
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OFf

High performance
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High Performance
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I
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Sleep
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High Performance
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For Help, press Fi

To edit a power scheme setting, highlight the setting and select a value from the
dropdown box that appears at the bottom. An asteric will appear in the first column next
to any values that have been changed. Click the Save Settings box to apply the changes

to this power scheme

Commands

You can apply any of the following commands to the power scheme by clicking on the

corresponding button:

Command

Description

Active Scheme

Make this the active power scheme for this system

Delete Scheme

Delete this power scheme from this system

211




PROXY Pro Master Guide

Duplicate Scheme
values

Create a new custom power scheme with the same

Menu options

The following table describes menu commands and, in some cases, their equivalent tool
bar icons in the PROXY Pro Master Connection Window. The menu items and icons that

display depend on which tab you select.

Tool
Menu Command bar
icon

Description

Connection Properties

Opens a window that
displays the information
about the remote
connection.

Disconnect a

Closes a connection to
one or more of the PROXY
Pro services to the remote
Host computer. If you
choose Remote Control,
the Master Connection
Window closes.

Begin
Recording

Starts a recording of the
screen display of the
remote Host computer.
The Master must connect
to the Host through a
Gateway to enable
recording.

Stop
Recording

Stops a recording of the
screen display of the
remote Host computer.
The completed recording
will be accessible on the
Gateway through which
the Master connected to
the Host.

Add to
Favorites

Adds the Host computer to
which you are connected
to the Favorites list on the
PROXY Pro Master
console window.
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Add to
Cycling
Monitor
Hosts

Connection Window Operation

Adds the open Host
computer (from the
Remote Control tab on the
Master Connection
Window) to the Cycling
Monitor Hosts list on the
PROXY Pro Master
console window.

Reboot Host

Restarts a remote Host
computer running DOS or
Windows 3.1. Use the
Start > Shut Down
command to reboot remote
Host computers running
later versions of Windows.

Exit

Terminates the connection
to the current Host and
closes the Master
Connection Window.

Edit

Input =
Control '“3

Gives keyboard and
mouse control of the Host
computer to the remote
user of a PROXY Pro
Gateway-managed
connection.

Send
Keystroke &

Sends a predefined key
combination to the Host
computer as though it
were entered on the
keyboard of the remote
Host computer when you
are connected to it for
remote control. This is
useful for sending special
key combinations such as
CTRL-ALT-DEL.

Request
Screen
Refresh

Sends command to remote
Host computer to refresh
screen capture.

Auto-Share %

Clipboard

Automatically copies the
contents of the clipboard
between the remote Host
computer and the local
computer when you view
the Remote Control tab.

Get
Clipboard i,‘
from Host

Copies the contents of the
clipboard on the remote
Host computer to the
clipboard on your local
computer when you view
the Remote Control tab.
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Send
Clipboard to
Host

Copies the contents of the
clipboard on your local
computer to the clipboard
on the remote Host
computer when you view
the Remote Control tab.

Copy Host
Screen

Copies a selected region
of the Host computer
display in the Master
Connection Window to the
clipboard on your local
computer from the
Remote Control tab.

214

View

Menu Bar

Toggles whether the menu
bar is displayed in the
Master Connection
Window.

Tool Bar

Toggles whether the tool
bar is displayed in the
Master Connection
Window.

Page Header

Toggles whether the
heading is displayed in the
Master Connection
Window.

Toggles whether tabs are

Tabs displayed in the Master
Connection Window.
Toggles whether the status

Status Bar bar is displayed in the
Master Connection
Window.

Remote Toggles whether the

Control Remote Control tab is

Page displayed.

File Transfer
Page

Toggles whether the File
Transfer tab is displayed.

Remote Toggles whether the
Printing % Remote Printing tab is
Page displayed.
Remote Toggles whether the
Management Remote Management tab
Page is displayed.

Scales the image of the
Fit to @, | Host computer display to
Window fit the size of the

Connection Window.




Fit 1-to-1 el

Connection Window Operation

Specifies that one pixel of
the Host computer display
corresponds to exactly one
pixel on the display of the
local computer.

Full Screen E-

Displays the screen output
from the remote Host
computer using either the
entire desktop or the
current monitor screen on
the local computer. To
return to the local
computer display, click the
Full Screen button on the
floating palette, or press
F11 in the Master
Connection Window.

Open Chat

Window =

Opens a Chat window in
which text messages can
be sent to Host and to any
other Masters connected
to that Host.

Options

Keyboard
Mapping

Opens the Keyboard
Mapping window, which
lets you define the key
combinations that you can
enter on the local
computer to initiate
keystrokes on the Host
computer.

Connection

Window

Settings

Displays the Connection
Window Settings dialog,
which contains settings for
various tabs in the Master
Connection Window.

Suppress
Host Mouse
& Keyboard

Check Suppress Host
Mouse & Keyboard
option from the Remote
Control tab of Master
Connection Window to
request that the remote
Host computer mouse and
keyboard be disabled. If
this request is granted, the
user at the remote Host
computer cannot operate
that computer when you
connect to it through
PROXY Pro Master. You
maintain exclusive control
throughout your Master
Connection Window.

GoTo

Remote

Control )

Page

Makes the Remote
Control tab active.
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File Transfer
Page

Makes the File Transfer
tab active.

Eﬁrr?t?rt\e % Makes the Remote
9 Printing tab active.
Page
Eﬂzwgtiment Makes the Remote
9 =] Management tab active.
Page
. Opens the PROXY Pro
Help Help Topics Master online help system.
Proxy Opens the Proxy Networks
Networks home page in a browser
Home Page window.
Check for Opens a web page with

Updates and
Maintenance

information about recent
updates and new releases

Releases of Proxy software.
Purchase Opens a web page to
Additional purchase license(s) for
Licenses PROXY Pro Master.

Order Opens a web page to
Technical purchase Maintenance &
Support Support contracts from
Contract Proxy Networks.

PROXY Pro information for PROXY Pro
Master

Master.
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PROXY Pro screen recordings can be played back in a Playback window that pops up as
a separate window from PROXY Pro Master.

The following elements in the window provide information about the playback you are
watching:

€ The Title bar displays the name of the managed Host on which you recorded screen
activity, followed by the date and time of the recording.

@ The Slider represents the playback in process. To go to an earlier or later part of the

playback, click and drag J-to another position on the slider.

€ The Time increments field displays the following measurements in xx:YY:ZZ, where
X represents hours, Y represents minutes, and Z represents seconds.

+ Elapsed Time indicates how much of the recording has played.
+ Out of indicates the total time of the recording.

¢ The Playback area plays the recording.

~g= SUPPORT 1/28/2015 6:01:44 PM via SUPPORT - PROXY Pro Master Playback

Connection Edit View Options Help

+

O Y B-e@%E = s

“ Elapsed Time: 00:00:07 out of: 00:00:07

| 2}

Recycle Bin

E

procdump

Proxy-w8-0-,..

In

Proxy-vw8-0-...

SUPPORT_C...

For Help, press F1
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Tool bar options

Table below summarizes the functions of icons available on the tool bar for the Playback
window:

Icon Function
} Resumes a paused playback.
I Pauses the playback.
[} Plays back the recording at half the speed of
the original activity.
] Plays the recording.
H‘ Plays back the recording at twice the speed

of the original activity.

Kb Plays back the recording at triple the speed
of the original activity.

@I Closes the Playback window.

Displays the screen output from the remote
Host computer using either the entire
desktop or the current monitor screen on the

EE j local computer. To return to the local
computer display, click the Full Screen
button on the floating palette, or press F11 in
the Master Connection Window.

Scales the image of the Host computer
+I:I+ | display to fit the size of the Connection
Window.

Specifies that one pixel of the Host computer

display corresponds to exactly one pixel on
the display of the local computer.

Copies a selected region of the Host
o computer display in the Master Connection
L Window to the clipboard on your local
computer from the Playback window.

Go to the Playback Window Settings tab to
modify the display settings for the Playback

218



Playback Window Operation

window.

[+

Exports the recording from the proprietary
PRXREC format to WMV.
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Playback options

Recordings can be played back from the following source locations:

& From the PROXY Pro Gateway, which streams the recording in real-time over a
network connection to the Playback window.

¢ From a PROXY Pro recording file that has been saved with the . PrxRec extension to
the local drive.

€ From any standard web server, which streams the recording in real-time over HTTP or
HTTPS to the Playback window.

Play a recording from the PROXY Pro Gateway
To play a recording from the PROXY Pro Gateway:
1 Select the recording you want to play.

2 Right-click the recording and choose Play Recording or choose Connection > Play
Recording from the menu.

The Playback window opens and the recording begins to play.

Zonneck

Conneck Special »
Conneck to YMC Server...

Send 'Wake-Cn-LAKN Signal

Recard, .,
Stop Recording

Play Recording
Delete Recording

Expark Recarding

Add to Favorites
add|te Cyeling Monitor Hasts

Save As Shortouk
Properties

Play Recording From Eile. ..

Play Recording wia LURL. ..

Exit

Play arecording from alocal disk file

By default, recordings are stored by the PROXY Pro Gateway at a location configured by
the Gateway Administrator (which may or may not be accessible through a network
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share). If recordings are moved to another machine, you can use PROXY Pro Master to
play that recording locally:

1 Choose Connection > Play Recording from File... from the menu. Find recording in the
explorer window that pops up

2 Click Open and the Playback window will pop up and start playing the recording.

Playback Recording File E

Look in: | () {36505AF6-9FFF-46C5-9F9E-E3B44BCSE701 | &= (&) £ ER)-

by Documents

™

by Computer

File name: ITest Recarding PreRec j Open

Cancel |
F

Filez of type: IHeu:u:urding Files

Play a recording from a web server

By default, recordings are stored by the PROXY Pro Gateway at a location configured by
the Gateway Administrator (which may or may not be accessible through a network
share). If recordings are moved to a location accessible by a standard web server, you
can use PROXY Pro Master to play that recording via standard URL.:

1 Choose Connection > Play Recording via URL... from the menu. Find recording in the
explorer window that pops up

2 Click OK and the Playback window will pop up and start playing the recording.
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Enter URL |

Please enter the URL of the recording file you wish to play:

I http:f{prozoywebservert Test Recording. prarec

Ik I Cancel

The following syntax can be used to specify the URL of the recording file you wish to
play:

® http://<webservername>/<recordingfile.prxrec> (default port is
8080)

® http://<webservername:port>/<recordingfile.prxrec>
® https://<webservername>/<recordingfile.prxrec>

€ https://<username.password@webservername>/<recordingfile.prxrec>

If URL is specified using HTTPS, the Master will attempt to validate the server's
certificate, and will display a warning dialog if the certificate has any errors.

If server requires authentication, and no username or password is specified in the URL,
the Master will present the current logged on user's credentials to the webserver; if the
default credentials are not accepted, a username/password dialog will appear.

Recordings played via URL or from a local file store will appear in the Master's History
tab and can be added to the Favorites tab. From either location, they can be played
again, deleted or exported (and converted to .wmv format).

Note the following limitations:

Note: If the server has a certificate error, the error action (i.e. to accept the certifcate) is
not stored in History or Favorites. The only way to export a recording from URL with a
certificate error is from within the Playback window.

Note: Playback via URL does not have access to metadata about the recording, i.e.
workstation ID, user name, date/time started, etc., so those fields are blank in the
properties dialog. The exception is duration, which is shown by default.

Play a recording using command line utility

The Playback window can be invoked by using the Master command line with following
syntax:

® proxy.exe /g"<Gateway>" /r"<sessionID>" (GUID sessionID of
recording)

® proxy.exe <recordingfile.prxrec> (recording file in local file
store)
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® proxy.exe http://<webservername:port>/<recordingfile.prxrec>
(recording file accessible via URL on webserver)

The standard command line options "/u<username>" and "/x<password>" can be used to
provide specific credentials if default credentials of current logged-on user are no
sufficient. See "Command line syntax examples" for more information.
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Playback window settings

To control the display of the PROXY Pro Master Playback window, choose Options >
Playback Window Settings to open the Playback Window Settings tab.

Default Playback Window Settings

Playback. |

]|

— Yiewer Setktings

[~ Full Screen

% Fit ko window
" Fit 1-to-1

—Auko-scroll

v Cursor (text-mode anly)

[+ Maouse (bext & graphics modes)

— D05 Sessions

Font: IF'ru:uxy Bx14 -
k. I Carnicel Apply Help

The settings in this window are for viewing, scrolling, and displaying a recording

playback:

& Viewer Settings determine how activity on a remote computer is displayed.

+ Full Screen displays the playback using the entire monitor screen on the local

computer.

+ Fit to window scales the image of the playback to
Master Playback window.

fit the size of the PROXY Pro

+ Fit 1-to-1 specifies that one pixel of the playback corresponds to exactly one

pixel on the display of the local computer.

+ Select Halftone to improve the quality of the display when the Master is in Fit to

Window mode.

224



Playback Window Operation

Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.

Select these options from the View menu and toolbar icons, k|- = .

€ Auto-scroll settings determine if the window scrolls when the cursor or mouse reaches
a boundary.

+ Cursor (text-mode only) - automatically scrolls when the cursor comes to an
edge of the Playback Window when you hold the CTRL key down.

+ Mouse (text & graphics mode) - automatically scrolls when the mouse comes to
an edge of the Playback Window when you hold the CTRL key down.

€ The DOS Sessions setting determines the Font that the Master uses when it displays a
DOS session on the Host. Each choice consists of combination of two elements, typeface
and point size.
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Recording properties
View the properties of a recording from two windows:
4 In the PROXY Pro Master window, right-click a recording and choose Properties.

4 In the Playback window, choose Connection > Properties.

FORD 2,2 /2006 3:49:22 PM Properties 5[

Connechion

—Gakteway Recording

Start Time: | 2}2}2006 3:49:22 PM

Durakion: I 1 rin

Workskation IO I {5DF2E7FO-432C-4393-9098- 2866 3448565L

I=er: I Administratar

Recording kKey: I {12EE2B26-C510-4600-9656-364 2EFEG4651

Filename: I Z:\Program Files\Funk Software|Proxy Gatet
Size (Bytes): | 4405
Started By: I BEMELLIN&dminiskrator

Gateway, ., |

] I Cancel | Apply | Help |

The following properties of a recording are listed in the Connection tab.
Start Time

Duration

Workstation ID

User

Recording Key

Filename

Size (Bytes)

Started By

L IR 2B 2R 2R 2B R JNE NN 2

Gateway
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Gateway properties

To record screen activity on a Host, the Host must be connected to a PROXY Pro
Gateway. When you view the properties of a recording and click Gateway, the properties
of the PROXY Pro Gateway that managed that connection are displayed.

Gateway Properties |

Connection | Connect e I

— Gakteway

Display Marme: I W5

Protocal; IUD'F'."IF' TI Port: I-::Standard:: vI

Gateway Specifier: I 152.1.1.1

Station Mame: | WS

tetwork Address: I 152.1.1.1

[~ Use encryvption

Find Gatewary... |

k. I Carnicel Apply | Help |
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Delete options

To delete a recording from the Host Recordings list on the PROXY Pro Gateway, follow
these steps

1 Inthe Host Recordings list, select each recording that you want to delete.

2 Right-click and choose Delete Recording or choose Connection > Delete Recording
from the menu. The recording is removed from the Host Recordings list and deleted from
the PROXY Pro Gateway.

To delete a recording from a local drive, you must use Windows Explorer to find and
delete the . PrxRec file from the computer.
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Recording format options

From the PROXY Pro Master Playback window, you can convert a recording to Microsoft
.wmv format and save it to your file system.

From the Connection menu, select Export Recording

A Windows dialog box will appear to let you choose where to save the converted
recording. Once the conversion begins, a status box will appear to indicate when the
conversion is complete.

J’; Conversion complete !E |

Conwverking via Gateway 127.0.0.1
SessionlD: {7F2CD4DE-3BAC-4BCD-91D0-02F7EBS4EFS3}

|

Conversion completed successfully

Destination:
C\Documents and Sektingstadmini, . virkual-2008-01-02-16-09-10-372 \WHY

[ Close this dialog box when conversion is complete

Play Cpen Eolder
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Menu options

Table below describes menu commands and tool bar icons in the PROXY Pro Master

Playback window:

230

Tool
Menu Command bar Description
icon
. Disconnect; Closes the PROXY Pro
Connection Exit @' Master Playback window.
Export Exports the recording from
Recording 2 the proprietary PRXREC
to WMV format to WMV.
Copies selected region or
Edit gopy Host o, text to the clipboard on your
creen
local computer.
Toggles whether the menu
. bar is displayed in the
View Menu Bar PROXY Pro Master Playback
window.
Toggles whether the tool bar
Tool Bar is displayed in the PROXY
Pro Master Playback
window.
Toggles whether the position
Playback indicator is displayed in the
Position PROXY Pro Master Playback
window.
Toggles whether the heading
Page is displayed in the PROXY
Header Pro Master Playback
window.
Toggles whether the status
bar is displayed in the
Status Bar PROXY Pro Master Playback
window.
Scales the image of the
Fit to @, ‘ playback to fit the size of the
Window PROXY Pro Master Playback

window.




Playback Window Operation

Specifies that one pixel of
the playback corresponds to

Fit1-to-1 [ exactly one pixel on the
display of the local computer.
Displays the playback using
Full Screen [ j either the entire desktop or a
specific monitor on the local
computer.
Opens the Keyboard
Mapping window, which lets
you define the key
Options I&(;ybci)r?rd combinations that you can
pping enter on the local computer
to initiate keystrokes on the
Host computer.
Displays the Playback
\Ij\}ﬁnyc?:vcvk Window Settings dialog,
Settings which contains the settings
9 for the Playback window.
. Opens the PROXY Pro
Help Help Topics Master online help system.
Home Page Opens the PROXY Pro home
9 page in a browser window.
Proxy Opens the Proxy Networks
Networks home page in a browser
Home Page window.
Register Opens a web page that you
can use to register your copy
PROXY Pro of PROXY Pro Master.
Purchase Opens a web page from
which you can purchase your
PROXY Pro copy of PROXY Pro Master.
About Displays version number of
msoé:( Pro PROXY Pro Master.
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Cycling Monitor Window Operation

PROXY Pro Master Cycling Monitor allows you to serially check in on a list of Host

computers that you create on the Cycling Monitor Hosts tab of the PROXY Pro Master
window.

=2 PROXY Pro Master H[=]

Jgnnnectiu:un Edit ‘jew Options Goko Help

E358x-35
Cycling Monitor Hosts

LiLy B-Es
LD aohs

Display Mame Protocol Gakeray Metwork Address
bR Oy GATEWAY
=) SpPoRT lacal

SUPPORTZ lacal

Peer-to-Peer Hosts }-.. Gateway Hosts }-.. Active Connections }1. Histary }-.. Favorites hEycIing Monitor Hosts {r_
3 Hosts, 1 selected ‘,ﬁ

This window is similar to the PROXY Pro Master Connection Window, except that you
cannot remotely control any of the active remote connections from it. Instead, the PROXY
Pro Master Cycling Monitor window will start with the Host at the top of the Cycling
Monitor Hosts list, make a connection to that Host, display the Host screen for a
predetermined interval, and then move on to the next Host on the list.
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;-. PROXYGATEWAY via SUPPORT - PROXY Pro Master Cycling Monitor

Jg::unnecticun Edit Wiew Options Help

Je J¢-¢|Eﬂm|ﬂ:

For Help, press F1 |C|:unnecting ko next host in 4 seconds. ..

Note that a countdown of cycling span interval time remaining is displayed in the status
bar in the bottom right hand corner.

The following options are available for managing the Cycling Monitor window:
& “Cycling Monitor window settings”
¢ “Menu options”

NOTE: Depending on how PROXY Pro Host (or PROXY Pro Gateway) is configured,
your credentials may be restricted from monitoring one or more Host computers on your
cycling monitor list.

Tool bar options

Table below summarizes the functions of icons available on the tool bar for the Cycling
Monitor window:

Icon Function
e Closes the Cycling Monitor window.
= Change the Cycling Monitor window to show

the previous Host computer on the Cycling
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Monitor Hosts list.

Change the Cycling Monitor window to show
the next Host computer on the Cycling Monitor
Hosts list.

Displays the screen output from the remote
Host computer using the entire monitor screen
on the local computer. To return to the local
computer display, click the Full Screen button
on the floating palette, or press F11 in the
Master Connection Window.

Specifies that one pixel of the Host computer
display corresponds to exactly one pixel on the
display of the local computer.

Scales the image of the Host computer display
to fit the size of the Connection Window.

Copies a selected region of the Host computer
display in the Master Connection Window to

@ the clipboard on your local computer from the
Cycling Monitor window.
- Go to the Cycling Monitor Settings tab to
modify the display settings for the Cycling

Monitor window.
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Menu options

The following table describes menu commands and tool bar icons in the Cycling Monitor

window.

Menu

Tool
Command bar
icon

Description

Connection

Properties

Opens a window that
displays the information
about the remote
connection.

Connect to

Closes a connection to
one or more of the
PROXY Pro services to
the remote Host
computer. If you choose
Remote Control, the
Master Connection
Window closes.

Next Host =

Change the Cycling
Monitor window to show
the next Host computer
on the Cycling Monitor
Hosts list.

Previous
q:u

Host

Change the Cycling
Monitor window to show
the previous Host
computer on the Cycling
Monitor Hosts list.

Start
Cycling

Adds the Host computer
to which you are
connected to the
Favorites list on the
PROXY Pro Master
console window.

Stop
Cycling

Adds the open Host
computer (from the
Remote Control tab on
the Master Connection
Window) to the Cycling
Monitor Hosts list on the
PROXY Pro Master
console window.

Exit

Terminates the
connection to the current
Host and closes the
Master Connection
Window.
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Edit

Cycling
Monitor
Hosts

Gives keyboard and
mouse control of the Host
computer to the remote
user of a PROXY Pro
Gateway-managed
connection.

Copy Text
Screen

Copies selected text from
the Host computer
display in theMaster
Connection Window to
the clipboard on your
local computer from the
Remote Control tab.

Copy
Graphics
Screen

Copies a selected region
of the Host computer
display in the Master
Connection Window to
the clipboard on your
local computer from the
Remote Control tab.

View

Menu Bar

Toggles whether the
menu bar is displayed in
the Master Connection
Window.

Tool Bar

Toggles whether the tool
bar is displayed in the
Master Connection
Window.

Page Header

Toggles whether the
heading is displayed in
the Master Connection
Window.

Tabs

Toggles whether tabs are
displayed in the Master
Connection Window.

Fit to
Window

Displays the screen
output from the remote
Host computer using the
entire monitor screen on
the local computer. To
return to the local
computer display, click
the Full Screen button
on the floating palette, or
press F11 in the Master
Connection Window.

Fit 1-to-1

Specifies that one pixel of
the Host computer
display corresponds to
exactly one pixel on the
display of the local
computer.
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Scales the image of the
Host computer display to

Full Screen m fit the size of the
Connection Window.
Opens the Keyboard
Mapping window, which
lets you define the key
Options Keyboard combinations that you
Mapping can enter on the local
computer to initiate
keystrokes on the Host
computer.
Displays the Cycling
Cycling Monitor Settings dialog,
Monitor which contains settings
Settings for Cycling Monitor
window.
Opens the PROXY Pro
Help Help Topics Master online help
system.
Proxy Opens the Proxy
Networks Networks home page in a
Home Page browser window.
Check for Opens a web page with

Updates and
Maintenance

information about recent
updates and new
releases of PROXY Pro

Releases

software.
Purchase Opens a web page to
Additional purchase license(s) for
Licenses PROXY Pro Master.
Order Opens a web page to
Technical purchase Maintenance &
Support Support contracts from
Contract Proxy Networks.
PROXY Pro information for PROXY
Master

Pro Master.
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The command line from the Windows command prompt, Start > Run > cmd, can be used
to run PROXY Pro Master and manually perform any of the following tasks:

4 Use commands to set up connections to specific Host computers.

€ Use command line scripts to make connections to specific Host computers whose
configuration is specified in a shortcut file (a file with a .PRX4 extension).

€ Run a script to connect automatically to the remote Host computer with PROXY Pro
Master preconfigured.

& Specify a PROXY Pro Host recording file, with a .PrxRec extension, to be played in a
Playback Window.

The command line can also be used to manage configuration options, including the
following:

& Specify the Host computer in terms of address, port, and protocol.

€ Customize the title bar of the “Connection Window operation” that appears when you
make a remote connection.

& Provide the name of the shortcut file for opening connections.

The syntax for using the command line is as follows:

proxy.exe [/option"values"]|[ ShortCutFile | RecordingFile ]

With this syntax, follow the command proxy . exe with a sequence of configuration
option/value pairs (do not include brackets). Specify the option with a forward slash (‘/’)
followed by one letter. If you specify a value that has a space or a special character, the
value must be in quotes. Optionally, you can include the name of a shortcut file to specify
all other configuration parameters for the connection. The shortcut file extension must be
.PRX4. See “Command line options”.

The following is an example of the PROXY Pro Master command line syntax.

proxy.exe /PUDP /S198.186.166.124 MyShortcut.prx4

If you have created and specified a shortcut file called MyShortcut.prx4, use this
syntax to run MyShortcut . prx4 with its “Default Connection Window Settings”, and
open a connection to a remote Host computer at 198.186.166.124, using the UDP/IP
protocol and the standard port. All other configuration parameters are specified in the
shortcut file.

4 "Command line option values and syntax"

4 "Command line syntax examples”
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Command line options

Command line options can be used to customize your remote connection configuration.

All command line options consist of a one-letter option specification, preceded by a
forward slash (*/’). Follow each command immediately by a command value surrounded
by double quotes, with no space between the one-letter command and its value. If you do
not have any special characters such as blank spaces in your option values, you do not
have to use quotes.

Command options are not case-sensitive; for example, /W and /w are the same
command.

The command options are as follows:

€ /H opens a custom remote Host computer connection, but hides the PROXY Pro
Master console window when you open it. Note that /1 does not hide any instances of
PROXY Pro Master that are already open.

& /M starts a new instance of PROXY Pro Master, even if one is already open and
running.

& /P specifies the network protocol and nonstandard listening port required by your
remote Host computer.

@ /s specifies Host information. For a peer-to-peer connection, use this command to
specify the Host computer name or network address in the syntax required by the
protocol you choose. For remote connections through a PROXY Pro Gateway, use the
PROXY Pro Gateway syntax of this command to specify your Host computer key. See
“Connection tab”.

€ /G specifies the PROXY Pro Gateway to connect to for a remote connection. With this
option, you must also use the PROXY Pro Gateway syntax for /S to specify a Host
computer key associated with a Host computer. The specified PROXY Pro Gateway must
be configured to manage the specified Host computer.

€ /U specifies a user name that your remote Host computer or PROXY Pro Gateway
requires. You must configure PROXY Pro Host on your remote Host computer to accept
this user name (and corresponding password).

& /v specifies a DNS name or IP address of a VNC server to connect to for a remote
connection.

& /u specifies a title other than the default for the “Master Connection Window”.
€ /X provide a password for your remote connection.
€ <recordingfile.prxrec> specifies a local screen recording file to be played

€& <http://webserver:port/recordingfile.prxrec> specifies a screen
recording file located at a webserver to be played over HTTP (or HTTPS).

If you do not specify one or more of these connection options in a command line, PROXY
Pro Master relies on the connection values in the current PROXY Pro Master console
window, or the default configuration values if you have not yet configured the product.

Command line option values and syntax
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The values that you can assign to a command line option depend on the option. For
example, /H /M take no values.

The following values can be assigned to the other command line options as listed in table

below.

Comman

d Value(s) Notes or Syntax
For TCP/IP protocol. No quotes
required.

/P TCP For UDP/IP protocol. No quotes

(No F_’f(?rt ; UDP required.

ZE}‘;CI icatl IPX For IPX protocol. No quotes required.
The default (standard) port is
assigned in each case.

Syntax:
Protocol /P"Protocol name|Port num

/P name | port pair (see ber"

(With port above for the allowed Example:

specificati protocol name values). /P"TCP|5001"

The entire phrase is in . . .
on) quotes P The vertical bar is required as a
' separator for the protocol/port number
pair.
] Typically, the required format is
String value for username . , . .
/U in quotes /U”domain\user name”, asin
' /U”ACME\george”.
/% String value for the Example: /X" foo™"
password in quotes. ple:

/W tslttlgnlg \éigjtiéor the new Example: /W"Stock Traders"
When you specify the PROXY Pro
Gateway, you must also specify the
Host computer using the Host key

String value for the Gateway syntax for /S, as described
/G PRO?(Y Pro Gatewa for Gateway-managed connections.
name in quotes y When you specify the PROXY Pro
g ' Gateway and protocol (using /P), the
protocol applies between the local
PROXY Pro Master computer and the
PROXY Pro Gateway.
In quotes, the string value
for the station name, DNS
/s name, or network The peer-to-peer syntax depends on

address specifier for
peer-to-peer Host
computer connections.

your protocol specification.
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In quotes, the string value
for the station name, DNS

Examples:

/v name, or network /PTCP /V"192.168.160.138"
address specm_er for VNC /PTCP /V"Mac VNC Server"
server connections.

/PTCP Examples:

S " . . . "
/ network address /PUDP /S"192.168.160.138
or . /PTCP /S"jackson"

station name

/BUDE dns naﬁ; /PTCP

/8 — /S"jackson.acme.com"
@node Examples:

/PIPX @network:node /PIPX /SE@IB13DAEY

/S "Station name" /PIPX /S@20:lBl3DAE9
"het— /PIPX /S"Dell P200"
work:station name /PIPX /S"2:Dell

The Gateway syntax depends on the
managed Host specification:
Use u for a logged-in user, and w
(with curly braces) for a workstation.
In quotes, the string value NOTE: The u and w that you use
for the Host key for for the PROXY Pro Gateway
remote connections .
through a PROXY Pro syntax of /s are independent of
/S Gateway: the /U and /W commands.
& “w={host key}” To find the Host key, navigate to the
- managed Hosts tab of the PROXY
€ “u=host key” Pro Master console window. Select
the PROXY Pro Gateway and display
its list of managed Host computers.
Right-click the desired Host computer,
and select Properties. The Host key
displays.
Examples:
Gateway Name and /67 Gat 17
. ateway
Workstation Host
P Key Ton_rost /S"w={ 6F93DF16-8352-46EB-
ADDF-T7FD752EAT72FA}"”
or Gateway Name and
U — /G”Gatewayl™
ser Name
- /S”u=ACME\george"
Specify a GUID session ID of
recording on a Gateway to be played:
/R Gateway Name and

SessionID

/G”Gatewayl”
/R"{92E3970A-682E-4B93—-
B4A4-925F96EB9E85}"
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Command Line Configuration

Table below describes a set of full command-line calls.

Examples of syntax for command lines

Command

Explanation

proxy.exe /PUDP
/U"ACME\george" /X"foo"
/S"jackson.acme.com"

Opens both the PROXY Pro Master
console window and the PROXY Pro
Master Connection window,
connecting to a computer whose DNS
name is jackson.acme.com using
the UDP/IP protocol, valid username,
ACME\george, and password foo.

proxy.exe /PIPX /X"foo"
/S"Dell P200"

Uses the IPX protocol to connect to a
computer named Dell P200 with the
configured PROXY Pro Host password
foo.

proxy.exe /P"IPX|5001"
/S@20:1B31DAEY

Uses the IPX protocol to connect to a
computer on network 20 with IPX
address 1B31DAE9, using port 5001
and the local computer user credentials.
Note that to specify the port, you must
separate the protocol/port number pair
with a vertical bar | and put the entire
group in quotes.

proxy.exe /PTCP
/S8"192.168.160.138"

Uses the TCP/IP protocol to connect to a
remote Host computer with network
address 192.168.160.138, using
the local computer user credentials.

proxy.exe /PTCP /S"jackson"

Uses the TCP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials. All
other PROXY Pro Master console
window configuration parameters are
specified in the current configuration of
PROXY Pro Master.

proxy.exe /PTCP /S"jackson"
jackson.prx4

Uses the TCP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials. All
other PROXY Pro Master console
window configuration parameters are
specified in the PROXY Pro Master
shortcut file named jackson.prx4.

proxy.exe /PTCP /W"Jackson"
/Sjackson

Uses the TCP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials. The
resulting Connection Window is titled
jackson.
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proxy.exe /H /PUDP
/S"jackson™"

Uses the UDP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials, and
hides the PROXY Pro Master console
window for this connection.

proxy.exe jackson-2008-04-
24 .prxrec

Opens a Playback window to play the
recording file “jackson-2008-04-
24.prxrec" from local file store

Proxy.exe
http://MyIIS:8080/jackson-
2008-04-24.prxrec

Opens a Playback window to play the
recording file “jackson-2008-04-

24 prxrec” from webserver "MylIS" over
port 8080

proxy.exe /P"TCP|5900"
/V"Mac VNC Server"

Uses the TCP/IP protocol to connect to a
VNC server on a remote Host computer
with DNS name "Mac VNC Server".
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